StoreVirtual Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

P4000 VSA - weird Errors

Patrick Neuner
Regular Advisor

P4000 VSA - weird Errors

Hello,

 

we have this Configuration:

2 LH VSA Nodes (one on top of EVA 4100 and one on top of MSA P2000)

 

1 of those nodes was down for one day - after we brought it back online he started resyncing and in this process we got dozens of such alert mails:

 

Message            :      Cluster 'Cluster_LocalEVA' write space is 'Low'. Reduce I/O demand.  System is busy redistributing data.

Message            :      Cluster 'Cluster_LocalEVA' write space is 'Full'. Reduce I/O demand. NOW System cannot redistribute data.

Message            :      Cluster 'Cluster_LocalEVA' write space is 'Low'. Reduce I/O demand.  System is busy redistributing data.

Message            :      Cluster 'Cluster_LocalEVA' write space is 'Full'. Reduce I/O demand. NOW System cannot redistribute data.

........

 

 

Since there are a few houndret GB free on both nodes - why did we get those Errors? Can someone give me some insight into this?

 

Thank you

Andreas Schnederle-Wagner

 

4 REPLIES
cjs_serversup
Occasional Visitor

Re: P4000 VSA - weird Errors

Hi there, did you ever find a resolution to this at all please?  We've just had it on a P4500 cluster and it took out the look of them.

oikjn
Honored Contributor

Re: P4000 VSA - weird Errors

took out multiple nodes in a cluster?   Sounds like you are tyring to do something like full volume snapshots and that will suddenly generate a TON of demand on your usable space and could easily fill a cluster.

 

Do you have any full provisioned volumes?  If so, that is likely the cause.

M_C
Occasional Advisor

Re: P4000 VSA - weird Errors

We have started to see these errors on our cluster currently running SANIQ 11.5

 

The error appeared at 86% utlisation (3TB free space), with no schedueld snapshots at the time of the error. The SAN is under very low load as well.

 

Is this a known bug?

Patrick Neuner
Regular Advisor

Re: P4000 VSA - weird Errors

In our case we were told it is not a good idea to have a SAN below the VSA, and our setup was done because we had this equipment laying around but wanted the VSA features for remote snapshots for a hardware based Lefthand. For real live and fast accessible data we couldn't use it anyway because the performance was weak, again, as this seems to be an unsupported scenario and we had lot's of snapshots too.  The same error didn't happen on the hardware Lefthand even with 90 % usage. 

 

As we don't have this kind of setup with the SAN anymore (too many spindles and power usage for old equipment) unfortunatly I can't tell whats the reason. neither if it would have happened with a "supported" setup too. But by the time if I remember right it was Version 10 or 10.5 we had deployed, you have already 11.5, so somehow I doubt it could be related to the same problem we had. 

 

Do you have a support contract, usually HP could give out better infos when looking onto the setup. 

 

Patrick