StoreVirtual Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

P4300 upgrade from 8.1 to 9 fails

Andy_R
Frequent Advisor

P4300 upgrade from 8.1 to 9 fails

Hello,

I tried to upgrade two nodes from SAN/iQ 8.1 to 9 but after the first reboot the nades stop with a write error followed by a kernel panic. See attached screenshot for details on the errors.

After those errors I used the 8.5 recovery media to get one node back and then performed an upgrade from 8.5 to 9 without any problems.

Are there any known problems upgrading from 8.1 to 9 or is there a solution for my problem?

Regards,
Andy
2 REPLIES
Bryan McMullan
Trusted Contributor

Re: P4300 upgrade from 8.1 to 9 fails

Did you try rebooting again after the Kernel Panic? I received those on upgrades of old NSM160's in the past, but a power off then reboot seemed to clear it up.

I've upgraded 13 nodes so far to 9.0 and have yet to have a single issue, but I'm going from 8.5 to 9.0.

IIRC, the first reboot isn't really the upgrade they are upgrade prep patches.
Andy_R
Frequent Advisor

Re: P4300 upgrade from 8.1 to 9 fails

I tried powering off and rebooting the nodes but the kernel panic happened again.
Upgrading from 8.5 to 9 works fine. I'll test an upgrade again in a few days and see what else I can do.