StoreVirtual Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

SAN/IQ 8.1 to 9 fails with error: The desired software is not supported..

SOLVED
Go to solution
RalfH
Occasional Visitor

SAN/IQ 8.1 to 9 fails with error: The desired software is not supported..

Hi guys,

 

Hope you could help me out with this one.

 

I have a management group with two Nodes and a fail over manager. Last night I tried to update the nodes from 8.1 to 9.  The failover manager (ESX) is already running on version 9.0

 

CMC is already updated to the latest version. After starting the upgrade is stops after a couple of minutes with the error:

 

Installation failed. The desired software is not supported on the current platform/software (Exit Status 20).

 

When viewing the logfiles is can see this:

 

 

0:0:0:0 ,Starting upgrade server version 8

0:0:0:0 ,args[0] = 11120

0:0:0:0 ,args[1] = 192.168.100.1

0:0:0:0 ,args[2] = 144757682

0:0:0:0 ,args[3] = /etc/lefthand/upgrade-sync

0:0:0:0 ,args[4] = /mnt/lhnupgrade

0:0:0:0 ,Bound the socket OK, moving on...

0:0:0:0 ,Sending to the CMC: OK

0:0:1:86 ,Next line is from file.receiveName() it's xml(2 stage) or MD5(1 stage):

0:0:1:86 ,6cca8acc9939a8b89b404f8982250fe9

0:0:1:86 ,1 Stage Package: d:\Program Files\HP\P4000\UI\downloads\10098-00.20110107.patch: 1. Addresses potential growth in memory utilization of the SAN/iQ manager which can cause the storage node to become unresponsive; 2. Fixes an issue with multi-terabyte snapshots where some operations like snapshot delete or node resynchronization may result in severe performance degradation causing iSCSI and MPIO sessions to disconnect/reconnect continuously; 3. Addresses an issue when using the QLogic (QLE4062C) initiator HBA which can lead to failed sessions and excessive login/disconnect events; 4. Fixes the metadata repair utility; 5. Fixes volume inaccessibility and snapshot functionality issues that can occur in a mixed 8.5/9.0 cluster.

0:0:1:86 ,MD5 <6cca8acc9939a8b89b404f8982250fe9>

0:0:1:86 ,Sending to the CMC: OK

0:0:1:86 ,Sending to the CMC: Extracting the install file ...

0:0:1:87 ,Sending to the CMC: Preparing for installation of patch 10098-00 ... (Tue Aug 9 20:05:55 GMT 2011)

0:0:1:87 ,Sending to the CMC: ERROR: This patch is NOT for SAN/IQ version 8.1.00.0047, patch failed!

0:0:1:87 ,In ProcessLine. getting error: INSTALL_STATUS_MESSAGE: done [20]

0:0:1:87 ,Sending to the CMC: INSTALL_STATUS_MESSAGE: done [20]

0:0:1:87 ,Sending to the CMC: Completed installation 3.

0:0:1:87 ,Cleaning up in the finally...

0:0:1:87 ,Calling System.exit() with value: 0

 

And the other file says this:

 

Installation process started on: 9-8-11 22:34

Installation process ended on: 9-8-11 22:45

Hostname: HP1.tevreden.local

IP Address: 192.168.100.71

Software Applied

10054-04 - Successful

10098-00 The file was not installed. - Failed

9.0.00.3561.0 The file was not installed. - Failed

10054-04 The file was not installed. - Failed

10060-02 The file was not installed. - Failed

10090-00 The file was not installed. - Failed

20031-00 The file was not installed. - Failed

20040-00 The file was not installed. - Failed

Hostname: LH-FOM1

IP Address: 192.168.100.83

Software Applied

10054-04 - Successful

Hostname: HP2.tevreden.local

IP Address: 192.168.100.72

Software Applied

10054-04 - Successful

10098-00 The file was not installed. - Failed

9.0.00.3561.0 The file was not installed. - Failed

10054-04 The file was not installed. - Failed

10060-02 The file was not installed. - Failed

10090-00 The file was not installed. - Failed

20031-00 The file was not installed. - Failed

20040-00 The file was not installed. - Failed

 

What could be the problem? The Failovermanager already running on version 9? Should I upgrade the nodes to 8.5 first?

 

Any help would be appreciated.

 

Kind regards,

 

Ralf

 

4 REPLIES
Michael Paul_3
Occasional Visitor
Solution

Re: SAN/IQ 8.1 to 9 fails with error: The desired software is not supported..

Hi because I had this exact same issue and basically no replies, but a bunch of views, I wanted to share what I found out to solve the problem.  Basically I called HP Storage, and they put the Management Console into a maintenance support mode.  By editing a special preferences.txt file with some custom text they provided.  This allowed them to bypass the various checks in the software on a 'regular' upgrade and successfully perform the update.  After we finally upgraded to version 9, I then did a software check and there were even some post 9 hotfixes.  Also applied those, which took another hour to two hours to complete.  A bunch of hoops to jump through, but in the end, we're on the latest build.  Hope this helps anybody else who might have the same error. 

 

Emilo
Trusted Contributor

Re: SAN/IQ 8.1 to 9 fails with error: The desired software is not supported..

I guess the first question wold be is are you at all the required firmware? It is critical that you are at the minimum firmware requirements. You can find the firmware updates here,http://h20272.www2.hp.com/Pages/spock2Html.aspx?htmlFile=hw_iscsi.html&lang=en&cc=us&hpappid=hppcf
The doucment name is "P4300 & P4500 Firmware Compatibility Matrix'

 



You can also check this document, it does show you can go from 8.1 to 9 on page 3

http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c01886197/c01886197.pdf

 

Supported upgrade paths
Direct upgrades to release 9.0 can be performed from the following released versions.
• Version 8.5
• Version 8.1
• Version 8.0
If you are upgrading from version 7.0, SP1, the upgrade first applies the version 8.1 upgrade before
upgrading to release 9.0.

 

I also need to ask if you have any Network RAID 5 or 6 volumes?

Patch 10098 is for a specfic problem that involves Network RAID 5 or 6 volumes.

 

Hope this helps somewhat but more information is needed.

 

 

RalfH
Occasional Visitor

Re: SAN/IQ 8.1 to 9 fails with error: The desired software is not supported..

Hi Guys,

 

Thanks for the awnsers. I managed to update the system to 9 the following way.

 

I've looked at the updates.xml file and saw that a couple of upgrade pathes were possible to avoid the 10098 update. One of them was updating to 8.5. The 10098 update is only for LH 8.5, and that's the reason why my upgrade to 9.0 directly didn't work. Afther the upgrade to 8.5 the update to 9.0 was no problem.

 

So the reason why the update from 8.1 to 9.0 didn't work was due to a error in the update.xml file by wanting to aply a patch for a non supported OS.

Frank Verstraten
Frequent Advisor

Re: SAN/IQ 8.1 to 9 fails with error: The desired software is not supported..

Got exactly the same problem. Is it only HP who can help or is there an other way to get this update working.

I don't want to go trough the 8.5 upgrade because of all the time it costst.