StoreVirtual Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

SRA v9.5 problem??: SRM test fails to create snapshot

SOLVED
Go to solution
JasonD
Advisor

SRA v9.5 problem??: SRM test fails to create snapshot

Hello all,

 

I'm building an SRM 5 lab around the LeftHand VSA (SANIQ v9.5, SRA v9.5) as are a few people it would seem.  I've configured SRM, the SRA, discovered the replication relationship, setup protection groups, recovery plans etc.   All good.   

 

I can do the following:

 

  • Perform a failover.
  • Perform a reprotect.
  • Perform a failback. 

All works as advertised.   However, performing a failover test isn't working; the test fails when the trying to create a writable snapshot (step 4); this is irrespective of whether I force a data sync or not (which seems to spawn another snapshot and replication task on the LH).   

 

I've dug into this and run the command.pl from the LH SRA in debug mode and collected the output, using the SRM-generated XML input files that are left in the SRM bin directory.   The full log is attached, but the critical part is below:

 

12/18/2011 12:25:25.513 +11:00 2404 VERBOSE Verifying Snapshots on Volume Replica-PROD-VMFS-1. Verifying complete snapshots from Remote Schedule.
12/18/2011 12:25:25.513 +11:00 2404 VERBOSE Verifying snapshot 'PROD-VMFS-1_Sch_RS_1_Rmt.142'
12/18/2011 12:25:25.513 +11:00 2404 VERBOSE Snapshot is remote
12/18/2011 12:25:25.513 +11:00 2404 VERBOSE Snapshot md5 match
12/18/2011 12:25:25.513 +11:00 2404 VERBOSE Snapshot has schedule
12/18/2011 12:25:25.513 +11:00 2404 VERBOSE Snapshot is complete
12/18/2011 12:25:25.513 +11:00 2404 VERBOSE Verifying snapshot 'PROD-VMFS-1_Sch_RS_1_Rmt.141'
12/18/2011 12:25:25.513 +11:00 2404 VERBOSE Snapshot is remote
12/18/2011 12:25:25.513 +11:00 2404 VERBOSE Snapshot md5 match
12/18/2011 12:25:25.513 +11:00 2404 VERBOSE Snapshot has schedule
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Snapshot is complete
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Verifying snapshot 'PROD-VMFS-1_Sch_RS_1_Rmt.140'
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Snapshot is remote
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Snapshot md5 match
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Snapshot has schedule
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Snapshot is complete
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Verifying snapshot 'HP.P4000.SRA.Remote.Snapshot**8b6b20c1fe02ecd9a508da60f5f145f0*PROD-VMFS-1238820254*Created*634597718585036250'
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Snapshot is remote
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Snapshot md5 match
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Snapshot doesnt have schedule
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Snapshot is complete
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Verifying snapshot 'HP.P4000.SRA.Schedule*Reverse*9536b23cc1050a819c4f155b0d51d0af**Created*634597706850607500_Pri.1'
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Snapshot is primary
12/18/2011 12:25:25.529 +11:00 2404 INFO Reviewing incomplete snapshots on Volume Replica-PROD-VMFS-1
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Finding latest snapshot for Replica-PROD-VMFS-1 volume.
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Looking at snapshot PROD-VMFS-1_Sch_RS_1_Rmt.142.
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Looking at snapshot PROD-VMFS-1_Sch_RS_1_Rmt.141.
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Looking at snapshot PROD-VMFS-1_Sch_RS_1_Rmt.140.
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Looking at snapshot HP.P4000.SRA.Remote.Snapshot**8b6b20c1fe02ecd9a508da60f5f145f0*PROD-VMFS-1238820254*Created*634597718585036250.
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Looking at snapshot HP.P4000.SRA.Schedule*Reverse*9536b23cc1050a819c4f155b0d51d0af**Created*634597706850607500_Pri.1.
12/18/2011 12:25:25.529 +11:00 2404 VERBOSE Latest snapshot is PROD-VMFS-1_Sch_RS_1_Rmt.142.
12/18/2011 12:25:25.545 +11:00 2404 INFO Creating a Smart Clone Volume on Snapshot PROD-VMFS-1_Sch_RS_1_Rmt.142.
12/18/2011 12:25:25.545 +11:00 2404 VERBOSE Executing Gauche command:
<gauche version="1.0">
<command method="cloneSnapshot" locale="en_US" snapshotName="PROD-VMFS-1_Sch_RS_1_Rmt.142" volumeName="HP.P4000.SRA.SmartClone*TestFailover*9536b23cc1050a819c4f155b0d51d0af*Replica-...D-VMFS-1-2147235137*N*Created*634598079255451250">
<login nsm="172.20.200.5" username="admin" password="***" />
</command>
</gauche>
12/18/2011 12:25:25.545 +11:00 2404 INFO Waiting to acquire global SRA lock.
12/18/2011 12:25:25.545 +11:00 2404 INFO Global SRA lock acquired. Executing task.
12/18/2011 12:25:25.560 +11:00 2404 VERBOSE Gauche response is:
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<gauche version="1.0" xmlns="http://www.hp.com/p4000/sra/v2">
<response description="Parameter VolumeName must be specified as parameter=value." name="CliqParameterFormat" processingTime="15" result="80001003" />
</gauche>
12/18/2011 12:25:25.560 +11:00 2404 INFO Gauche ERROR details - NAME:CliqParameterFormat CODE: 80001003 DESCRIPTION: Parameter VolumeName must be specified as parameter=value.
12/18/2011 12:25:25.560 +11:00 2404 WARNING Unabled to create a Smart Clone Volume for snapshot PROD-VMFS-1_Sch_RS_1_Rmt.142.
12/18/2011 12:25:25.560 +11:00 2404 INFO Attempting to assign Volume HP.P4000.SRA.SmartClone*TestFailover*9536b23cc1050a819c4f155b0d51d0af*Replica-...D-VMFS-1-2147235137*N*Created*634598079255451250 to a server.
12/18/2011 12:25:25.560 +11:00 2404 VERBOSE Executing Gauche command:
<gauche version="1.0">
<command method="getserverinfo" locale="en_US">
<login nsm="172.20.200.5" username="admin" password="***" />
</command>
</gauche>

 

Note that I have not licensed the VSAs and am using the 60 day trial license here, but as I understand it I should have full functionality for 60 days?

 

Anybody seeing similar problems??  

 

Thanks,

 

Jason D

3 REPLIES
Solution

Re: SRA v9.5 problem??: SRM test fails to create snapshot

Hey Jason,

 

I'm not sure it is the sasme problem but since it's about the same situation I'll give you this:

 

Right click on the Cluster and selet Registration. Then select "Feature Registration..." unde Registration Tasks. Go to Tab "Scripting Evaluation" and enable "I agree....".

 

I' had the same problem however I'm not sure it's the same error. It resolved my problem.

 

Knipsel2.JPG

Knipsel.JPG

JasonD
Advisor

Re: SRA v9.5 problem??: SRM test fails to create snapshot

Joris,

 

You were absolutely correct!  I didnt think so at first but after several attempts I realised that you need to tick that box before you create any volume replication schedules.  Once I did that, it worked perfectly.  

 

Anyway, what a stupid requirement for an evaluation ... grrrrrr.

 

Thanks for pointing me in the right direction...

 

Cheers!

 

JD

Rukam
Visitor

Re: SRA v9.5 problem??: SRM test fails to create snapshot

Hi Jason,

 

 

Please help me and tell me how did you run the command.pl in detail.

 

I couldn't understand this statement

 

ran command.pl from the LH SRA in debug mode and collected the output, using the SRM-generated XML input files that are left in the SRM bin directory

 

Any help with be appreciated

 

Thanks