StoreVirtual Storage
Showing results for 
Search instead for 
Did you mean: 

VSA 1TB weird License Problem

Occasional Visitor

VSA 1TB weird License Problem



I've succesfully registered & activated  2  VSA nodes on HP  webware site (free 1 TB licenses). 

The problem is:

-when I apply the license to either the VSA , everything is OK - all features registered, no errors.

-when I compose the CLUSTER from these two appliances,  the "violation" error arises and license information in storage system "Feature Registration" pane shows exclamation mark : "Not licensed for Multi-node Virtualiz. and Clustering (in violation in cluster <name>)".

I recon,  "free" HP VSA 1TB license assumes creating a cluster of max. 3  VSA's, so I  don't  "violate" any  lic. agreement.

Also, in  Management Group "Registration"  pane it shows a 60-day coutdown warning, regardless I did activate and install a 3-year  reg. keys for my both storage systems.



Does it some kind of "cosmetic" problem or maybe I don't realize smth.? 



P.S. This thread has been moved from General to HP StoreVirtual Storage / LeftHand. - Hp Forum Moderator


Re: VSA 1TB weird License Problem



This can occur due to the running Virtual manager...You can try these fixes:


  1. Stop and removing the virtual manager and then try.
  2. If nogo then restart the storage system and check.




Kindly click on Kudos if the post is helpful. .


To assign points on this post? Click the white Thumbs up below!
Occasional Visitor

Re: VSA 1TB weird License Problem

Hi, Prakash.


Thanx for your attention & reply .  Sorry,  I didn't describe my config (my miss),  but  we have a Failover Manager installed on a 3rd physical system.  So virtual manager is unneded and  even prohibited. But anyway to test your suggestion I 've disabled & removed Fail. Manager,  had installed & removed Virtual Manager,  and restarted all storage (both VSA's in management group). 

To clarify in a little the situation I've attached S/shots with weird warnings.


Thanks again.

Regards, Alex.

Honored Contributor

Re: VSA 1TB weird License Problem

are you applying the licenses before or after you join the management group?  try removing the liceses and re-adding.  Also, make sure you are using a static MAC address for each node as the license is tied to that MAC.

Occasional Visitor

Re: VSA 1TB weird License Problem

Hi, oikjn.

Thanx for your reply.


I've tried this move before,   i.e.  tried to apply the licenses in different ways.  No difference, nogo.

Also tried static assignments of MACs -nothing.

Some additional "interesting" facts:


- after restarting the storage appliances in vcenter license period "resets" and counts down again from 60-day mark,  i.e. "59 days, 23 hours, 11 minutes left...." regardless that the  VSA system was running for 10 days already before.

- if I  remove the storage system from cluster and then from management group, the license immediatly becomes "normal" (see that on a pic), and even with "Adaptive Optimization" (not capable when apllying 1TB lic.)


Found an interesting thread instead:


HP  is assumed  to "screw up" a little its "license machine" and their licenses had became "weird".  Maybe someone from HP will shed the light on this?



Re: VSA 1TB weird License Problem issued wrong 1TB VSA licenses, that resulted in the exact behavior you are mentioning. You are currently running your VSA cluster with the 60 days Instant-On licenses. I could confirm this in my lab.


The license issue was resolved early Friday morning. However, customers who have bad license keys will need newly generated keys. I.e. they need to reapply for free 1TB VSA licenses on


I did check in my lab, that applying newly generated licenses is solving the issue.

Any customer that is currently running with the bad licenses is actually running the VSA cluster with the 60-days Instant-On licenses. I.e. after running the VSA cluster for more than 60 days your access to the volumes will be blocked until you reapply newly generated license keys.


Sorry for any inconvienance.