Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

2 vlans - 1 connection to a cisco router

SOLVED
Go to solution
ssosa
Occasional Visitor

2 vlans - 1 connection to a cisco router

I am trying to get two vlans working on a procurve 2650 switch with ONE connection to a cisco 1841 router. No luck as of yet!

My configuration on the switch looks like this:

trunk 12 Trk5 Trunk
ip default-gateway 192.168.16.1
vlan 1
name "DEFAULT_VLAN"
untagged 1-9, 11,13-50,Trk5
ip address 192.168.16.2 255.255.255.0
no untagged 10
exit
vlan 5
name "vlan5"
ip address 192.168.76.2 255.255.255.0
tagged 10, Trk5
exit

My configuration on the cisco router looks like this:
interface FastEthernet0/0
ip address 192.168.16.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.5
encapsulation dot1Q 5
ip address 192.168.76.1 255.255.255.0

At this point, I have a PC on port 10 (vlan5) and it cannot ping the cisco router (192.168.76.1), which is on port 12.

Also, I notice that when I view the the port address table on the switch for port 10, nothing shows up.

Any ideas?

Thanks!

Sergio
2 REPLIES
Case Van Horsen
Frequent Advisor
Solution

Re: 2 vlans - 1 connection to a cisco router

First, a "trunk" on HP is an EtherChannel on Cisco. To allow multiple VLANs on an link, you just need to tag them on the HP side.

I think this will work:

1) Get rid of Trk5.
2) VLAN 5 should be tagged on port 12 and untagged on 10.

casevh
ssosa
Occasional Visitor

Re: 2 vlans - 1 connection to a cisco router

It works! Thanks casevh!

I definitely tried it without the Trk5. What I didn't try was setting port 10 as "untagged". My thinking was that I wanted anything on this port to be "tagged" because I knew that it would need to be "tagged" going out port 12 to the router. Does the "untagged" mean that what is coming in is "untagged"?

Thank you very much!

Sergio