Switches, Hubs, and Modems
Showing results for 
Search instead for 
Did you mean: 

2510g-48 crash after upgrade

Occasional Contributor

2510g-48 crash after upgrade

hi all.

after upgrade my 2510G-48 to version Y.11.16 my switch boot every 5 minute

i get this log error :
Crash msg: Software exception at exception.c:374 -- in 'tHttpd', task ID = 0x81e


BR Avi
Respected Contributor

Re: 2510g-48 crash after upgrade

kindly contact HP Support and log a case for this.

cenk sasmaztin
Honored Contributor

Re: 2510g-48 crash after upgrade

can you connect console port to switch

if you connect to switch with console port
please look at to flash with

#sh flash

command your switch in flash memory two partition
for examle

ProCurve Switch 5406zl# sh flash
Image Size(Bytes) Date Version
----- ---------- -------- -------
Primary Image : 7559045 05/06/09 K.13.63
Secondary Image : 6791094 11/24/08 K.12.62
Boot Rom Version: K.12.12
Default Boot : Primary

if you downlaod one partition new software you have to change boot partition

for example new OS version on partion primary and old OS version on secondary partition

you can change startup software version this command

(config)# boot system flash secondary

so that your switch get over wrong software version

after you can update older version on primary partition

good luck


Occasional Contributor

Re: 2510g-48 crash after upgrade

hi, i have the same problem, except that the error ocures only if i open a Browser session to the WebManagement site of the switch. Did you get an answer from hp? Which is the preferred firmware version to use?

Justin Birkhofer
Occasional Visitor

Re: 2510g-48 crash after upgrade

I had the exact same error today with my very first, new in box ProCurve 2510G-48 when I upgraded it from Y.11.12 to Y.11.16

Thankfully, I have a fix :-)

After I did the upgrade, it looked like this as does yours (most likely):

show flash
Image Size(Bytes) Date Version
----- ---------- -------- -------
Primary Image : 3376851 11/17/09 Y.11.16
Secondary Image : 3368329 07/16/09 Y.11.12
Boot Rom Version: N.10.02
Current Boot : Primary

Essentially, I configured my switch and among other things my config looks like this:

show running-config
; J9280A Configuration Editor; Created on release #Y.11.12

hostname "MY-HOSTNAME"
snmp-server contact "Our Department"
snmp-server location "BHS IDF 200 BLDG"
time timezone 300
time daylight-time-rule Continental-US-and-Canada
no web-management
web-management ssl
no telnet-server
ip default-gateway
sntp server
timesync sntp
sntp unicast
sntp 30
vlan 1
untagged 1-48
ip address
no snmp-server enable
ip ssh
no tftp server
loop-protect 1-48
loop-protect trap loop-detected
password manager
password operator

This is when the problem occurs (provided you also have a managment IP set). I was able to send HP a video replicating the crash.

Here is when the problem happens:
web-management ssl

I think the crypto keys are not compatible due to a software bug, but I will explain.

The Fix:

First, boot your switch into the Rom Monitor mode and boot the secondary (hopefully still Y.11.12 is in Secondary).

To do this, hold down Reset and Clear at the same time it will power cycle and keep holding until the test light blinks rapidly. Release reset while holding clear until the Test led goes out. Then release clear. I hope I said that right; it usually takes a few tries ;-)

You will get to a boot ROM prompt and see =>

Type "jp 2" and press enter

=>jp 2

Your switch will boot the secondary and not crash.

Enter the following to turn off all certificates and write mem to save:

no ip ssh
no web-management
write mem

(At this point, the switch can boot Y.11.16 without crashing, but it still has bad/broken cyrpto certificates)

Also at Global Config:

crypto key zeroize

Use the ? mark. I cannot remember the exact commands, but zeroize both the SSH and the SSL certificates (they are stored separately of the configuration).

Now, cross your fingers and type:

MY-SWITCH# boot system flash primary

It should boot Y.11.16 and not crash.

Now, you need only re-generate your SSL and SSH certificates.

Then when you type:

web-management ssl
ip ssh

The switch should not crash.

When I was talking with HP today about this issue, I bounced back and forth a dozen times between Y.11.12 and Y.11.16 booting the primary/secondary switching back and forth. Essentially to troubleshoot, I deleted my entire configuration:

erase start-config after I was back in Y.11.12 and noticed my switch no longer crashed when I would boot Y.11.16.

However, as soon as I would run

web-management ssl (and set a management IP on vlan 1) it would instantly crash and then reboot fine because I did not save the config.

Interestingly enough, it remembered my password even with the config reset, and unlike the first time I set it up, I was never prompted/required to generate crypto keys, so I knew they were stored separately of the configuration much like the password is not in the configuration.

This caused me to speculate the switch probably worked when HP tested it, but probably does not like something stored separately of the config that has to do with web-management ssl.

I totally cleared the crypto keys then generated new ones in Y.11.16 and have not had a crash since.

Good Luck. :-)
Todd Saettele
Occasional Visitor

Re: 2510g-48 crash after upgrade

I had a similar problem and Justin's helpful post (thank you) about turning Web-Management off worked but we had to leave it off. I called support and Vince was very helpful as well and although he had not heard of this problem he did dig around and got back to me with the following:

We have identified a cause for this issue. The switch stacking feature is currently causing the issue. The current work around is to disable stacking or back rev to Y.11.12. The Y.11.19 code I sent you does not fix the issue. The next release of the Y.11.x code will contain the fix.

Ivan Kuznetsov
Frequent Advisor

Re: 2510g-48 crash after upgrade


Have similar problem: switch firmware crashes when someone tries to login via web-browser.

Log shows:
Saved crash information:
TLB Miss: Virtual Addr=0x0000000a IP=0x805e2168 Task='tHttpd'
Task ID=0x81e81810 fp:0x00000000 sp:0x81e816d8 ra:0x8024ce58 sr:0x1000fc01
(registers values may be different)

Mostly we administer switches via command line so I turn off the web interface
with 'no web-management' command.

Is the previous firmware release (Y.11.12) free of this bug?

Regards, Ivan
Ivan Kuznetsov
Frequent Advisor

Re: 2510g-48 crash after upgrade

Did not read the entire post of Justin, sorry for the last question

Thank you!