Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

25xx not forwarding BPDU frames (STP)

Jeff Allen_5
Valued Contributor

25xx not forwarding BPDU frames (STP)

I have a 2512 with 2 links plugged into an HP Proliant GbE2 switch (same vlan). I left the 2512 to the default of STP disabled and left STP enabled on the GbE2. I expected to see the GbE2 disable one of the ports connected to the 2512 as soon as it received its own BPDU back. However, it doesn't and eventually causes a loop.

The reason this is a Procurve issue and not a GbE2 issue is because if I take a patch cable and loop the same 2 ports on the GbE2 switch, it does indeed block one of the ports. This tells me that the Procurve is not forwarding the BPDU packets it is receiving when STP is disabled. This is not the way it should be - these 2 features (forwarding BPDU's and disabling STP) should not be mutually exclusive.

Is this a bug? Thanks for any feedback
12 REPLIES
Ralph Bean_2
Trusted Contributor

Re: 25xx not forwarding BPDU frames (STP)

Jeff -

There was a fix for a problem like this in Switch 2512 firmware F.05.05. What version of f/w are you running?

Regards,
Ralph
Jeff Allen_5
Valued Contributor

Re: 25xx not forwarding BPDU frames (STP)

I am running version F.05.17, so I guess it isn't really fixed?

Stuart Teo
Trusted Contributor

Re: 25xx not forwarding BPDU frames (STP)

Hi,

I did an experiment with a setup like the one below

+-----------+
| |
2524 2524
| |
+-----------+

One of the 2524 running 5.17 has RSTP turned on, the other has RSTP turned off. The one with RSTP turned on recognized the loop immediately and blocked the port.

I then changed the version to STP and it still blocked correctly. The 2524 without STP turned on DID forward the BPDUs.
If a problem can be fixed, there's nothing to worry. If a problem can't be fixed, worrying ain't gonna help. Bottom line: don't worry.
Stuart Teo
Trusted Contributor

Re: 25xx not forwarding BPDU frames (STP)

OK that diagram didn't come out right. Let's try this one:

2524
| |
| |
| |
| |
2524
If a problem can be fixed, there's nothing to worry. If a problem can't be fixed, worrying ain't gonna help. Bottom line: don't worry.
Stuart Teo
Trusted Contributor

Re: 25xx not forwarding BPDU frames (STP)

OK, this drawing ought to do it.
If a problem can be fixed, there's nothing to worry. If a problem can't be fixed, worrying ain't gonna help. Bottom line: don't worry.
Ardon
Trusted Contributor

Re: 25xx not forwarding BPDU frames (STP)

Hi,

I am pretty sure that the 25XX DOES forward BPDU's even with STP/RSTP disabled. I will test this tomorrow when back into the office as follows.

25XX (STP ON)===25XX(STP Off)====25XX(STP On)

If you theory is right I would end up with two instead of one Root as they would not see eachother right?

What happens if you set up the same senario but using two times 25XX?

I will let you know my results tomorrow.

Regards, Ardon

I will let you know

ProCurve Networking Engineer
Ardon
Trusted Contributor

Re: 25xx not forwarding BPDU frames (STP)

Hi Hwee Liang Teo,

Sorry I did not not read you post correctly as it confirms my idea as well (that 25XX DOES formward BPDU's even with STP disabled). Shame on me:-(

Can we get an Ethereal Trace of the BPDU's sent out by the HP Proliant GBE2 Switch?

Thanks, Ardon
ProCurve Networking Engineer
Jeff Allen_5
Valued Contributor

Re: 25xx not forwarding BPDU frames (STP)

I will send a trace when I get the equipment again - it will be a week or 2. You are correct in the theory, however - both GbE2's did think they were root when STP was disabled on the 25xx. When STP was enabled, all worked fine.
Ardon
Trusted Contributor

Re: 25xx not forwarding BPDU frames (STP)

Jeff,

Please also send me the used config of the 25XX and GbE2. I do not want to be a pain but normally speaking you enable STP on all switches or was this simply something you noticed as we have STP Disabled by default.
My collegue tested my poposed setup this morning so:

25XX(STP on)===25XX (STP Off)====25XX(STP On)

and did NOT end up in a looped environment caused by two STP Root Switches. I wonder what is so special on these BPDU's from the GbE2. I understand you reasoning and want to find out where things go south.

Regards, Ardon
ProCurve Networking Engineer
Ardon
Trusted Contributor

Re: 25xx not forwarding BPDU frames (STP)

Jeff,

Sorry forgot. Where you using a Management VLAN (and if so which VLAN ID) on the 25XX.

Ardon
ProCurve Networking Engineer
Jeff Allen_5
Valued Contributor

Re: 25xx not forwarding BPDU frames (STP)

I didn't set the MGMT vlan on the 25xx from what it defaults to. I didn't even assign it an ip address. The only reason I did not enable STP on it was because the GbE2 supports PVST+ and the 25xx supports just mono-STP. So, I don't want the whole port blocked (as opposed to just one vlan) byt the 25xx finding a loop. In this confgiuration, the BPDU frames are supposed to just flow through the 25xx and the GbE2 switches should be able to make the loop decisions. I will post more when I get it.
Stuart Teo
Trusted Contributor

Re: 25xx not forwarding BPDU frames (STP)

Reviving an old thread. I have the below setup:



5308 e.8.42 RSTP
|
|(vlan2)
|
4000 c.9.16 STP-off
|
|(vlan3)
|
5308 e.8.07 RSTP


It's interesting to note that both the 5308 think that they are root, suggesting that the 4000 isn't passing BPDUs. the VLAN shouldn't matter since the BPDU multicast frames would breach that partitioning, wouldn't it?
If a problem can be fixed, there's nothing to worry. If a problem can't be fixed, worrying ain't gonna help. Bottom line: don't worry.