Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

2610 Routing

Daniel Marriott
Occasional Advisor

2610 Routing

Hi,

I am trying to connect two subnets using a 2610-24/12 power switch.

I have set up two VLANs -
VLAN1 has port (26) and VLAN2 contains all other ports. Port 26 is connected to one subnet in another building on 192.168.140.0/24 and VLAN2 is subnet 192.168.141.0/24. I have enabled IP ROUTING.

Config:
; J9086A Configuration Editor; Created on release #R.11.04

hostname "HP2 - ProCurve 2610-24/12PWR"
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 26
ip address 192.168.140.238 255.255.255.0
no untagged 1-25,27-28
exit
vlan 2
name "141_VLAN"
untagged 1-25,27-28
ip address 192.168.141.254 255.255.255.0
exit


The client on VLAN2 has a DG of the VLAN2 ip (192.168.141.254). It can ping VLAN1 IP and VLAN2 IP but not ping anything else on VLAN1 (192.168.140.0/24). From the router, I can ping both subnets and clients on both subnets. Clients on either subnet cannot see each other.

Can anyone suggest where I am going wrong?

Thanks.

11 REPLIES
Mohieddin Kharnoub
Honored Contributor

Re: 2610 Routing

Hi

The problem i guess not in Vlan2 Client, its on your Vlan1 Clients,

Check their gateway ?

Good Luck !!!
Science for Everyone
Yan Henrichon
Frequent Advisor

Re: 2610 Routing

Hi Daniel. Here is the config you will have to do.

At the config level, enter the following route:

ip route 192.168.141.0/24 192.168.140.254

If your vlan 2 needs to go to the other swtch, you will have to do this:

config
vlan 2
tagged 26
write memory.

hth... Yan
cenk sasmaztin
Honored Contributor

Re: 2610 Routing

hi Daniel
please check ip routing enable on switch
and check pc default gateway address

when connect pc on vlan interface that time running routing operation on switch

please attach pc each vlan
and assign ip address

for example

pc1*** for vlan1***(int 26)
ip address 192.168.140.10
subnet mask 255.255.255.0
default gateway 192.168.140.238

pc2***for vlan2***(int 1)
ip adress 192.168.141.10
subnet mask 255.255.255.0
default gateway 192.168.141.254

and retest ping between pc

cenk
cenk

Daniel Marriott
Occasional Advisor

Re: 2610 Routing

Hi All,

thanks for your suggestions. I have connected two machines in to VLAN1 and VLAN2 as suggested with the appropriate IPs and DGs of the VLAN's switch IP address:
VLAN1= 192.168.140.238
VLAN2= 192.168.141.254

From the PC on VLAN1, I can ping the switch (both VLAN IPs) and the client on VLAN2 (192.168.141.1)
On the PC on VLAN2, I can not ping the client on VLAN1 (I can ping both VLAN IPs assigned on the switch).

The routing and VLAN setup are as below (I have added one more port to the VLAN1):

hostname "HP2 - ProCurve 2610-24/12PWR"
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 25-26
ip address 192.168.140.238 255.255.255.0
no untagged 1-24,27-28
exit
vlan 2
name "141_VLAN"
untagged 1-24,27-28
ip address 192.168.141.254 255.255.255.0
exit
password manager
password operator

HP2 - ProCurve 2610-24/12PWR# show ip route

IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
127.0.0.0/8 reject static 0 250
127.0.0.1/32 lo0 connected 0 0
192.168.140.0/24 DEFAULT_VLAN 1 connected 0 0
192.168.141.0/24 141_VLAN 2 connected 0 0

Any more advice would be greatly appreciated.

Thanks.
cenk sasmaztin
Honored Contributor

Re: 2610 Routing

please check
for vlan 1 pc connect int 25
for vlan 2 pc connect int 24

and

assing ip address for pc

vlan 1 pc
ip address 192.168.140.10/24
default gateway 192.168.140.238


vlan 2 pc
ip address 192.168.141.10/24
default gateway 192.168.141.254

cenk
cenk

cenk sasmaztin
Honored Contributor

Re: 2610 Routing

and please shutdown local firewall (windows firewall)on each pc

cenk
cenk

Yan Henrichon
Frequent Advisor

Re: 2610 Routing

I was going to say the same thing: turn off windows firewall (or else) on both pc.

hth... Yan
Daniel Marriott
Occasional Advisor

Re: 2610 Routing

Hi,

I have set up this test environment and it is working correctly as you suggested. I can contact both machines between the subnets and I have the default gateway of the HP switch set to the IP of the ISA server which is giving me internet access. Thanks for your help getting this to work.

Last question (hopefully). This switch is connected to other UNMANAGED switches on the 192.168.140.0/24 network via port 26. I cannot ping any PCs which are plugged into those switches, including the ISA server which I am successfully using to browse the internet. All PCs have MS Windows firewall enabled but I can usually ping clients without issue.

Thanks,

Daniel.
Daniel Marriott
Occasional Advisor

Re: 2610 Routing

Hi - I have this all sorted now.

Thanks for all your help it really is appreciated.

Daniel.
Yan Henrichon
Frequent Advisor

Re: 2610 Routing

Hi Daniel. Make sure you close the thread. Also, if you found that the help provided in this post was helpful, please set points accordingly to the relevance of the post.

Thank You.
Daniel Marriott
Occasional Advisor

Re: 2610 Routing

Hi All - I'm closing the thread as requested and have allocated the points.
Thanks again for your help - hopefully this will help others too.
Daniel.