Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

2900-48G IP Address problem

SOLVED
Go to solution
ThurstonCollege
Occasional Visitor

2900-48G IP Address problem

Hi All
having a problem with a switch, I have just upload T13.71 to it which was ok, just tried to set the IP Address from DHCP to manual using CLI and it keeps coming up with invalid Subnet mask, i know the subnet is valid.

what i am trying to enter is;
under "Switch configuration - Internet (IP) Service
IP Routing: Disabled
Default Gateway: 10.164.64.1
Default TTL: 64
Arp Age: 20
IP Config: Manual
Ip Address 10.164.64.113
Subnet Mask: 255.255.248.0

when i try to save it, it comes up with 2Invalid IP Subnet Mask"

Any help would be greatly appreciated.
2 REPLIES
Jeff Carrell
Honored Contributor
Solution

Re: 2900-48G IP Address problem

Are you simply typing:

(config)# vlan 1
(vlan-1)# ip address 10.164.64.113 255.255.248.0

and getting the error?

Only thing I can think of is the switch has another IP addr on a different vlan that overlaps that space.

hth...Jeff
ThurstonCollege
Occasional Visitor

Re: 2900-48G IP Address problem

Hi Jeff

I was trying to do it through the web interface and also through the CLI, didnt selec the VLAN though.

In the end i resulted in downloading the config script via the web interface and manually changing it and then uploading it again to get it to take. which has worked. very strange though! cheers for your help.