Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

2900 to Dlink PoE VLAN Setup Help

Colonelk
Frequent Advisor

2900 to Dlink PoE VLAN Setup Help

Hi,

I want to set-up a fairly simple VLAN to segregate voice and data traffic on the network. The "data" network will be on 192.168.5.0/24 and the "Voice" network will be on 192.168.4.0/24.

The 2900-48G will be the main switch and will connect to 2 DLink L2 PoE switches that will provide power and comms for the Cisco IP Phones. The phones will get their IP address from our windows DHCP server connected to the 2900-48g. I'm intending on using ports 47 and 48 for the Vlans, with one cable to each of those Dlink PoE switches.

I also want to connect the VoIP servers to the main 2900-48 switch (ports 43 and 44) so I don't use up valuable PoE ports unneccesarily. The VoIP servers need to be able to communicate with both the voice and data subnets. In addition, some of the VoIP phones will have PC's connected to them to provide ethernet to remotely placed PC's on the manufacturing plant, so those need to be able to communicate on the data segment too.

I need some advice on how to set tagging and vlan qos prioritys please.

So far my 2900-48 vlan config is as follows:

Startup configuration:

; J9050A Configuration Editor; Created on relea


hostname "ProCurve Switch 2900-48G"
module 1 type J86yyA
module 2 type J86xxA
module 3 type J90XXA
ip routing
snmp-server community "sfm" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-A4
ip helper-address 192.168.5.22
ip address 192.168.5.1 255.255.255.0
jumbo
exit
vlan 10
name "voicevlan"
qos priority 4
ip helper-address 192.168.4.22
ip helper-address 192.168.5.22
ip address 192.168.4.1 255.255.255.0
tagged 47
voice
exit


I'm not 100% sure about tagging/untagging in order to get the desired results. Does the config look about right? What tagging/untagging do I need on the Dlink switch?


Many thanks in advance for your help

Regards

Tino
16 REPLIES
cenk sasmaztin
Honored Contributor

Re: 2900 to Dlink PoE VLAN Setup Help

hi

J9050A Configuration Editor; Created on relea


hostname "ProCurve Switch 2900-48G"
module 1 type J86yyA
module 2 type J86xxA
module 3 type J90XXA
ip routing
snmp-server community "sfm" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-A4
ip address 192.168.5.1 255.255.255.0
exit

vlan 10
name "voicevlan"
qos priority 7
ip address 192.168.4.1 255.255.255.0
untag 43-44 (this interface for 43-44 voicevlan member for voip server connection)
tagged 1,47-48(47,48 interface for dlink switch link default vlan untag member voice vlan tag member;
int 1 connect dhcp server default vlan untag voicevlan tag)
voice
exit


for dhcp server config
scobe 1
vlan id 1
range 192.168.5.20/24 to 192.168.5.200/24

scobe 2
vlan id 2
range 192.168.4.20/24 to 192.168.4.200/24



this information d-link DES-3028P switch I don't know d-link switch config ,because more switch same standart architecture
I connect d-link switch console may be to make vlan config ;because you make d-link vlan config ,for dlink vlan config you
carefully tag untag port concept.please you send (same procurve sh run print)d-link sh run or config info resume ,may be
I help you .

802.1Q VLANs
The DES-3028P provides support for 802.1Q VLANs for improved security and bandwidth utilization.
VLANs provide a means of securing each broadcast domain, segregating them from each other.
This in turn prevents users on one VLAN from gaining access to resources on other network segments.
VLANs can be configured to segment departmental resources. For example, VLANs can be implemented on an SMB
network to prevent the Marketing department from gaining access to secure resources in the Accounting department.

good luck..



cenk

cenk sasmaztin
Honored Contributor

Re: 2900 to Dlink PoE VLAN Setup Help

I give you forget very important information

for cisco ip phone config ;you create on ip phone vlan you config on procurve switch named vlan because for cisco ip phone vlan config vlan id number .
ıt for vlan config no name you make vlan id
example default vlan vlan 1 ,voice vlan vlan 2

good luck


cenk

Colonelk
Frequent Advisor

Re: 2900 to Dlink PoE VLAN Setup Help

cenksasmaztin

Many thanks for your replies.

The Dlink switches are currently in use on the old network so I can't test Vlan's on them yet. However I have created the Vlans on the switch (DES-1526) and I have attached a screenshot as they currently configured.

As an aside I think I am going to purchase a new D-link PoE switch for testing so I can set it up correctly in advance. I just need to clear it with my boss.

Anyway, onto the switch config. The Dlink is configured from the web based interface (I haven't found any reference to telnet based config on it). Attached are the screenshots for the default vlan (VID1) the one I created for voice (VID10) and the trunking page (which I don't think I need to use as I don't need to aggregate bandwidth). I will be connecting this switch to the 2900-48g via port 23 (the other Dlink will be on port 24 of the 2900)

Thanks in advance

Tino

Colonelk
Frequent Advisor

Re: 2900 to Dlink PoE VLAN Setup Help

Hi again.

Regarding your addition of Cisco IP phones information, would you mind having another go at explaining what you mean please?

I'm struggling to understand your English in that reply (I must thank-you though for going to the effort to try!)

Regards

Tino
cenk sasmaztin
Honored Contributor

Re: 2900 to Dlink PoE VLAN Setup Help

hi Colonelk
I hope appropriate configuration
please you carefully look untag tag combination and priority (802.1q)config

I to recommend ,for network perform use for edge switch procurve 2610pw series

good luck
cenk

Colonelk
Frequent Advisor

Re: 2900 to Dlink PoE VLAN Setup Help

The 2610pwr is too expensive. I've ordered a DES-3028p to put into the new network for PoE support. I'm sure it will work fine for VLAN's and QoS (at least the documentation says so).

Hopefully it will arrive tomorrow and I can fully test the configuration. I'll then assign points accordingly.

Thanks again

Colonelk
Frequent Advisor

Re: 2900 to Dlink PoE VLAN Setup Help

The DES-3028p Dlink switch arrived and I've played with the settings. I think I'm almost there, but I'm having DHCP related problems. I'll explain the situation and post config below:

2 VLAN's. Vlan 1 = default. VLAN 10 = voice vlan

Switch 2900-48g:

port 1 = DHCP server
port 48 = link to Dlink switch port 27
port 44 = VoIP server
port 27 = Standard PC

The config of the 2900 is currently:

module 1 type J86yyA
module 2 type J86xxA
module 3 type J90XXA
ip routing
snmp-server community "sfm" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-43,45-A4
ip helper-address 192.168.5.22
ip address 192.168.5.1 255.255.255.0
tagged 44
jumbo
exit
vlan 10
name "voicevlan"
untagged 44
qos priority 4
ip helper-address 192.168.5.22
ip address 192.168.4.1 255.255.255.0
tagged 1,27,47-48
voice
exit


On the dlink I have an IP phone connected to port 16 and a computer connected to port 1

Dlink Vlan config is as follows:

Vlan 1 - Default:

ports 1-28 untagged with egress

VLAN 10 - VoiceVlan

Ports 1-28 Tagged with Egress


Situation:

Set Cisco IP Phone Admin Vlan ID to 10, and it does not pick up an address from IP scope 192.168.4.x/24. In fact it doesn't pick up an address at all.

If I set the IP phone to vlan 1 it picks up an IP address from the 192.168.5.x/24 address range and registers normally. Any PC attached to the Cisco phone correctly picks up an IP address in the .5/24 range on vlan 1.

The issue is therefore with attaining the correct DHCP scope details for the phones.

Do I need to set static routes in the HP switch at all? I was under the impression that because the DHCP request would be broadcast within the same vlan, that I wouldn't need to do any port forwarding on the dlink switch, it could all be taken care of within the HP L3 functionality.

Almost there.....just need a little more help please ! :)

Thanks in advance

Tino
cenk sasmaztin
Honored Contributor

Re: 2900 to Dlink PoE VLAN Setup Help

hi
please

test 1- on d-link switch interface 1 untag member vlan 10 and attach cisco ip phone this switch int 1(be carefully cisco ip phone vlan id 10 )and you look unbroken occur same problem.

test 2-enable voip server dhcp for ip phone and as well d-link switch first config you look occur same problem.

please this test results commentate me
cenk

cenk sasmaztin
Honored Contributor

Re: 2900 to Dlink PoE VLAN Setup Help

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/7970g_7971g-ge/english/3_3_3/english/administration/guide/HEADset.html#wp1146674

hi please you do after test.

hi you see this link and check your cisco ip phone vlan setting more producer vlan architecture you see untag and tag because
on cisco device config not see untag tag port this operation called cisco truk port
many people mixed this term.
cenk

Colonelk
Frequent Advisor

Re: 2900 to Dlink PoE VLAN Setup Help

Hi,

The first test did not work. The phone is still unable to get an IP address from the DHCP server on the .5/24 network whilst a member of the voice vlan.

The second test is a little more tricky because I need to set-up DHCP as a service on the VoIP server. I can do that but its not really the solution I was hoping for (I wanted to keep all DHCP assigments on the Windows 2003 box).

For reference, the phone server is based on CentOS and has Asterisk installed (so its not Cisco call manager!)
cenk sasmaztin
Honored Contributor

Re: 2900 to Dlink PoE VLAN Setup Help

hi
please check
one ip phone you configure static ip
example 192.168.4.11/24

you look operation and say me result


cenk

cenk sasmaztin
Honored Contributor

Re: 2900 to Dlink PoE VLAN Setup Help

hi check static ip test not successfully
we may be change you dhcp config architecture

please you say static ip test result

good luck ..
cenk

Colonelk
Frequent Advisor

Re: 2900 to Dlink PoE VLAN Setup Help

Hi,

When I gave the IP Phone a static address it worked. I still need to do some work on the VoIP server for the phone to successfully register, but at least it wasn't struggling to get an IP address.

AS soon as its put back to DHCP the phone will not pick up an ip address.

I'd like to check the routing. The 2900 default VLAN address is 192.168.5.1. The 2900 voicevlan address is 192.168.4.1.

On the Dlink the IP address for the switch is 192.168.5.3. Its default gateway is 192.168.5.1 (this was how a dlink eng recommended it be set up).

On the 2900 a "show ip route" command yields

ProCurve Switch 2900-48G# show ip route

IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
127.0.0.0/8 reject static 0 0
127.0.0.1/32 lo0 connected 1 0
192.168.4.0/24 voicevlan 10 connected 1 0
192.168.5.0/24 DEFAULT_VLAN 1 connected 1 0




on the dlink a similar command yields:

DES-3028P:4#show iproute
Command: show iproute


Routing Table

IP Address/Netmask Gateway Interface Hops Protocol
------------------ --------------- ----------- ------- --------
0.0.0.0 192.168.5.1 System 1 Default
192.168.5.0/24 0.0.0.0 System 1 Local

Total Entries : 2



I suspect I may need to put in some manual routes on the dlink switch for 192.168.4.0/24 network on voicevlan.

Ideas?


cenk sasmaztin
Honored Contributor

Re: 2900 to Dlink PoE VLAN Setup Help

hi
I think we not routing problem I think we are dhcp server on 802.1q problem

please check ;your dhcp server to connect on vlan 1untag and vlan 2 tag port

please you say how make dhcp server architecture what use type dhcp server.

cenk

Colonelk
Frequent Advisor

Re: 2900 to Dlink PoE VLAN Setup Help

Right,

I've solved the DHCP issue by installing a DHCP service on the Linux VoIP server (vlan 10 voicevlan) (webmin came in very handy for that)

So now the IP phones correctly pick up an ip address from the phone server DHCP pool, and the computers plugged into the back of the IP phones correctly pick up a dhcp assigned address from the Windows 2003 DHCP on the data subnet (vlan 1). Routing between the two vlans seems to be working fine (tested by making PC's an untagged member of vlan 10)

Many thanks for your help


Colonelk
Frequent Advisor

Re: 2900 to Dlink PoE VLAN Setup Help

Some good advice in this thread regarding tagging of vlans for a basic voice and data vlan setup. Many thanks to Cesz

DHCP IS a problem across Vlan's. No matter what ip helper-address settings I used I could not get DHCP requests to forward across broadcast domains (vlans). In the end I installed the DHCPd service on the VoIP phone server running Linux and will have to manage DHCP in two places now (Windows 2003 DHCP for the data vlan, and Linux DHCPd for the voice vlan)

Please note, with Cisco IP phones (ours are 7941g) you need to set the Admin Vlan ID to be the VID of the voice vlan in your setup.

hope this helps