Switches, Hubs, and Modems
Showing results for 
Search instead for 
Did you mean: 

2910AL Trunking help

Frequent Advisor

2910AL Trunking help

Hi all, I am trying to trunk my VLAN(s) to my Cisco 2621 router but I can't get the default VLAN to trunk over.

This is a quick overview of how my VLAN(s) are setup on my switch

1 - Default (IP (untagged 21-23) (no untagged 1-20, TRK24) -> port 24 is used to trunk
10 - E (NO IP) (untagged 1-4) (tagged trk24)
20 - J (NO IP) (untagged 5-8) (tagged trk24)
30 - S (NO IP) (untagged 9-12) (tagged trk24)
40 - P (NO IP) (untagged 13-15) (tagged trk24)
50 - Servers (NO IP) (untagged 17-20) (tagged trk24)

All the DHCP and sub interfaces are configured on my Cisco router he is a sample of how the networks look like.

VLAN 1 - /24
VLAN 10 - /24 (DHCP)
VLAN 20 - /24 (DHCP)
VLAN 30 - /24 (DHCP)
VLAN 40 - /24 (DHCP)
VLAN 50 - /24

This is how the trunking looks like on the Cisco router

FA0/1 - no ip address, no shutdown
FA0/1.1 - IP, encap dot1q 1 native
FA0/1.10 - IP, encap dot1q 10
FA0/1.20 - IP, encap dot1q 20
FA0/1.30 - IP, encap dot1q 30
FA0/1.40 - IP, encap dot1q 40
FA0/1.50 - IP, encap dot1q 50

All the static port VLAN(s) work fine for example if I plug in my laptop to port 1 its going to be tagged with a VLAN ID of 10 and assigns me a DHCP address of

BUT on my switch I CAN'T ping my router so when I ping coming form (default vlan), no response.

When I plug in my laptop into port 23 (untagged VLAN1) and set an IP of I CAN ping my switch and access the web interface BUT I can't ping the gateway.

I tried setting it so VLAN 1 trunks via TRK24 but still no luck

Maybe my trunks are messed up, which I think is the main issue. Does anybody know the solution to my problem? This is my first time configuring an HP switch.

Thanks for the responses

cenk sasmaztin
Honored Contributor

Re: 2910AL Trunking help

Frequent Advisor

Re: 2910AL Trunking help

Thanks for the help guys I got it figured out. I am still new to L3 switches so I dumped that old topology and enabled intra-vlan routing on the HP switch.

Once that was done everything was working fine. I even got Radius assigned VLAN(s) to work everything is gravy.. well not quite

Thanks for the help!