Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

2910al and Equallogic

2910al and Equallogic

I have an Equallogic PS4000 connected to a ProCurve 2910al switch. I also have a Dell PowerEdge R710 connected to the same switch.

I have "partitioned" the switch right now so that ports 1-12 are part of the DEFAULT_VLAN, and ports 13-24 are part of iSCSI vlan (5).

Two network ports from the PowerEdge are connected to ports assigned to the VLAN 5 only, and so are two of the network ports from the Equallogic.

I have setup teaming for the network adapters in the PowerEdge.

But when I go the ProCurve, and assign these ports to a Trunk group, and then assign the Trunk group to a VLAN, I lose connectivity.

If I have no Trunks set up in the ProCurve, I have connectivity.

What am I doing wrong?

Thanks!
4 REPLIES
nemix
Occasional Advisor

Re: 2910al and Equallogic

Can you Post your config?

Which type of trunk do you configure?Static or LACP?
jmglass
Occasional Advisor

Re: 2910al and Equallogic

I have had luck with the following.

~trunk config command
trunk 17-18 Trk1 Trunk


~add Trk1 to the VLAN
vlan X
untagged 1-16,19-24,A1-A4,Trk1

~this was added by switch when I created Trk1
spanning-tree Trk1 priority 4


XX#show inter

16 3,733,325,800 117,274,910 0 0 off 0
17-Trk1 549,345,094 352,185,496 0 134 off 0
18-Trk1 279,264,711 925,166,059 0 1747 off 0
19 4,065,063,090 327,812,416 0 69,324,549 off 0


XX#show inter brief
16 100/1000T | No Yes Down 1000FDx MDI off 0
17-Trk1 100/1000T | No Yes Up 1000FDx MDI off 0
18-Trk1 100/1000T | No Yes Up 1000FDx MDI off 0
19 100/1000T | No Yes Up 100FDx MDIX off 0


jim

Re: 2910al and Equallogic

I am trying to create a static trunk. Here's the original configuration that works fine:

Startup configuration:

; J9145A Configuration Editor; Created on release #W.14.38

hostname "SKW-3"
module 1 type J9145A
module 2 type J9165A
stack join C09134C60980
vlan 1
name "DEFAULT_VLAN"
untagged 1-12,A1
ip address 192.168.1.247 255.255.255.0
no untagged 13-24
exit
vlan 2
name "Guest"
no ip address
exit
vlan 4
name "External"
no ip address
exit
vlan 5
name "iSCSI"
untagged 13-24
no ip address
jumbo
exit
vlan 10
name "Phones"
no ip address
exit
snmp-server community "public" unrestricted"

But then, when I do this, it doesn't work:

Startup configuration:

; J9145A Configuration Editor; Created on release #W.14.38

hostname "SKW-3"
module 1 type J9145A
module 2 type J9165A
stack join C09134C60980
vlan 1
name "DEFAULT_VLAN"
untagged 1-12,A1
ip address 192.168.1.247 255.255.255.0
no untagged 13-18,21-24,Trk1
exit
vlan 2
name "Guest"
no ip address
exit
vlan 4
name "External"
no ip address
exit
vlan 5
name "iSCSI"
untagged 13-18,21-24,Trk1
no ip address
jumbo
exit
vlan 10
name "Phones"
no ip address
exit
snmp-server community "public" unrestricted"
spanning-tree Trk1 priority 4

I don't know if it's related, but I tried disabling spanning-tree with "spanning-tree Trk1 admin-edge-port", but it still shows as priority 4.

Re: 2910al and Equallogic

Hmm... I may have got it now - looks like LACP is the way to go instead:

config trunk 19-20 trk1 lacp

Seemed to be the right spell. Now, how do I disable the spanning tree on this trunk...