Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

3500yl and Nortel 1140e using LLDP

3500yl and Nortel 1140e using LLDP

Hi,
I was wondering if i might get some help with our network here. I have been running the 3500 with these phones for a good time now but after updating to the latest software version 14.41 we are having log entries that say "00828 lldp: PVID mismatch on port XX(VID 1) with peer device port 0(VID 0)(XXXX)"
I'm not sure why this has all of a sudden shown up in our logs but it was never there before. Everything is working OK except for these log entries. Not sure what to do.
Thank you for any help you can give.
:)
Preston
11 REPLIES
Holger Hasenaug
Trusted Contributor

Re: 3500yl and Nortel 1140e using LLDP

Hello Preston,

Reading the Release Notes is always a good idea.

Release K.14.40 Enhancements
â   Enhancement (PR_0000016237) â Port VLAN ID TLV Support on LLDP.

So in your case you should disable the LLDP Port VLAN TLV:

no lldp config dot1TlvEnable port-vlan-id

Regards

Holger

Re: 3500yl and Nortel 1140e using LLDP

OK i'll give that a try. Thank you for your response. I guess that the port vlan id is different than the voice vlan id that is assigned?
thank you,
Preston

Re: 3500yl and Nortel 1140e using LLDP

UPDATE:
I ran the turnoff recommended and didn't have any luck. Before I did it i checked the status with show lldp config 1 and saw that port-vlan-id was shown.
I ran no lldp config ... on ports 1-24 and it completed.
I ran show lldp config again and port-vlan-id was not shown so the TLVs are not advertised.
However, I am still getting messages in the log that say the same thing despite having disabled pvid TLVs.
Not sure where to go from here. Thank you for any help.
Preston

Re: 3500yl and Nortel 1140e using LLDP

I don't know if it has anything to do with the pvid problem or not but when the phones come online they have the message "LLDP TTL has expired" on them. Still though, they seem to receive the voice vlan information without any trouble.
I have attached the switch's running config too incase that helps.

Thank you,
Preston
Holger Hasenaug
Trusted Contributor

Re: 3500yl and Nortel 1140e using LLDP

Hi Preston,

Regarding the log entry I would contact the support and suggest that ProCurve Switches should not log anything if an LLDP for PVID=0 is received.

Regards

Holger

Re: 3500yl and Nortel 1140e using LLDP

Holger thank you for your help in this. I will try to get in touch with HP support but I don't have any plan with them. As far as the PVIDs go, what does that represent? If you have a port that has data vlan 1 untagged and voice vlan 2 tagged then how do you represent the untagged packets with a vlan id? Just curious.
Thank you again,
Preston
Holger Hasenaug
Trusted Contributor

Re: 3500yl and Nortel 1140e using LLDP

Hi,

The PVID stands for Port VLAN Identifier. The PVID for a given Port provides the VLAN ID for untagged and priority-tagged frames received through that Port.

The problem with your setup is the following:
On the switch side the untagged VLAN ID is â 1â . Therefore the switch advertises the PVID=1 via LLDP.
The phone send the data traffic of the PC just untagged to the switch. The phone does not know which VLAN ID matched the untagged VLAN traffic. Therefore the phone advertise the PVID=0 via LLDP.

The switch just compare the following: The received VID=0 is not equal the locally configured PVID=1 and logs an error.
Aarón
Frequent Advisor

Re: 3500yl and Nortel 1140e using LLDP

Hi Preston,

we are having the same issue you are having. We get this message:

"lldp: PVID mismatch on port 1(VID 0)with peer device port 252(VID 90)(19517)"

We have a 10GbE link with a VirtualChassis-Juniper equipment that is using this exact configuration:

CPD1B# sh vlans ports a1 detail

Status and Counters - VLAN Information - for ports A1

Port name: VC Uplink
VLAN ID Name | Status Voice Jumbo Mode
------- -------------------- + ---------- ----- ----- --------
80 PreBalB0 | Port-based No No Tagged
81 PrebalB1 | Port-based No No Tagged
88 PreBalB8 | Port-based No No Tagged
89 PreBalB9 | Port-based No No Tagged
90 PostBalB0 | Port-based No No Tagged
91 PostBalB1 | Port-based No No Tagged
725 Comm | Port-based No No Tagged
726 Servicios_Sis | Port-based No No Tagged
730 Backup | Port-based No No Tagged


We have no untagged vlan on both sides so I don't understand how can be a PVID mismatch between switches. Any suggestion?

We have no actual problem now but it would be nice to check the log and see only _real_ problems.

Thank you very much,

Aarón
pov-bcn
Occasional Contributor

Re: 3500yl and Nortel 1140e using LLDP

Hello Preston:

Have you achieved to solve this issue? After an upgrade to K.13.71 we see similar log entries in our 5406zl boxes connected to Nortel IP Phones.

We have the phones on a dedicated VLAN, so we feed them with untagged traffic. We get a similar error since the PVID on the port switch 21 and the phone is announcing PVID 0.

Has the newer firmware version of the phones solved the issue? Did you take further actions?

Re: 3500yl and Nortel 1140e using LLDP

Hi,
In order to get this issue resolved I went through HP's support group. They did a lot of testing and the solution that they gave me was basically to just configure the switch to stop reporting this log message. In order to make things line up you would have to set the vlan ID of untagged packets to be the same on the phone as it is on the switch. I don't know what type of phones you use but in our case we did not know (couldn't find out how) to do this. If you want the troubleshooting thread from HP then send me an email to
p aleshire @ debonairac com
(no spaces and . before the com domain) and i will forward you the emails.
Preston
pov-bcn
Occasional Contributor

Re: 3500yl and Nortel 1140e using LLDP

OK thank you a lot for your feedback Preston.
Gonna take a look at my phones to check if the VID is tunneable or not....

Best regards