Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

3COM switch, enable elevated mode in Telnet/SSH

Silvester Bosman
Occasional Visitor

3COM switch, enable elevated mode in Telnet/SSH

Hi All,

I have a 3COM switch here, which i want to administer remotely. The only problem is that when i log in to the device through Telnet or SSH, i cannot use the "Enable" command:

WX0003> ena
error: Enable not permitted from this session.

Is there any way i can change the security so i can "enable" in a telnet session?

Many thanks!

Silvester
7 REPLIES
Jeff Carrell
Honored Contributor

Re: 3COM switch, enable elevated mode in Telnet/SSH

Silvester, which 3Com switch and code version?
Olaf Borowski
Respected Contributor

Re: 3COM switch, enable elevated mode in Telnet/SSH

Silvester,

Try this:

VTY lines are used for telnet...

local-user admin
password simple h3c
authorization-attribute level 3
service-type telnet

user-interface vty 0 4
authentication-mode scheme
command accounting
user privilege level 3
idle-timeout 0 0


Olaf
Silvester Bosman
Occasional Visitor

Re: 3COM switch, enable elevated mode in Telnet/SSH

Hi Guys,

The sugestion didn't quite work out. :(
I've got a WX1240 wireless LAN switch.

The commands stated earlier were not accepted, unfortunately.
Seems like these command are for a different CLI type.

My version is as follows:
Mobility System Software, Version: 7.0.5.6 REL
Copyright (c) 2004 - 2008 3Com Corporation. All rights reserved.

Build Information: (build#0) REL_7_0_5_branch 2008-10-14 15:10:00
Model: WX1200
Hardware
Mainboard: version 15 ; revision AB ; FPGA version 31
Serial number 28WM8DJC0A610
Flash: 1.0.0 - 0
Kernel: QNX-630
BootLoader: 4.20 / 7.0.2
Asmerani
Occasional Visitor

Re: 3COM switch, enable elevated mode in Telnet/SSH

Hi Anyone/Support Team,

 

was there a resolution to this issue : when trying to go into enable mode you get the following error:

 

error: Enable not permitted from this session.

 

i have the same WX2200 controller.

 

Thanks

Cisco-Tech
Occasional Visitor

Re: 3COM switch, enable elevated mode in Telnet/SSH

Did anyone ever figure this out? I am having the same problem!!

Cisco-Tech
Occasional Visitor

Re: 3COM switch, enable elevated mode in Telnet/SSH

im not sure what that article pertains to.. is my awnser somewhere within?

hk47zen
Occasional Visitor

Re: 3COM switch, enable elevated mode in Telnet/SSH

 

Hi, check command if it exists:

 

set authentication admin ** none  -- > if there is this command, change to:

 

set authentication admin ** local

 

create user with password then, privileges to enable it with this command:

 

set user admin attr service-type 6

 

I think this should work.

 

; )