Switches, Hubs, and Modems
Showing results for 
Search instead for 
Did you mean: 

4108GL spanning tree on LX ports

Ric Shortman
Occasional Visitor

4108GL spanning tree on LX ports

I've just added a 4108GL to my existing network of 4000M's.
I have a fibre backbone on 1000LX ports.
When I add the 4108 to the network (using an existing uplink to a 4000m) there is no connection made, and the spanning tree shows as disabled on the LX port (looking at it from telnet)

any ideas please ?

Ron Kinner
Honored Contributor

Re: 4108GL spanning tree on LX ports

First check the port status to see if the link is UP. Could be that autonegotiate failed. My Ciscos won't talk to each other either until I set both ends to the same speed and duplex and turn off flow control. On a Cisco (which HP seems to mimic) Disabled in the STP state means the link is no good or has been shutdown by the admin. Blocking is STP's normal indication that it has turned off the port to prevent a loop.

Next check if you are using tagging the same on both ends and are allowing the same vlans.

Is STP enabled on the 4108? Which bridge does it think is the root bridge? You might want to set its priority a bit higher than normal so that it will not be selected as the root bridge since I assume it is on the edge of your network.

Arimo Laine_2
Valued Contributor

Re: 4108GL spanning tree on LX ports


Check first the firmware levels. The latest firmware for 4000M is C.09.16, 4108GL runs on G.07.21. Update if you're running lower revisions.

Then check that both switches have the ports set to autonegotiation. If you have a Duplex Mismatch situation going on, the firmware will not allow the link to come up at all.

If you do not have redundant links, disable STP on the switches.

If you are not using LACP trunks, disable also LACP on 4108:

1. Remove all trunks you have configured
2. Go to command line and give commands:

con t
int all
no lacp
write mem

3. Re-configure the trunks

Tito Tortelli
Occasional Visitor

Re: 4108GL spanning tree on LX ports

Make sure that the 4108s and the 4000s are running the same version of STP. The newest code for the 4108s support RSTP (Rapid Spanning Tree} and the 4000s may not have code that support the RSTP protocol.