Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

4208vl LACP + vlan trunking to 3com switches

SOLVED
Go to solution
traty
Occasional Advisor

4208vl LACP + vlan trunking to 3com switches

All,

I am new to the HP world of things and am having issues with my 4208 doing LACP And Vlan Trunking. Whenever I link the 4208 to a 3com 4500G and a 4500 only vlan1 passes through the LACP link. The same 3com switch links to other 3coms and Cisco switches fine without configuration changes. the LACP port groups are B1&B2 and B3&B4 Below is the config.

-------------

max-vlans 12
time timezone -480
time daylight-time-rule Continental-US-and-Canada
flow-control
web-management ssl
module 5 type J8763A
module 6 type J8763A
module 2 type J8776A
module 3 type J8776A
module 4 type J8776A
module 1 type J8765A
interface B1
name "Switch 1"
lacp Active
exit
interface B2
name "Switch 1"
lacp Active
exit
interface B3
name "Switch 2"
lacp Active
exit
interface B4
name "Switch 2"
lacp Active
exit
sntp server 217.160.254.116
timesync sntp
sntp unicast
snmp-server community "public"
snmp-server community "helpme" Unrestricted
vlan 1
untagged A13,A15,A17,A20-A21,B1-B4,C1-C4,D1-D4,E1-E12,F1-F12
ip address 10.0.4.1 255.255.0.0
qos priority 5
tagged A2,A4,A6,A8,A10,A19,A23
no untagged A1,A3,A5,A7,A9,A11-A12,A14,A16,A18,A22,A24
exit
vlan 2
no ip address
qos priority 4
tagged A2,A4,A6,A8,A10,A19,A23,B1-B4,C1-C4,D1-D4,E1-E12,F1-F9
ip igmp
exit
vlan 3
no ip address
qos priority 4
tagged A2,A4,A6,A8,A10,A19,A23,B1-B4,C1-C4,D1-D4,E1-E12,F1-F12
exit
vlan 4
untagged A1,A3,A5,A7,A9,A11,A14,A16,A18,A23
no ip address
qos priority 0
tagged A2,A4,A6,A8,A10,A19,B1-B4,C1-C4,D1-D4,E1-E12,F1-F12
ip igmp
exit
vlan 5
ip address 10.2.0.2 255.255.0.0
qos priority 5
tagged B1-B4,C1-C4,D1-D4,E1-E12,F1-F12
exit
vlan 6
untagged A2,A4,A6,A8,A10
no ip address
qos priority 6
tagged A23,B1-B4,C1-C4,D1-D4,E1-E12,F1-F12
ip igmp
exit
vlan 7
no ip address
qos priority 0
tagged A2,A4,A6,A8,A19,B1-B4,C1-C4,D1-D4,E1-E12,F1-F12
ip igmp
exit
vlan 8
no ip address
qos priority 4
tagged A2,A4,A6,A8,A19,B1-B4,C1-C4,D1-D4,E1-E12,F1-F12
ip igmp
exit
vlan 9
no ip address
qos priority 4
tagged B1-B4,C1-C4,D1-D4,E1-E12,F1-F12
ip igmp
exit
vlan 10
untagged A12,A22,A24
no ip address
qos priority 7
tagged B1-B4,C1-C4,D1-D4,E1-E12,F1-F12
ip igmp
exit
vlan 200
no ip address
qos priority 0
tagged C1-C4,D1-D4,E1-E12,F1-F12
exit
qos type-of-service diff-services
no stack
4 REPLIES
Ardon
Trusted Contributor
Solution

Re: 4208vl LACP + vlan trunking to 3com switches

Hi Traty,

The way you describe the issue and based on the running configuration this all is expected behavior.

First of all interfaces B2,B3 and B4 are set to LACP Active. Now if the remote 3Com switch either Passive LACP or Active LACP, this will in both cases result in a Active LACP Trunk (issue a Show LACP on the ProCurve 4200 should show you Dyn1 indicating the Active LACP Trunk).

Now an ACtive LACP Trunk runs in de default VLAN ONLY unless you use GVRP to propagate other VLANs across the Trunk as well. Please refer to the 4200 Managament and Configuration Guide where it is stated that:
'Dynamic LACP trunks operate only in the default VLAN (unless GVRP is enabled and Forbid is
used to prevent the trunked ports from joining the default VLAN). Thus, if an LACP dynamic port
forms using ports that are not in the default VLAN, the trunk will automatically move to the default
VLAN unless GVRP operation is configured to prevent this from occurring. In some cases, this can
create a traffic loop in your network. For more on this topic, refer to â VLANs and Dynamic LACPâ on page 13-23.
This is no ProCurve proprietry implementation.

Personally I am not that big of a GVRP fan anyways and therefore would choose to make my Trunks work in Static LACP which allows for static Tagging of VLANs across them (as mentioned above you can not use static VLAN assigments of VLANs accros a Dynamic LACP Trunk).

To do so you first need to get rid of the Dynamic LACP Trunk. Of course you have to be in Global Configuration Mode 4200(config)#

*Issue a Show LACP on the 4200 and note which ports are member of the Dynamic LACP Trunk(s).

*Now disable those listed interfaces (this is needed as otherwise the next command will fail).

*From Global Configuration Mode AT LEAST issue the follwing command for ports that should be in the Static LACP Trunk: lacp passive.

*Make sure the corresponding 3COM ports are also set to Passive LACP as otherwise you will still end up with a Dynamic LACP Trunk (also mentioned in the 4200 Management and Configuration Guide).

*Once you have performed the above steps you can now configure the Static LACP Trunks using the command: Trunk B2,B3,B4 Trk1 LACP

*You are now able to Tag individual VLANs on the newly configured Trunk (Trk1). Go into the VLAN context from the Global Configuration Mode (4200(config)#vlan 8) and Tag the ports you want. For example Tag Trk1. Now VLAN 8 is Tagged for Trk1. This is the same as you orginally did.

So the problem you have is expected behavior due to the way a Dynamic LACP Trunk operates: all ports in the Default VLAN UNLESS you use GVRP.

Hope this helps.


ProCurve Networking Engineer
traty
Occasional Advisor

Re: 4208vl LACP + vlan trunking to 3com switches

Ok that makes sense. I would run GVRP but not all of my switches support it, (I have a mix of this hp, some cisco 2950, 2940's and 3com 4500 and 4226's)

Once I get back to work I'll try it.

Thanks!
traty
Occasional Advisor

Re: 4208vl LACP + vlan trunking to 3com switches

Just got a chance to set it up. It works great! Thanks a bunch. Now I don't need to throw the switch across the room :)
traty
Occasional Advisor

Re: 4208vl LACP + vlan trunking to 3com switches

See above