Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

5304XL and 2810 VLAN and trunking question

ctdam
Occasional Visitor

5304XL and 2810 VLAN and trunking question

I have a 5304XL acting as a distribution switch. It connects via a GBIC into our IP provider on port A15, and then in turn into two 2810s.

Previously, I had only two VLANs on the 5304XL - one for the /30 from the upstream on VLAN 1, and one for a handful of subnets on our class-C block on VLAN 2. All the routing worked perfect.

I then wanted to start separating out some client servers into separate VLANs on a second 2810 connected to the 5304XL.

I originally had two-port trunks setup into each 2810, but I removed the trunks temporarily to work on one issue at a time.

On the 5304XL port a3 goes into port 1 on the 2810 in the configs below.

I can't reach the servers on VLANs 10 or 11. They have IPs .82 and .90 respectively, with .81 and .89 as the gateways. What am I doing wrong here?

------------

5304XL:

hostname "HP ProCurve Switch 5304XL"
max-vlans 256
module 1 type J4907A
interface A2
disable
exit
ip default-gateway 4.X.X.X
ip routing
snmp-server community "public" Unrestricted
snmp-server community "REMOVED" Operator
vlan 1
name "DEFAULT_VLAN"
untagged A15
ip address 4.X.X.X 255.255.255.252
no untagged A1-A14,A16
ip proxy-arp
exit
vlan 2
name "public"
untagged A1-A14,A16
ip address 8.X.X.33 255.255.255.240
ip address 8.X.X.49 255.255.255.240
ip address 8.X.X.2 255.255.255.224
ip address 8.X.X.65 255.255.255.240
tagged A15
ip proxy-arp
exit
vlan 12
name "cust32"
ip address 8.X.X.97 255.255.255.248
tagged A3-A4
ip proxy-arp
exit
vlan 13
name "cust33"
ip address 8.X.X.105 255.255.255.248
tagged A3-A4
ip proxy-arp
exit
vlan 10
name "cust30"
ip address 8.X.X.81 255.255.255.248
tagged A3-A4
ip proxy-arp
exit
vlan 11
name "cust31"
ip address 8.X.X.89 255.255.255.248
tagged A3-A4
ip proxy-arp
exit
vlan 20
name "cust40"
ip address 8.X.X.161 255.255.255.248
tagged A3-A4
ip proxy-arp
exit
ip route 0.0.0.0 0.0.0.0 4.X.X.X
ip ssh
router rip
exit
password manager
password operator

2810:

hostname "ProCurve Switch 2810-24G"
max-vlans 256
no telnet-server
interface 1
lacp Passive
exit
interface 2
lacp Passive
exit
ip default-gateway 8.X.X.2
snmp-server community "public" Unrestricted
snmp-server community "REMOVED" Operator
vlan 1
name "DEFAULT_VLAN"
untagged 1-2,5-24
ip address 8.X.X.9 255.255.255.224
no untagged 3-4
exit
vlan 2
name "public"
ip address 8.X.X.27 255.255.255.248
tagged 1-5,8-24
exit
vlan 10
name "cust30"
untagged 3
tagged 1-2
exit
vlan 11
name "cust31"
untagged 4
tagged 1-2
exit
no stack auto-join
ip ssh
password manager
password operator
1 REPLY

Re: 5304XL and 2810 VLAN and trunking question

Hi

First of all.

The untagged vlan on the link a3 - 1 is a mimatch:

53xx:
vlan 2
name "public"
untagged A1-A14,A16

2810:
vlan 1
name "DEFAULT_VLAN"
untagged 1-2,5-24

So on the 2810 side the untagged vlan is 1, but on the 5300 the untagged vlan is 2.

I would suggest keeping vlan 1 as the untagged vlan on both sides, to keep it compatible.