Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

5308XL simple Vlan help!

SOLVED
Go to solution
pricho
Occasional Visitor

5308XL simple Vlan help!

HI,

 

Trying to setup a simple vlan on our core switch, it currently has an ip of 10.60.148.29 and we have a router with the ip of 10.60.148.1 which is the default gateway for all clients.

 

I've enabled IP Routing on the core and added the vlans as you can see from the config below. If I manually assign an address to a PC plugged into untagged port (G13) on Vlan 1648 it can ping the vlan ip and the ip of the switch but nothing else. I have an IP Helper on vlan 1648 but its not issuing address.. is this because the dhcp server default gateway is the router and not the switch? regardless of the gateway the switch should be able to route the ip ok?

 

; J4819A Configuration Editor; Created on release #E.11.29

hostname "Cab1" 
snmp-server contact "ITSupport" 
snmp-server location "serverroom1" 
module 4 type J4907A 
module 5 type J4820B 
module 7 type J4820B 
module 6 type J4907A 
module 8 type J4907A 
module 3 type J4907A 
module 2 type J4878B 
module 1 type J4878B 
interface E12 
   name "SAN CLI" 
exit
interface H1 
   name "SAN Traffic" 
   no lacp
exit
interface C6 
   name "SAN BUI" 
exit
interface C13 
   name "SAN Traffic" 
exit
interface D14 
   name "SAN Traffic" 
   no lacp
exit
trunk D14,H1 Trk1 LACP 


ip routing 
snmpv3 enable 
snmpv3 only 
snmpv3 restricted-access 
snmpv3 user "initial" 
snmpv3 user "cacti" 
snmpv3 user "list" 
snmpv3 group OperatorAuth user "cacti" sec-model ver3 
snmp-server community "public" Unrestricted 
vlan 1 
   name "DEFAULT_VLAN" 
   untagged A1-A4,B1-B4,C1-C16,D1-D13,D15-D16,E1-E24,F1-F16,G1-G12,G14-G24,H2-H16,Trk1 
   ip address 10.60.148.29 255.255.252.0 
   no untagged G13 
   exit 
vlan 1648 
   name "Guest" 
   untagged G13 
   ip address 172.16.48.1 255.255.252.0 
   ip helper-address 10.60.148.116 
   exit 
fault-finder bad-driver sensitivity high 
fault-finder bad-transceiver sensitivity high 
fault-finder bad-cable sensitivity high 
fault-finder too-long-cable sensitivity high 
fault-finder over-bandwidth sensitivity high 
fault-finder broadcast-storm sensitivity high 
fault-finder loss-of-link sensitivity high 
fault-finder duplex-mismatch-HDx sensitivity high 
fault-finder duplex-mismatch-FDx sensitivity high 
ip route 0.0.0.0 0.0.0.0 10.60.148.1 
spanning-tree Trk1 priority 4
password manager
password operator

 

Any help and advice would be great! 

 

Cheers, 

 

2 REPLIES
Vince_Whirlwind
Trusted Contributor
Solution

Re: 5308XL simple Vlan help!

Two separate issues:

 

1/ Your router is on the same subnet as your VLAN1 hosts, but you already have a router on VLAN1 (Core switch). You should not extend a VLAN to span across multiple Layer-3 devices.

 

2/ Does your router have a route for the 172.16.48.0 subnet?

pricho
Occasional Visitor

Re: 5308XL simple Vlan help!

Thanks for you reply, fixed the issue. Made the Core switch the new default gateway on the DHCP Server.. works a charm now.

Regards,