Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

5308xl won't route

SOLVED
Go to solution
thothompson
Occasional Visitor

5308xl won't route

Received 5308xl and am trying to just set up a basic vlan/ip routing config on it. However, it doesn't add these intraswitch vlans to the routing tables even though they are defined on the switch itself. What am I missing? Here's the config and output from show ip route command:

; J4819A Configuration Editor; Created on release #E.10.27

hostname "HP ProCurve Switch 5308xl"
module 1 type J4907A
module 6 type J4852A
module 8 type J4852A
module 3 type J4907A
module 5 type J4907A
ip default-gateway 10.10.50.2
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A1-A14,C1-C16,E1-E16,F1-F12,H1-H12
ip address 10.10.50.1 255.255.255.0
no untagged A15-A16
exit
vlan 2
name "two"
untagged A15
ip address 10.10.100.1 255.255.255.0
exit
vlan 3
name "three"
untagged A16
ip address 10.10.200.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 10.10.50.2

HP ProCurve Switch 5308xl# show ip route

IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
127.0.0.0/8 reject static 0 250
127.0.0.1/32 lo0 connected 0 0
2 REPLIES
Matt Hobbs
Honored Contributor
Solution

Re: 5308xl won't route

The routes won't be created in the table until you have physically connected some ports in those VLANs. For your example, ports A1, A15 and A15 at minimum need to have a link - this in turn brings up the VLAN interface and then the routes are created automatically.
thothompson
Occasional Visitor

Re: 5308xl won't route

You are correct sir! Thanks.