Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

5400zl, Wake-on-Lan --need help to understand results

SOLVED
Go to solution

5400zl, Wake-on-Lan --need help to understand results

Hello--
We have, at the moment, a very simple bench setup testing a 5400 before installing. There are 2 VLANS (the default and VLAN20). We have three different wake-on-lan applications. Testing one of them has given the results that follow. The application uses port 2304. The "sending" machine is on VLAN 1 (10.0.10.0/24). The receiving machine is on VLAN20 (10.0.20.0/24). UDP broadcast forwarding is on and ip forward protocol port(s) are set for VLAN1.
RESULTS:
--When the WOL application is set to broadcast on 255.255.255.255, WOL works and a packet capture on VLAN20 shows the WOL packets with destination 10.0.20.255. So far so good.
--If the WOL application is set to broadcast on 10.0.10.255 (10, not 20!), WOL works and a packet capture on VLAN20 again shows packets with destination 10.0.20.255.
--However, if the WOL application is set to broadcast on 10.0.20.255 (which is the way all three WOL applications really work in the production environment), WOL fails and the capture shows no wol packets at all in VLAN20.

The configuration is simple, since it's just a test right now:

----------------------------------------
Running configuration:

; J8697A Configuration Editor; Created on release #K.12.14

hostname "ProCurve Switch 5406zl"
snmp-server location "MDF"
time timezone -300
time daylight-time-rule Continental-US-and-Canada
module 1 type J8702A
module 2 type J8702A
module 6 type J8705A
sntp server 10.0.10.1
ip routing
ip udp-bcast-forward
timesync sntp
sntp unicast
sntp 600
snmp-server community "EDITED" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24,B3-B24,F1-F24
ip forward-protocol udp 10.0.20.255 65535
ip forward-protocol udp 10.0.20.255 2304
ip forward-protocol udp 10.0.20.255 1761
ip address 10.0.10.18 255.255.255.0
no untagged B1-B2
exit
vlan 20
name "VLAN20"
untagged B1-B2
ip helper-address 10.0.10.4
ip helper-address 10.0.10.3
ip address 10.0.20.1 255.255.255.0
exit
mirror 1 port B13
interface A1
monitor all Both mirror 1
exit
interface B2
monitor all Both mirror 1
exit
------------------------------------------

Thank you for your help...Regards, Chris G
4 REPLIES
Joel Belizario
Trusted Contributor

Re: 5400zl, Wake-on-Lan --need help to understand results

Hi Chris, I could be way off but wondering if it is something as simple as the subnet being defined wrongly in your WOL application?
Richard Brodie_1
Honored Contributor
Solution

Re: 5400zl, Wake-on-Lan --need help to understand results

ip directed-broadcast ?

Re: 5400zl, Wake-on-Lan --need help to understand results

ip directed-broadcast was the solution---
I would still like to understand the various results observed in the packet traces (as described in the original post), but I can't complain, since it works! Thanks for your help and for taking the time to answer. Regards, cg
Joel Belizario
Trusted Contributor

Re: 5400zl, Wake-on-Lan --need help to understand results

Think this answers the question.

http://www.depicus.com/wake-on-lan/what-is-wake-on-lan.aspx

I learn something new everyday! :)