Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

5406zl Default route problem

Tolga Cengiz
Occasional Visitor

5406zl Default route problem

I have a swicth e 5406zl image K.14.33 want to do I have 2 units in our company has linux firewall to the Internet, they both come from a different point is the default route ip route 0.0.0.0 0.0.0.0 195.33.224.7 distance would enter 10 as the route ip route 2 0.0. I entered as 0.0 0.0.0.0 195.33.224.251 distance later, 200 of the Interface 195.33.224.7 would disable, but still 195.33.224.7 cliente trace of pull out when I see you trying to enable load-sharing is very glad if you can help
9 REPLIES
Patrick Terlisten
Honored Contributor

Re: 5406zl Default route problem

Hello,

did you enable ip routing? Can you provide use a "show running-config" and a "show ip route" from the switch?

Try:

ip route 0.0.0.0/0 195.33.224.7 10
ip route 0.0.0.0/0 195.33.224.251 200

Best regards,
Patrick

Best regards,
Patrick
Tolga Cengiz
Occasional Visitor

Re: 5406zl Default route problem

Hi
sh run
Running configuration:

; J8697A Configuration Editor; Created on release #K.14.33

hostname "Router5406zl"
module 1 type J8702A
module 2 type J8702A
module 3 type J8702A
module 4 type J8702A
interface C1
name "Passport_4400"
exit
interface C2
name "Network_Disk"
exit
interface C4
name "Orhan"
exit
interface C6
name "PRI_SesKayit"
exit
interface C7
name "Analog_SesKayit"
exit
interface C11
name "Sureyya"
exit
interface C20
name "Firewall_Local"
exit
interface C24
name "IDBMEVBANK"
exit
interface A1
name "Web_Server_Local"
exit
interface A3
name "IDBAPL_1"
exit
interface A5
name "Bulent"
exit
interface A7
name "18Broker"
exit
interface A8
name "Ets_Server"
exit
interface A9
name "Test_Masasi"
exit
interface A10
name "DatabaseSQL"
exit
interface A11
name "366Broker"
exit
interface A12
name "Tolga"
exit
interface A13
name "IBS"
exit
interface A14
name "Euroline"
exit
interface A15
name "Foreks"
exit
interface A16
name "Matriks"
exit
interface A18
name "Kameralar"
exit
interface A19
name "VPN_Local"
exit
interface A21
name "4000M"
exit
interface A22
name "File_Server_Samba"
ip access-group "no-http" in
exit
interface A24
name "Takas_MRTG"
exit
interface B1
name "Takas_Router"
speed-duplex 100-full
exit
interface B2
name "IDB_Vob_Takas"
speed-duplex 100-full
exit
interface B3
name "IDB_VOB2_Takas"
speed-duplex 100-full
exit
interface B4
name "Umur_Takas"
speed-duplex 100-full
exit
interface B5
name "Murat_Takas"
speed-duplex 100-full
exit
interface B6
name "Ali_Takas"
exit
interface B7
name "Mesut_Takas"
exit
interface B8
name "Selma_Takas"
exit
interface B9
name "Webtest_server"
exit
interface B10
name "tolga"
exit
interface B15
name "IDB_VOB2_internet"
exit
interface B16
name "Doruk_Voice"
exit
interface B17
name "Weltech_Musteri"
exit
interface B18
name "P109-DNS-FTP(T)"
exit
interface B20
name "VPN_INTERNET"
exit
interface B21
name "P110-WEB(T)"
exit
interface B22
name "RouteFW"
exit
interface B23
name "P120-MAIL(T)"
exit
interface B24
name "P113-FIREWALL(T)"
exit
interface D5
name "Phonex"
exit
interface D10
name "Whatsup"
exit
interface D17
name "IDB_VOB2_Local"
exit
interface D18
name "IDB_VOB1_Local"
exit
interface D22
name "Fax_Server"
exit
ip routing
no ip source-route
vlan 1
name "DEFAULT_VLAN"
untagged A1-A23,C1-C24,D1-D24
qos priority 7
ip address 195.33.224.3 255.255.255.0
no untagged A24-B24
exit
vlan 2
name "Takas"
untagged A24-B8
qos priority 7
no ip address
exit
vlan 4
name "TTNET"
untagged B9-B12,B15-B24
qos priority 4
no ip address
exit
vlan 5
name "HD"
untagged B13-B14
no ip address
exit
exit
qos protocol IP priority 7
qos type-of-service ip-precedence
ip load-sharing 2
no dhcp-relay hop-count-increment
qos device-priority 195.33.224.1/0 priority 7
qos device-priority 195.33.224.253/0 priority 7
qos device-priority 195.33.224.19/0 priority 7
qos device-priority 195.33.224.16/0 priority 7
qos device-priority 195.33.224.8/0 priority 7
qos device-priority 195.33.224.9/0 priority 7
qos device-priority 195.33.224.252/0 priority 7
qos device-priority 195.33.224.10/0 priority 7
qos device-priority 88.255.106.235/0 priority 7
qos tcp-port ipv4 20311 priority 7
qos tcp-port ipv4 1433 priority 7
ip route 0.0.0.0 0.0.0.0 195.33.224.7
ip route 0.0.0.0 0.0.0.0 195.33.224.251 distance 200
ip route 195.33.225.0 255.255.255.0 195.33.224.5
ip route 195.33.227.0 255.255.255.0 195.33.224.5
snmp-server community "public" unrestricted


sh ip route
XXXXXX# sh ip route

IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
0.0.0.0/0 195.33.224.7 1 static 1 1
127.0.0.0/8 reject static 0 0
127.0.0.1/32 lo0 connected 1 0
195.33.224.0/24 DEFAULT_VLAN 1 connected 1 0
195.33.225.0/24 195.33.224.5 1 static 1 1
195.33.227.0/24 195.33.224.5 1 static 1 1

Patrick Terlisten
Honored Contributor

Re: 5406zl Default route problem

Hi,

have you tried the both routing commands?

Best regards,
Patrick
Best regards,
Patrick
Tolga Cengiz
Occasional Visitor

Re: 5406zl Default route problem

it says invalid input. As follows

5406zl(config)# ip route 0.0.0.0/0 195.33.224.7 10
Invalid input: 10
5406zl(config)# ip route 0.0.0.0/0 195.33.224.251 200
Invalid input: 200

But i can give distance.

5460zl(config)# ip route 72.14.221.147 255.255.255.255 195.33.224.7 distanc
e 200
Patrick Terlisten
Honored Contributor

Re: 5406zl Default route problem

Hi,

you're right. I missed the "distance".

Best regards,
Patrick
Best regards,
Patrick
Tolga Cengiz
Occasional Visitor

Re: 5406zl Default route problem

I think that route can not siwcth the multiple defaul
Pieter 't Hart
Honored Contributor

Re: 5406zl Default route problem

You cannot use two default-routes for load-balancing!

the switch will use only the "lowest distance" default-route.
unless this destination is down then it may switch to the other defaul-route.

for load balancing you will need to configure a routing protocol.
Tolga Cengiz
Occasional Visitor

Re: 5406zl Default route problem

Not my problem I installed load-balanc. Default route is down a second route I want to pass.
Pieter 't Hart
Honored Contributor

Re: 5406zl Default route problem

>>>
ip route 0.0.0.0 0.0.0.0 195.33.224.7
ip route 0.0.0.0 0.0.0.0 195.33.224.251 distance 200
<<<

I think that you only see a single default route in your "show ip route" because both destination routers are in the same subnet!
this route is only down when the router itself is detected down.
only then you may see the default route switch to the "distance-200" router.
As the subnet itself stays reachable it may not work as you want it

I suggest you create another subnet(/vlan) to connect the second router.
then you probably see both 0.0.0.0 routes with different "distance".

alternatively you can look if you can configure HSRP or VRRP on the linux systems to present a single (virtual) router adress with backup.