Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

5406zl crashed

Bruce Campbell_3
Valued Contributor

5406zl crashed


We have a 5406zl running K.11.33,
doing routing, ospf and rip, and
it crashed with:

Software exception at rt_table.c:758 -- in 'eRouteCtrl', task ID = 0x8ad6b30
-> Routing Task: Route Destinations exceeded

I have a case open (100908-134977)
but it hasn't lead to a resolution yet.

Any good/bad experience doing routing
on the 5400zl series out there ?

Bruce Campbell
Director, Network Services
Information Systems and Technology
MC 1018
(519)888-4567 x38323
University of Waterloo, Waterloo, ON
10 REPLIES
Mohieddin Kharnoub
Honored Contributor

Re: 5406zl crashed

Hi
Since you are using the OSPF with the 5406, then you have the Premium Edge License for the 5400 Series (J8994A)?

Have you tried to configure a Syslog server to track the events, you may get good info. from the debug commands also.

Why don't you Reduce the number of routes in the Route Table or reconfigure the limit or maybe use CIDR.

More info about your case will help also.
Good Luck !

Science for Everyone
Bruce Campbell_3
Valued Contributor

Re: 5406zl crashed


In the case, they advised the problem was corrected in K.11.33 which is what we are
already running.

The switch has 2 peers (one RIP and one OSPF), and is routing for a single /24 subnet.
The route table has maybe 200 entries.

Bruce Campbell
Director, Network Services
Information Systems and Technology
MC 1018
(519)888-4567 x38323
University of Waterloo, Waterloo, ON
Bruce Campbell_3
Valued Contributor

Re: 5406zl crashed


(by the way, thanks for the debug idea,
I've set "debug all" now, so I may see
what happens before the next crash. It
is already syslogging. And yes it has the premium license for OSPF etc)

Bruce Campbell
Director, Network Services
Information Systems and Technology
MC 1018
(519)888-4567 x38323
University of Waterloo, Waterloo, ON
Mohieddin Kharnoub
Honored Contributor

Re: 5406zl crashed

Great news to hear that they already fixed it in the K.11.33 ??? then how come its crashing ???

Really strang, anyway i hope the debug will help you, and you can pick up the debug only for OSPF, no need to use debug all, it will be hedache to see everything going on.

Just turn in on for OSPF and RIP as well, and hopefully you will see something ...


Don't forget to assign points my friend.

Good Luck !!!
Science for Everyone
Bruce Campbell_3
Valued Contributor

Re: 5406zl crashed


This is a new bug apparently, and it has
been escalated to Engineering.

The switch consistently crashes every 371439
seconds (5 times now), with the error:

Software exception at rt_table.c:758 -- in 'eRouteCtrl', task ID = 0x8ad6b30
-> Routing Task: Route Destinations exceeded

(it has about 240 entries in the route table).

It is running RIP and OSPF.

The case number is 3215250237.

Bruce Campbell
Director, Network Services
Information Systems and Technology
MC 1018
(519)888-4567 x38323
University of Waterloo, Waterloo, ON
Bruce Campbell_3
Valued Contributor

Re: 5406zl crashed


For what its worth, the switch is now
crashing every 247716 seconds.

Bruce Campbell
Director, Network Services
Information Systems and Technology
MC 1018
(519)888-4567 x38323
University of Waterloo, Waterloo, ON
Mohieddin Kharnoub
Honored Contributor

Re: 5406zl crashed

Hi

Its bad news to hear that, i've noticed that the major Crash fixes was in Release K.11.32

In Release K.11.33 only one crash fix for ACLs, i wish if you can follow up your case with ProCurve.

Anyway the Routing Table size is 10,000 entries, and you have less than 250, but the crash is saying Destination Limits Exceeded ...

Untill Procurve replies you, i wish from you to try to reduce the Route Table, use any technique to do that, try to summarize some networks, specially that you have RIP and OSPF together, so i think there would be walk around.

Update us with your latest and Good Luck ... :)
Science for Everyone
Mohieddin Kharnoub
Honored Contributor

Re: 5406zl crashed

Some questions i have.

Have you enabled Virus throttling, or IP multicast routing or VRRP ????
Science for Everyone
Bruce Campbell_3
Valued Contributor

Re: 5406zl crashed


Below is the config for the switch.
No multicast or virus throttling.

case 3215250237 openned with HP Procurve June 20.

"show tech all" from a minute before the
crash shows the usual 250 or so entries
in the route table.



#
# IMPORTANT
#
# This configuration file is for display purposes only.
# Do not use this file for an actual switch configuration,
# as it has passwords and other private information removed
#
; J8697A Configuration Editor; Created on release #K.11.33

hostname "sci-swphy-temp"
max-vlans 64
time timezone -300
no cdp run
no web-management
module 1 type J8705A
module 2 type J8705A
module 3 type J8705A
mirror-port A2
interface A1
name "sci-swphy-1"
exit
interface A21
name "gw-cnnet (core)"
exit
interface A22
name "was sci-swopt"
exit
ip default-gateway 172.17.2.193
sntp server 10.123.65.170
ip routing
timesync sntp
sntp unicast
logging facility local3
logging 10.123.65.170
vlan 1
name "DEFAULT_VLAN"
untagged A2-A20,A23-A24,B1-B24,C1-C24
ip address dhcp-bootp
no untagged A1,A21-A22
exit
vlan 3026
name "phyxprinet"
ip address 172.17.2.204 255.255.255.192
tagged A1
exit
vlan 717
name "cnpp17"
ip address 10.123.1.66 255.255.255.252
tagged A21
exit
vlan 17
name "scilabnet"
tagged A22
no ip address
ip igmp
exit
vlan 18
name "sci-naanet"
tagged A22
no ip address
ip igmp
exit
vlan 52
name "optfl1net"
tagged A22
no ip address
ip igmp
exit
vlan 53
name "classroom1net"
tagged A22
no ip address
ip igmp
exit
vlan 65
name "scicompnet"
tagged A22
no ip address
ip igmp
exit
vlan 142
name "optnet"
tagged A22
no ip address
ip igmp
exit
vlan 700
name "scipri1net"
tagged A22
no ip address
ip igmp
exit
vlan 3022
name "optprinet"
tagged A22
no ip address
exit
vlan 73
name "scicli2net"
ip address 10.123.73.1 255.255.255.0
tagged A1
ip igmp
exit
interface A1,A21
monitor
exit
spanning-tree
spanning-tree force-version RSTP-operation
ip router-id 10.123.1.66
ip ssh
router ospf
area 0.0.0.3
area backbone
redistribute connected
restrict 172.17.2.192 255.255.255.192
exit
router rip
exit
vlan 717
ip ospf 10.123.1.66 area backbone
exit
vlan 3026
ip rip 172.17.2.204
exit
Bruce Campbell
Director, Network Services
Information Systems and Technology
MC 1018
(519)888-4567 x38323
University of Waterloo, Waterloo, ON
Bruce Campbell_3
Valued Contributor

Re: 5406zl crashed


This is now fixed:

K.11.41

ftp://ftp.hp.com/pub/networking/software/3500yl-5400zl-RelNotes-K1141-59914720.pdf

Crash (PR_1000351693) â The switch may crash with a message similar to
Software Exception at rt_table.c.758 -- in 'eRouteCtrl', task ID =
0x8a d6b30 -> Routing Task: Route Destinations exceeded
Bruce Campbell
Director, Network Services
Information Systems and Technology
MC 1018
(519)888-4567 x38323
University of Waterloo, Waterloo, ON