Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

5406zl strange inter-VLAN routing problem.

Eby
Occasional Contributor

5406zl strange inter-VLAN routing problem.

I'm having trouble with the 5406zl, i have created a new VLAN 50.

Now none of the hosts inside VLAN 50 will ping to hosts in VLAN 20 even with "IP Routing" enabled, but all can access Internet, which is VLAN 10 !!!!. Any idea what could be the problem ?.

 

J8697A Configuration Editor; Created on release #K.14.41

hostname "Core Switch"
time timezone 5
module 1 type J8706A
module 2 type J9154A
module 3 type J8706A
ip default-gateway 10.10.10.10
ip ttl 32
ip routing
vlan 1
   name "DEFAULT_VLAN"
   untagged A8-A24,C1-C24
   ip address 192.168.100.100 255.255.255.0
   no untagged A1-A7,B1-B2
   exit
vlan 10
   name "Internet"
   untagged A1,B1
   ip address 10.10.10.1 255.255.255.0
   exit
vlan 20
   name "LAN"
   untagged A2-A6,B2
   ip address 192.168.0.1 255.255.255.0
   ip igmp
   exit
vlan 50
   name "LAB"
   untagged A7
   ip address 192.168.10.1 255.255.0.0
   ip igmp
   exit
ip route 0.0.0.0 0.0.0.0 10.10.10.10
snmp-server community "public" unrestricted
spanning-tree
no autorun
password manager

 Note. Default VLAN is not used.


Any help is appreciated.

3 REPLIES
Fredrik Lönnman
Honored Contributor

Re: 5406zl strange inter-VLAN routing problem.

Your networks are overlapping. You can't have 192.168/16 in vlan50 and 192.168.0/24 in vlan20 in the same time. I'm surprised it even let you configure it that way.

---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

Eby
Occasional Contributor

Re: 5406zl strange inter-VLAN routing problem.

Sorry, It is a mistake I made while typing in the forum. The subnet mask is /24 for "LAB" VLAN, so there is no overlapping.

10.10.10.10 is the Firewall and there are no ACL anywhere in the switch.

TB_Hunter
Visitor

Re: 5406zl strange inter-VLAN routing problem.

Try taking out the ip default-gateway.

 

I remember this from somewhere else.  If you were not routing, then you would use the default-gateway command, but since you have IP routing and an ip route, you should not need the gateway command.