Switches, Hubs, and Modems
1752320 Members
5284 Online
108786 Solutions
New Discussion

7102dl 2 x LAN 2x ADSL strange problem

 
theputto
New Member

7102dl 2 x LAN 2x ADSL strange problem

Hi Guys,

I have an interesting problem with my 7102 dl. I have the 2 lan interfaces enabled and ip policies sending traffic from each lan to a different adsl connection. The problem i am having is weird, traffic between the 2 lan interfaces routes fine when both ADSL connections are live, if you unplug 1 adsl connection, the route between the lans continue working, the problem occurs if 1 adsl connection goes down and the router is rebooted or switched off, traffic from lan 1 to lan 2 stops, if you plug the adsl connection in traffic starts again.....any help would be greatly appreciated here is my config


interface eth 0/1
ip address 192.168.0.1 255.255.254.0
access-policy Private
ip access-group trust-to-untrust in
no shutdown
!
!
interface eth 0/2
encapsulation 802.1q
no shutdown
!
interface eth 0/2.1
description management
vlan-id 10 native
no shutdown
ip address 10.0.0.1 255.255.254.0
ip policy route-map ppp2-trafic-from-10.0.0.0
access-policy ppp2

interface eth 0/2.2
description wireless
vlan-id 20
no shutdown
ip address 192.168.2.1 255.255.254.0
ip policy route-map ppp2-trafic-from-10.0.0.0
access-policy ppp2

interface eth 0/2.3
description other servers
vlan-id 40
no shutdown
ip address 192.168.4.1 255.255.254.0
ip policy route-map ppp2-trafic-from-10.0.0.0
access-policy ppp2
ip access-group VLAN_40_INT in

!
!
interface adsl 1/1
description "Net1"
no shutdown
interface adsl 2/1
description "Net2m"
no shutdown
!
!
interface atm 1 point-to-point
description Net1
no shutdown
bind 1 adsl 1/1 atm 1
!
interface atm 1.1 point-to-point
no shutdown
pvc 8/35
no ip address
!
!
interface atm 2 point-to-point
description Net2
no shutdown
bind 2 adsl 2/1 atm 2
!
interface atm 2.1 point-to-point
no shutdown
pvc 8/35
no ip address
fair-queue
!
interface ppp 1
ip address negotiated
access-policy Public
no fair-queue
ppp pap sent-username blank@l.Net1.com.au password encrypted
mtu 1492
no shutdown
bind 3 atm 1.1 ppp 1 pppoe-client
!
interface ppp 2
description net 2
ip address negotiated no-default
access-policy Public
no fair-queue
ppp pap sent-username blank@net2.com.au password encrypted
mtu 1492
no shutdown
bind 4 atm 2.1 ppp 2
!
!
!
!
!
route-map ppp2-trafic-from-10.0.0.0 permit 1
match ip address NAT-PPP2
set default interface ppp 2
!
!
!
!
ip access-list standard wizard-ics
remark NAT list wizard-ics
permit any
!
!
ip access-list extended NAT-PPP2
permit ip 10.0.0.0 0.0.1.255 any log
permit ip host 192.168.4.30 any
permit ip host 192.168.4.31 any
deny ip any any
!

!
ip access-list extended self
remark Traffic to ProCurve SR
permit ip any any
!
ip access-list extended trust-to-untrust
permit ip ***********
deny ip any any
!

ip policy-class ppp2
nat source list NAT-PPP2 interface ppp 2 overload
!
ip policy-class Private
allow list self self
nat source list wizard-ics interface ppp 1 overload
!
ip policy-class Public