Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

7102dl NATnot working?

SOLVED
Go to solution
Ryan_G
Frequent Advisor

7102dl NATnot working?

Hi All

Ive configured a 7102 with single ADSL. The ADSL connection is working and I can ping from the router to hostname and IP. However, my test client can't. My client can however, ping the router, attach to its http server etc.

The clients default gateway is the router and its DNS is the router.

Furthermore, I have a previous connectioni was using at it worked fine and I can not see a difference. The config is posted below.

I believe it has to to a NAT issue or internet sharing.

Thanks in advance for the advise.

!
!
hostname "ProCurveSR7102dl"
enable password -------
!
clock timezone +10-Brisbane
!
ip subnet-zero
ip classless
ip routing
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
no service password-encryption
!
username "manager" password "-------"
!
!
ip firewall
no ip firewall alg h323
!
!
!
!
!
no autosynch-mode
no safe-mode
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 192.168.10.254 255.255.255.0
access-policy Private
no shutdown
!
!
interface eth 0/2
no ip address
shutdown
!
!
!
interface adsl 1/1
description "ATCGC"
no shutdown
interface adsl 2/1
shutdown
!
!
interface atm 1 point-to-point
no shutdown
bind 1 adsl 1/1 atm 1
!
interface atm 1.1 point-to-point
no shutdown
pvc 8/35
no ip address
!
interface ppp 1
ip address negotiated
access-policy Public
no fair-queue
ppp chap hostname ------
ppp chap password ------
no shutdown
bind 2 atm 1.1 ppp 1
!
!
!
!
!
!
!
!
ip access-list standard wizard-ics
remark Internet Connection Sharing
permit any
!
!
ip access-list extended self
remark Traffic to ProCurve SR
permit ip any any log
!
ip access-list extended wizard-pfwd-1
remark Port Forward 1
permit tcp any host 121.50.211.62 eq smtp log
!
ip policy-class Private
allow list self self
nat source list wizard-ics interface ppp 1 overload
!
ip policy-class Public
nat destination list wizard-pfwd-1 address 192.168.11.23
!
!
!
no ip tftp server
ip http server
no ip http secure-server
no ip snmp agent
no ip ftp agent
!
!
!
!
!
!
!
ip sip
ip sip proxy
!
line con 0
no login
!
line telnet 0 4
login
password --------
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
end


3 REPLIES
Ryan_G
Frequent Advisor

Re: 7102dl NATnot working?

I have fiddled with for access-policies etc. This looks a little more correct. But still does not work.

Can anyone help please.

!
!
hostname "ProCurveSR7102dl"
enable password ------
!
clock timezone +10-Brisbane
!
ip subnet-zero
ip classless
ip routing
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
no service password-encryption
!
username "manager" password "------"
!
!
ip firewall
no ip firewall alg h323
!
!
!
!
!
no autosynch-mode
no safe-mode
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 192.168.10.254 255.255.255.0
access-policy FROM-LAN
no shutdown
!
!
interface eth 0/2
no ip address
shutdown
!
!
!
interface adsl 1/1
description "ATCGC"
no shutdown
interface adsl 2/1
shutdown
!
!
interface atm 1 point-to-point
no shutdown
bind 1 adsl 1/1 atm 1
!
interface atm 1.1 point-to-point
no shutdown
pvc 8/35
no ip address
!
interface ppp 1
ip address negotiated
access-policy Public
no fair-queue
ppp chap hostname ------
ppp chap password ------
no shutdown
bind 2 atm 1.1 ppp 1
!
!
!
!
!
!
!
!
ip access-list standard wizard-ics
remark Internet Connection Sharing
permit any
!
!
ip access-list extended lan-acl
remark used for Nat
permit ip any any
!
ip access-list extended self
remark Traffic to ProCurve SR
permit ip any any log
!
ip access-list extended wizard-pfwd-1
remark Port Forward 1
permit tcp any host 121.50.211.62 eq smtp log
!
ip policy-class FROM-LAN
nat source list lan-acl interface ppp 1 overload
!
ip policy-class Private
allow list self self
nat source list wizard-ics interface ppp 1 overload
!
ip policy-class Public
nat destination list wizard-pfwd-1 address 192.168.11.23
!
!
!
no ip tftp server
ip http server
no ip http secure-server
no ip snmp agent
no ip ftp agent
!
!
!
!
!
!
!
ip sip
ip sip proxy
!
line con 0
no login
!
line telnet 0 4
login
password ------
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
end

Matt Hobbs
Honored Contributor
Solution

Re: 7102dl NATnot working?

Try 'ip domain-proxy', otherwise the 7000dl will not proxy DNS information to your client.
Ryan_G
Frequent Advisor

Re: 7102dl NATnot working?

So Simple. Thanks Matt.


10 points to you!