Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

7102dl Problems with routing

AlanR
Occasional Visitor

7102dl Problems with routing

I am a complete novice when it comes to this router. What I am trying to do is connect it via a single ADSL line then connect it to another router. This router to be totally exposed on all Ports (Its a Checkpoint Edge).

I cannot get the HP router to route!
I get the ADSL line to come up
I get connected via the ethernet port (direct cable connection)
But nothing routes. I enclose my current configuration.
7 REPLIES
Jeff Carrell
Honored Contributor

Re: 7102dl Problems with routing

hmm...i don't see an ip addr on the atm interface...did i miss something?

cheers...jeff
Jeff Carrell
Honored Contributor

Re: 7102dl Problems with routing

and i also don't see an ip addr on the adsl line (sorry i didn't send this as 1 reply)...

...jeff
AlanR
Occasional Visitor

Re: 7102dl Problems with routing

I said I am a Novice when it comes 7102dl router! We bought a package from BT (our ISP) and they gave us:
Router Adddress x.x.x.136
Default Gateway x.x.x.142

Useable ip range x.x.x.137 to x.x.x.141
Subnet of 255.255.255.248

The 7102dl won't allow me to enter x.x.x.136 with a subnet of 255.255.255.248 (says invalid subnet)

So I specified no ip and the status of the ADSL connection says its all up: what next?
Jeff Carrell
Honored Contributor

Re: 7102dl Problems with routing

ah...

the ip addr you need to enter would be x.x.x.137 255.255.255.248 (1st usable addr in the subnet)

in an ip subnet, the 1st addr (.136) is the "network" and the last addr (.143) is the "broadcast"...meaning you don't actually use the 1st or last addr...

it appears that the ISP is using .142 on their end, so you can use any of the addr from .137 thru .141...


the adsl connection indicating its up is probably just the adsl line protocol sync'ing...but no ip yet...

i'm surprised that BT didn't provide the router already configured or at least a template for you...


btw, working with ip addr its sometimes handy to have a subnet calculator :-)

here's a link for some handy network tools:

www.thenetworktoolbox.com no warranty, your mileage may vary :-)

also, check out this procurve link for adsl config examples, maybe they will assist as well:
http://www.hp.com/rnd/support/config_examples/7000dl.htm

hth...jeff
AlanR
Occasional Visitor

Re: 7102dl Problems with routing

But...I currently have the ADSL line configured with a BT Business-Hub and it doesn't use an ip-address. I still have the five available- which was why I thought that I didn't have use one. Do I have use one on the router- it cannot be x.x.x.137 because thats my end of a VPN.
AlanR
Occasional Visitor

Re: 7102dl Problems with routing

Sorry but I have just done an analysis of the BT-Business Hub & it does get its address via DHCP - so I'll try that and figers crossed
AlanR
Occasional Visitor

Re: 7102dl Problems with routing

I have created the configuration to have a DHCP address from BT and it still does not route. I am exasperated. All I need from the device is the adsl connection and to route everything to my 10.0.0.1 network and vice-versa: I foolishly thought that would be simple.

I enclose the running config

ProCurveSR7102dl#show running-config
Building configuration...
!
!
! ProCurve Secure Router 7102dl SROS version J06.06
! Boot ROM version J06.06
! Platform: ProCurve Secure Router 7102dl, part number J8752A
! Serial number US514TR215
! Flash: 33554432 bytes DRAM: 134217727 bytes
! Date/Time: Mon Sep 29 2008, 18:13:33 CEST
hostname "ProCurveSR7102dl"
no enable password
clock timezone +1-Amsterdam
ip subnet-zero
ip classless
ip routing
event-history on
no logging forwarding
no logging email
logging email priority-level info
no service password-encryption
username "****" password "****"
no ip firewall alg msn
no ip firewall alg h323
no autosynch-mode
no safe-mode
interface eth 0/1
ip address 10.0.0.1 255.255.255.0
no shutdown
interface eth 0/2
no ip address
shutdown
interface adsl 1/1
no shutdown
interface atm 1 point-to-point
no shutdown
bind 1 adsl 1/1 atm 1
interface atm 1.2 point-to-point
no shutdown
pvc 0/38
no ip address
fair-queue
interface ppp 2
ip address negotiated no-default
no fair-queue
ppp chap hostname -------
ppp chap password -------
no shutdown
bind 3 atm 1.2 ppp 2
ip route 0.0.0.0 0.0.0.0 ppp 2

no ip tftp server
no ip tftp server overwrite
ip http server
no ip http secure-server
no ip snmp agent
no ip ftp server
ip ftp server default-filesystem flash
no ip scp server
no ip sntp server
ip sip
ip sip proxy
line con 0
no login
line telnet 0 4
login
no shutdown
line ssh 0 4
login local-userlist
no shutdown
end
ProCurveSR7102dl#