Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

7102dl is NAT'ing when it shouldnt!?!?

paladin_uth
Occasional Visitor

7102dl is NAT'ing when it shouldnt!?!?

We need to disable the NAT on the 7102dl’s configuration that is attached and have it classically route the packets. The
WAN side is a private network connected to a carrier that is supplying an ATM DSL 2+ service that is connected to a fiber network with 2610’s attached.

The private network work works fine between switches and the router’s current config allows a user on its LAN side to communicate to the WAN side of the network. The issue comes when a user in the WAN side on a 2610 tries to find a PC connected on the LAN side of this router. The router is trying to NAT instead of route the incoming traffic. i.e. an outgoing resposne shows as the systems WAN ip with a nat port number and incoming trace routes show the traffic hitting the WAN side of the router.

ip subnet-zero
ip classless
ip default-gateway 172.29.117.252
ip routing
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
no service password-encryption
!
username "admin" password "Serv1tel"
username "manager" password "Serv1tel"
ip forward-protocol udp time
ip forward-protocol udp nameserver
ip forward-protocol udp tacacs
ip forward-protocol udp tftp
ip forward-protocol udp netbios-ns
ip forward-protocol udp netbios-dgm
!
no ip firewall alg h323
no ip firewall alg sip
!
no autosynch-mode
no safe-mode
!
interface eth 0/1
ip address 172.29.117.254 255.255.255.0
no shutdown
!
interface eth 0/2
no ip address
no shutdown
!
interface adsl 1/1
description "TransACT"
no shutdown
!
interface atm 1 point-to-point
description TRANSACT
no shutdown
bind 1 adsl 1/1 atm 1
!
interface atm 1.1 point-to-point
no shutdown
pvc 8/36
atm routed-bridged ip

ip address 192.168.10.7 255.255.255.0
bandwidth 1654
!
!
ip route 0.0.0.0 0.0.0.0 172.29.117.252
ip route 172.29.116.0 255.255.255.0 192.168.10.10

Thank you in advance!
1 REPLY
Olaf Borowski
Respected Contributor

Re: 7102dl is NAT'ing when it shouldnt!?!?

I can guarantee you that with this config, the router is not NATing. You have to enable the firewall and define policies to NAT. They don't exist in this config.
Simple test:
Issue a "show ip policy-session". Empty = not NATing.