Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

802.1Q VLAN with mixed Cisco HP switches

Dale Magnant
Occasional Advisor

802.1Q VLAN with mixed Cisco HP switches

Hello,

I have a site with a small LAN comprised of a Cisco 3550 and a number of Cisco 2950 switches. I would like to introduce a couple HP Procuve switches, either 26xx or 28xx series. Can anyone comment as to whether they have had problems running 802.1Q VLANs over mixed brand switches like this? Or, whether they have had any other noteworthy problems mixing HP and Cisco switches of these series?

Thank You
7 REPLIES
Jeff Carrell
Honored Contributor

Re: 802.1Q VLAN with mixed Cisco HP switches

Mixing Cisco and HP Networking switches together with 802.1Q is not an issue, it all works very well. 802.1Q is a standard.

Now, what is different is the terminology: on Cisco, assigning ports to vlans that are 802.1Q is called a "trunk" port. HP (ProCurve switches) defines a port in a vlan supporting 802.1Q as a "tagged" port. They mean the same and interoperate with no problem. On Cisco, a non-802.1Q port is defined as an "access" port, while on a ProCurve switch it is defined as an "untagged' port.

There is one area to be mindful of, Cisco by default uses PVST+/RPVST+ for its spanning tree protocol which is not an industry standard, therefore not available on HP (nor basically anyone else).

So, if you need STP between these environments, you need to pay careful attn to how you interconnect the two different platforms together.

Ref this link and look at the bottom in the "other" section for a couple of white papers that discusses this topic in more detail. It is not an issue that it can't be done, but it does have a few challenges to be aware of. http://www.procurve.com/library/whitepapers.aspx


hth...Jeff
Dale Magnant
Occasional Advisor

Re: 802.1Q VLAN with mixed Cisco HP switches

Jeff,

Thank you very much for the speedy and thorough reply. Sounds like it should not be an issue as far as the VLANs are concerned. Having both an HP and a Cisco LAN I've gotten fairly well adjusted to the VLAN nomenclature differences - though it is an adjustment. At present I don't have any redundancy built into the Cisco LAN so the STP piece should not be an issue.

One more question comes to mind - and again, since we're dealing with standards I would hope there would not be any issues, but experience usually trumps standards: The existing Cisco LAN has a mix of the older full size 'GBIC' and the newer 'SFP' class transceivers (all LX) - mostly Cisco, with, I believe, a few Axiom. Somewhere in the back of my mind it seems I've heard that brand x transceivers don't always play well with brand y transceivers - or that it is at least wise to have matching brand (and of course matching standard) transceivers on each end of a link. Now, I will likely be adding HP transceivers in the mix, some of which will be talking with Cisco transceivers on the other end. In your experience, have mixed brand transceiver links been an issue?

Thanks again,
Jeff Carrell
Honored Contributor

Re: 802.1Q VLAN with mixed Cisco HP switches

Dale asked: " have mixed brand transceiver links been an issue?"

I have not seen this to be an issue unto itself, but anytime you deal with fiber connections it can be simple things like dB loss on the link, dirty connections, mis-aligned connections, etc., that causes issues. The basic conversion of electrons to light that is done in the transceivers is defined in a standard (don't say which).

One important note. On ProCurve products you MUST use HP transceivers. Any other brand will plug-in ok, but will not be recognized. I have heard there are 3rd party 100% compatible that have said they will work, but I personally have no experience or knowledge if they do. AND there are up to 3 versions of HP mini_GBICs (rev A, B, C) verify on your ProCurve products which ones are _required_, meaning don't just buy some from a source and then discover that the Rev A may not work on a newer switch (ask me how I know).

hth...Jeff
Jari Savela
Occasional Visitor

Re: 802.1Q VLAN with mixed Cisco HP switches

We're having a problem with VLANs with Cisco 2960/4503SUP2+TS vs. HP 2626. The problem is that the mac addresses of certain VLANs behind the HP switch aren't advertised to the Cisco switches. The problem started all of the sudden and hit two VLANs at first about 6 months ago. Just two days ago it hit one more VLAN and I was forced to replace the HP's with Cisco 2960 because couldn't figure out what the problem was... No configuration changes were done to any of these equipment at that time.

Earlier when I had 4503 vs. HP2626 I could go around the problem by adding stating MAC entries to 4503. Now I've replaced the HP that was connected to the 4503, with a Cisco 2960. But now the HP's connected to this 2960 won't advertise the MAC addresses of these VLANs and although I added the static entries to the 2960, it won't work anyway.

No spanning-tree is in use in HP's, the VLAN taggings are correct in HP's, no VTP pruning in Cisco switches and no differences in the configuration of VLANs that work or don't.

I think HP switches can be used with Cisco in the same network with no problems, but I would'nt recommend spanning the same VLANs over them. Go either way but don't go both ways...

- J -
Jari Savela
Occasional Visitor

Re: 802.1Q VLAN with mixed Cisco HP switches

Cancel that... I went through the configurations once more and found out that one of the HP2626's had these two VLANs as Auto instead of Tagged. These have been configured originally as Tagged (checked it again when the two VLANs started malfunctioning) and I have no idea when this has changed and why. I'm using Kiwi to backup the configurations and it hasn't reported of any changes on those switches.

But I still think you'd be better off with a homogenic network instead of a mixed one. =)

- J -
cenk sasmaztin
Honored Contributor

Re: 802.1Q VLAN with mixed Cisco HP switches

hi Dale
simple config for you
Cisco 2950 and ProCurve 5400

CISCO 2950 CONF.*****************************************************

Current configuration : 1298 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
switchport trunk allowed vlan 1-3
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 10.0.11.1 255.255.255.0
no ip route-cache
!
ip http server
!
!
line con 0
line vty 5 15
!
end


HP CONF.************************************
vlan 1
name "DEFAULT_VLAN"
untagged A1,A4-A24
ip address 10.0.11.2 255.255.255.0
no untagged A2-A3
exit
vlan 2
name "VLAN2"
untagged A2
tagged A20
no ip address
exit
vlan 3
name "VLAN3"
untagged A3
tagged A20
no ip address
exit
cenk

Gerhard Roets
Esteemed Contributor

Re: 802.1Q VLAN with mixed Cisco HP switches

Hi Dale

This might help you
http://h10144.www1.hp.com/docs/training/HP-Networking-and-Cisco-CLI-Reference-Guide_June_10_WW_Eng_ltr.pdf

^^^ Shows you the cli differences in term of thinking about features.

http://h10144.www1.hp.com/docs/security/Migrating_from_Cisco_to_ProCurve_Apr_08_AM_Eng_Ltr.pdf

Will also help you a lot especially of what to do with spanning-tree.

I know it is a lot of reading but it should really help you.

Gerhard