Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

9308 - 2548 / VLANS over Trunk

SOLVED
Go to solution
Alan Skaarup_1
Occasional Contributor

9308 - 2548 / VLANS over Trunk

How du you setup a trunk between a 9803 and a 2548 on two gigaports and then configure untagged VLAN1 and 20 tagged VLANS?

Regards
/Alan
2 REPLIES
Ron Kinner
Honored Contributor
Solution

Re: 9308 - 2548 / VLANS over Trunk

I assume you are trying to use a pair of ports on each switch to act as a trunk carrying all 21 VLANS and you are not using GVRP.

Your best bet is to use FEC on each side.

trunk trk1 fec 1-2

should create a trunk called trk1 using fec with port 1 and 2 (Adjust the format for the port list as required by the switch.)

now you just add the trk1 to the list of tagged ports for each VLAN except the default one which you add as untagged. trk1 is a special reserved name on the switch and is used just like a port number in a port list.

Repeat on the other side

Ron
Alan Skaarup_1
Occasional Contributor

Re: 9308 - 2548 / VLANS over Trunk

Ron

vlan 2 tagged ?

the command didn't show you could add a trunk 'trk1', neither in the manual, only
Ethernet
but with your hint I made it.

Config for the trunk:


switch2848(config)# trunk 47-48 trk1

switch2848(config)# vlan 2 tagged ?
[ethernet] PORT-LIST Enter a list of ports or one port for the 'tagged'
command/parameter.


switch2848(config)# vlan 2 tagged trk1
switch2848(config)# vlan 3 tagged trk1
....
....

vlan 1
name "DEFAULT_VLAN"
untagged 45-46,Trk1
ip address 192.168.65.25 255.255.255.0
no untagged 1-44
exit
vlan 2
name "DEFAULT"
tagged 45-46,Trk1
exit
vlan 3
name "TLF"
tagged 45-46,Trk1
exit
...
...
...

----------------------------------------

9308switch

trunk switch ethe 1/1 to 1/2
trunk switch ethe 1/3 to 1/4
trunk switch ethe 1/5 to 1/6
trunk switch ethe 1/7 to 1/8

!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
spanning-tree
!
vlan 2 name DEFAULT by port
tagged ethe 1/1 to 1/8
router-interface ve 2
spanning-tree
!
interface ethernet 1/1
dual-mode
!
interface ethernet 1/3
dual-mode
!
interface ve 1
ip address 192.168.65.1 255.255.255.0
ip helper-address 1 172.16.142.82
!
interface ve 2
ip access-group 104 in
ip address 172.17.143.1 255.255.255.0
ip helper-address 1 172.16.142.82
!

Thanks
/Alan