Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

AP 420 VLAN issue

SOLVED
Go to solution
Brann Mitchell
Occasional Advisor

AP 420 VLAN issue

It should be pretty simple, I suppose. I have an AP420 with two VLAN's on the WLAN, one for guests and another for

staff (VLAN 2 and 100, respectively). The guests are buck naked with no authentication, the staff are WPA+TKIP

w/passphrase. The AP is at 2.2.3 as of this afternoon, and I can authenticate to both just fine.

Associated 'stations' are always logged as VLAN 0 for some reason, but I'm not convinced that's the issue.

The switch the AP is plugged into, a 2600-8PWR, has VLAN 2 and 100 tagged on the incoming port, which is what I assume needs to be done. However, this doesn't work, and no DHCP for the clients.

I feel like I'm missing something very simple!
2 REPLIES
Matt Hobbs
Honored Contributor
Solution

Re: AP 420 VLAN issue

Quick cut and paste from the manual...

Most likely you haven't enabled VLAN support under the Administration tab.

Web: Enabling VLAN Support
The Management window on the Administration tab to configure VLAN support and set a management VLAN ID.

The web interface enables you to modify these parameters:

â   VLAN Enable: Sets the VLAN tagging support on the access point.

Changing the VLAN support forces a reboot.

â ¢ Disable: The access point does not tag traffic passing to the wired network and ignores the VLAN tags on any received frames.

â ¢ Static: Enables VLAN tagging. Clients are assigned to the default VLAN ID of the associated SSID interface. VLAN assignment from a RADIUS server is not allowed.

â ¢ Dynamic: Enables VLAN tagging. VLAN IDs are assigned from a RADIUS server, if configured. Otherwise, clients are assigned to the default VLAN ID of the associated SSID interface.
Brann Mitchell
Occasional Advisor

Re: AP 420 VLAN issue

Hi Matt,

DOH. Yep, that certainly was a problem.

The next problem is the routing on the switch, which I have intentionally disabled. It looks like I have to reconfigure all the switches, since everything is running in the default VLAN, and not in the wi-fi VLAN.

Thanks. It certainly was simple!