Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

APC UPS's in PCM+

SOLVED
Go to solution
Jonathan Axford
Trusted Contributor

APC UPS's in PCM+

Hi All,

All of our UPS's here have network management cards fitted.

Half of them show up in PCM+ and half of them show up as 'Unreachable'

They are all on managed subnets and all share the same SNMP and CLI details as my switches.

Has anyone set these up before? Is there anything i can be missing? It seems odd that half of them work and half don't when i have configured them all the same. All versions of firmware on the UPS's are identical aswell..

Any idea's much appreciated...

I have attached a screenshot so you can see what i mean.

Cheers
Where there is a will there is a way...
9 REPLIES
Matt Hobbs
Honored Contributor

Re: APC UPS's in PCM+

All these unreachable ones look like they're on a different subnet... if you delete them from PCM, will it rediscover them on the next discovery cycle? Otherwise I'd just check the obvious things like their default gateways are set correctly. Can you ping them from the PCM server?
Jonathan Axford
Trusted Contributor

Re: APC UPS's in PCM+

Hi Matt,

All of the devices can be reached from the PCM server. The 10.100.1.x subnet (which it can't seem to ge them on) is our main Switch subnet, There are about 20 switches on this subnet which are all discovered fine.

I have checked IP settings on the UPS and they also appear to be fine. I will delete them and see if PCM re-discovers them correctly...

Cheers
Where there is a will there is a way...
Les Ligetfalvy
Esteemed Contributor

Re: APC UPS's in PCM+

In the APC config, under Network > SNMP, what mask do you have for NMS IP?
Jonathan Axford
Trusted Contributor

Re: APC UPS's in PCM+

It doesn't ask for a mask, just either the IP or Domain name of the network management server.... which is definatley right...

Where there is a will there is a way...
Matt Hobbs
Honored Contributor
Solution

Re: APC UPS's in PCM+

For the polling in PCM by default it sends an SNMP get for the sysObjectID every 5 minutes.

In PCM, with end nodes you can't reconfigure the SNMP community names as you can with your managed switches.

What I'm guessing is that PCM may be sending an SNMP get with the wrong community name.

Try deleting the device and then doing a manual discovery where you can specify the community names again, it should re-add itself and hopefully go 'good'.
Jonathan Axford
Trusted Contributor

Re: APC UPS's in PCM+

Hi, All appears to be sorted now. I deleted all of the devices and did a manual re-discovery, they all now appear in 'End-nodes' with a green tag and a status of 'Good'

Thanks for your help guys, :-)

Where there is a will there is a way...
Les Ligetfalvy
Esteemed Contributor

Re: APC UPS's in PCM+

Just to clarify the "mask" bit... it does in fact support using a mask in place of a single IP. Looking at the online help, it says:
[quote]
IP address of the allowed NMS stations. Limits the access to the NMS or NMSs specified by the format used for the IP address.
159.215.12.1 allows only the NMS with that specified IP address to have access.
159.215.12.255 allows access for any NMS on the 159.215.12 segment.
159.215.255.255 allows access for any NMS on the 159.215 segment.
159.255.255.255 allows access for any NMS on the 159 segment.
0.0.0.0 or 255.255.255.255 allows access for any NMS (Default).
[/quote]
Jonathan Axford
Trusted Contributor

Re: APC UPS's in PCM+

Thanks for the info les, We only have one so i had just specified it by IP address.

Where there is a will there is a way...
Jonathan Axford
Trusted Contributor

Re: APC UPS's in PCM+

Excellent, checked again this morning and all appears to be well.

Thanks for your help again guys.... :-)
Where there is a will there is a way...