Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Adding VLANs is flaky on 5412zl

Techops
Occasional Visitor

Adding VLANs is flaky on 5412zl

I am having the strangest problem with my 5412zl. I need to add vlans that are all using one single DHCP server. I add a vlan, give it an IP address, like 10.103.0.1/16, and add a helper-address, like 192.168.20.2.

I created vlans 103 to 109 and 111 to 115 in this way. When I add a port to a VLAN, command "untagged g20" in the appropriate VLAN context, the workstation on this port should pick up an IP address from 192.168.20.2.

The problem is, this does not work consistently across all these VLANs. In my case, from 103 to 115, only 108, 109, 111 and 113 worked, while the config is exactly the same. The only way to fix this is to reboot the switch after the vlans have been created, but that is obviously not a production solution.

The firmware is K.13.09, ROM K.12.12

The switch config is below, your help would be greatly appreciated.
Running configuration:

; J8698A Configuration Editor; Created on release #K.13.09

hostname "5412-12-1"
snmp-server contact "techops"
snmp-server location "12th floor"
time timezone -300
web-management ssl
module 1 type J8702A
module 2 type J8705A
module 3 type J8702A
module 4 type J8702A
module 5 type J8702A
module 6 type J8702A
module 7 type J8702A
module 8 type J8702A
module 9 type J8702A
module 10 type J8702A
interface B21
lacp Passive
exit
interface B23
lacp Passive
exit
interface E16
name "port_215_w1_windows"
exit
interface A16
name "w2_windows"
exit
interface D7
name "w3_windows"
exit
interface G15
unknown-vlans Disable
exit
interface C7
name "port 130"
exit
interface C20
name "port 131"
exit
interface J2
name "w4_windows"
exit
ip default-gateway 192.168.20.177
ip routing
snmpv3 enable
snmpv3 only
snmpv3 restricted-access
snmpv3 group ManagerPriv user "coreadmin" sec-model ver3
snmp-server community "public" Unrestricted
snmp-server community "private" Unrestricted "
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24,B1-B24,C1-C24,D1-D24,E1-E16,E18-E24,F1-F24,G1-G19,G21-G22,G24-H24,I1-I24,J1-J17,J19-J24
ip address 192.168.20.1 255.255.255.0
ip address 192.168.21.1 255.255.255.0
no untagged E17,G20,G23,J18
exit

vlan 101
name "VLAN101"
untagged E17,G23,J18
ip helper-address 192.168.1.1
ip address 192.168.1.250 255.255.255.0
exit
vlan 103
name "VLAN103"
ip helper-address 192.168.20.2
ip address 10.103.0.1 255.255.0.0
exit
vlan 104
name "VLAN104"
ip helper-address 192.168.20.2
ip address 10.104.0.1 255.255.0.0
exit
vlan 105
name "VLAN105"
ip helper-address 192.168.20.2
ip address 10.105.0.1 255.255.0.0
exit
vlan 106
name "VLAN106"
ip helper-address 192.168.20.2
ip address 10.106.0.1 255.255.0.0
exit
vlan 107
name "VLAN107"
ip helper-address 192.168.20.2
ip address 10.107.0.1 255.255.0.0
exit
vlan 108
name "VLAN108"
ip helper-address 192.168.20.2
ip address 10.108.0.1 255.255.0.0
exit
vlan 109
name "VLAN109"
ip helper-address 192.168.20.2
ip address 10.109.0.1 255.255.0.0
exit

vlan 111
name "VLAN111"
ip helper-address 192.168.20.2
ip address 10.111.0.1 255.255.0.0
exit
vlan 112
name "VLAN112"
ip helper-address 192.168.20.2
ip address 10.112.0.1 255.255.0.0
exit
vlan 113
name "VLAN113"
untagged G20
ip helper-address 192.168.20.2
ip address 10.113.0.1 255.255.0.0
exit
vlan 114
name "VLAN114"
ip helper-address 192.168.20.2
ip address 10.114.0.1 255.255.0.0
exit
vlan 115
name "VLAN115"
ip helper-address 192.168.20.2
ip address 10.115.0.1 255.255.0.0
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
no ip icmp redirects
aaa authentication port-access eap-radius
radius-server host 192.168.20.3
dhcp-snooping authorized-server 192.168.20.2
sflow 2 destination 192.168.20.4 12345
sflow 2 polling A1-A24,B1-B24,C1-C24,D1-D24,E1-E24,F1-F24,G1-G24,H1-H24,J1-J24 20
sflow 2 sampling A1-A24,B1-B24,C1-C24,D1-D24,E1-E24,F1-F24,G1-G24,H1-H24,J1-J24 50
ip route 0.0.0.0 0.0.0.0 192.168.20.177
ip route 10.0.1.0 255.255.255.0 192.168.30.53
ip route 10.230.0.0 255.255.0.0 192.168.20.41
ip route 192.168.20.0 255.255.255.0 vlan 1
snmpv3 user "coreadmin"
aaa port-access authenticator B1,C20,D7,G22,J2,J14
aaa port-access authenticator B1 unauth-vid 1
aaa port-access authenticator G22 unauth-vid 1
aaa port-access authenticator active
aaa port-access supplicant B1
spanning-tree
no tftp client
no tftp server
loop-protect A1-A24,B1-B24,C1-C24,D1-D24,E1-E24,F1-F24,G1-G24,H1-H24,J1-J24
loop-protect trap loop-detected
password manager