Email Subscription Notifications Suspended Temporarily
We are in the process of making navigation in the Servers and Operating Systems forums simpler and more direct. While doing this, we have to temporarily suspend email notifications for subscriptions. If you are subscribed to one or more discussion boards or blogs in the community, please check them daily to see new content. Notifications will be turned back on in a few days. We apologize for any inconvenience this may cause. Thanks, Warren_Admin
Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Almost have vlanning going ....

Randy Saeks
Occasional Advisor

Almost have vlanning going ....

I am almost there ....

I have two switches, each with a vlan 9 setup. I am able to ping the other device from each switch (can ping 10.16.1.10 from 10.16.1.11 and vice versa) If I am on the 10.15.0.0 network, I can ping 10.16.1.10, but I can not ping 10.16.1.11.

Ports G24 and 52 link the two switches together.

Here are the two run files. Any ideas what I am missing?

8 REPLIES
Jarret Workman
Frequent Advisor

Re: Almost have vlanning going ....

Hi Randy,

Looking at the two show runs, I see that you have a routing statement on the 4208. However, I do not see an IP routing entry indicating that routing has been enabled on the 4208.

Were you intending to route on the 4208 and the 2610?

Regards,

Jarret
cenk sasmaztin
Honored Contributor

Re: Almost have vlanning going ....

hi Randy I make new config for you
plaese test and you be carefull read in config my note

cenk


------------------------
| 4208vl Configuration: |
-------------------------

Running configuration:

; J8773A Configuration Editor; Created on release #L.11.12

hostname "Maple MDF"
snmp-server contact "Randy Saeks"
module 1 type J8765A
module 2 type J8765A
module 3 type J8765A
module 4 type J8765A
module 5 type J8765A
module 7 type J9033A
module 8 type J8776A
interface G3
name "SAN_Port_1"
exit
interface G4
name "SAN_Port_1"
exit
trunk G3-G4 Trk2 LACP
ip routing***********neccessary
timesync sntp
snmp-server community "public" Unrestricted
snmp-server host 10.15.100.202 "public"
vlan 1
name "DEFAULT_VLAN"
untagged A2-A24,B1-B24,C1-C24,D1-D24,E1-E24,G1-G2,G5-G24,H1-H4,Trk2 ********connect for test pc (vlan 1 member ip address 10.15.1.81/16 dg:10.15.1.10)*****
no untagged A1
ip address 10.15.1.10 255.255.0.0
ip igmp
exit
vlan 9
name "storage"
ip address 10.16.1.10 255.255.0.0
untagged A1 *******connect for test pc (vlan 2 member ip address 10.16.1.81/16 dg:10.16.1.10)****
tagged G24,Trk2
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
ip route 0.0.0.0 0.0.0.0 10.15.1.1 *********(to internet router)***********
*******************************************************************************************
and you can must be write routing on internet router ip route 10.15.0.0 255.255.0.0 10.15.1.10
and ip route 10.16.0.0 255.255.0.0 10.16.1.10
*************************************************
spanning-tree
spanning-tree Trk2 priority 4
password manager

------------------------
| 2610 Configuration: |
------------------------

Running configuration:

; J9088A Configuration Editor; Created on release #R.11.16

hostname "Do.IDF1"
snmp-server contact "Randy Saeks"
interface 49
name "SAN_Port_1"
exit
interface 50
name "SAN_Port_2"
exit
trunk 49-50 Trk1 LACP
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 2-48,51-Trk1 ********connect for test pc (vlan 1 member ip address 10.15.1.80/16 dg:10.15.1.10)*****
no untagged 1
ip address 10.15.1.11 255.255.0.0 (this ip address only managemet not for routing)
exit
vlan 9 (no need ip address this vlan )
name "storage"
untagged 1 *******connect for test pc (vlan 2 member ip address 10.16.1.80/16 dg:10.16.1.10)****
tagged 52-Trk1
exit
spanning-tree
spanning-tree Trk1 priority 4
password manager
cenk

Randy Saeks
Occasional Advisor

Re: Almost have vlanning going ....

Ok, I am working to make the changes, and after putting in the ip routing statement, I am working to add the ip route 10.16.0.0 255.255.0.0 10.16.1.10 statement.

The switch throws back to me:

10.16.1.10 can not be switch IP address and route gateway at the same time.
Jarret Workman
Frequent Advisor

Re: Almost have vlanning going ....

Hi Randy,

It looks like the switch is complaining that you are entering 10.16.1.10 as a destination on the switch when that IP address is already present on the switch.

Cenk's configuration only uses the 4208 for routing, so you should only need the following:

The 10.16.x.x traffic should go to 10.16.1.10 as long as that is the IP address assigned to the clients NIC as their default gateway.

You should only need a route of last resort to your upstream router for unknown destinations. Something like (ip route 0.0.0.0 0.0.0.0 10.15.1.1).

As long as your clients are pointing to the correct local default gateway (10.16.1.10 or 10.15.1.10 on the 4208) then the routing should work between these two subnets. The 0.0.0.0/0 route would be for unknown destinations such as the internet.

Looking at Cenk's configuration, I believe the intent is to have the 10.15.0.0/16 10.15.1.10 and the 10.16.0.0/16 10.16.1.10 configured on your internet router as return routes (the 10.15.1.1 router). This would enable traffic coming back in from the internet to make it back to the edge device. The internet router (10.15.1.1) needs to have return routes telling where to send traffic destined for the 10.15.x.x and the 10.16.x.x networks.

Regards,

Jarret
Randy Saeks
Occasional Advisor

Re: Almost have vlanning going ....

Ok, that sounds like it makes sense.

I am really only going to have two devices in that vlan, our iSCSI SAN. I can manually configure those to use the 10.16.1.10 gateway.

Since the 4208 will know about the 10.16 network, the servers connected to the storage network should be fine, right? Or, would I want to also tag the ports as a member of the storage vlan as well?

Jarret Workman
Frequent Advisor

Re: Almost have vlanning going ....

Hi Randy,

The servers should be fine living in just one vlan as they will be routed to the storage vlan via the 4208.

If the servers are in the 10.15.0.0 network, then they would have a default gateway of 10.15.1.10.
Randy Saeks
Occasional Advisor

Re: Almost have vlanning going ....

Jarret,

Thanks!

I'll plug in a laptop or two and test out the IP changes with those devices having the numbers I want to use with oru production system and see how it goes.

cenk sasmaztin
Honored Contributor

Re: Almost have vlanning going ....

ok sory Randy ip route must be
**********************************
internet router/server to switch
10.15.0.0 255.255.0.0 10.15.1.10
10.16.0.0 255.255.0.0 10.15.1.10
**********************************
switch to internet router/server
0.0.0.0 0.0.0.0 10.15.1.1

cenk
cenk