Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Attaching ProCurve 2510-24 to 2510G-48 Produces Broadcast storm.

Purtech2_1
Occasional Contributor

Attaching ProCurve 2510-24 to 2510G-48 Produces Broadcast storm.

I was told my someone at HP to connect these two switches together, I just need a simple Ethernet cable. Everytime I have done it, I get a broadcast storm on the 2510G-48. Granted I do not wait very long, because it is a production switch, but is this normal?

I have two 2510-24's and when I attach those two, no problem. Those, however, have no other connections.

Both switches have the latest firmware.
Any ideas?
7 REPLIES
Jeff Carrell
Honored Contributor

Re: Attaching ProCurve 2510-24 to 2510G-48 Produces Broadcast storm.

Sounds as if you are creating a "loop".

Spanning Tree is disabled on most HP Networking (formerly HP ProCurve) switches by default.

Therefore, when you connect these 2 together, you will get such a broadcast storm, and within 1-3 seconds the entire network will "go down".

If you can ping from one switch to the other, (before connecting the cable) then you are creating a loop.

If you need to connect this cable, enable STP first on these 2 switches 'span' and then connect.

But then you should go through and verify how all the switches/routers are configured and connected from a STP viewpoint.

You might reference the STP thread that has been going on today for a bit more info.

hth...Jeff
Purtech2_1
Occasional Contributor

Re: Attaching ProCurve 2510-24 to 2510G-48 Produces Broadcast storm.

Jeff:

First thing I thought of. However, there is nothing else attached, except my laptop, to the 2510-24. My laptop doesn't have any other network connection.

How can there be a loop? Is there a period where a discovery is going on, then it settles? I pulled the wired because I saw all the ports on the 2510G-48 flashing like crazy and saw excess broadcasts in the logs.
Jeff Carrell
Honored Contributor

Re: Attaching ProCurve 2510-24 to 2510G-48 Produces Broadcast storm.

Purtech2 said: "How can there be a loop? Is there a period where a discovery is going on, then it settles? I pulled the wired because I saw all the ports on the 2510G-48 flashing like crazy and saw excess broadcasts in the logs."

If STP is enabled, then it is defaulted to RSTP versions which is a 6sec convergence time (listen/learn/forward-or-block).

If STP is not enabled (default) and there is a loop, like I said, in 1-3 seconds lights will "wig out", go solid, network stops.

Excess broadcasts can be many things, bad cable, bad hardware/interface, etc.

I assume you've tried various ports and cables on the 2510G-48 and 2510-24? If same results, hmmm...

Still sounds like a loop, but if it is simply one cable only between the 48 and the 24, that of course is no loop.

At this point, I can't think of anything else.

You might try to enable STP 'span' on the 2510 then connect and see what occurs.

hth...Jeff
Purtech2_1
Occasional Contributor

Re: Attaching ProCurve 2510-24 to 2510G-48 Produces Broadcast storm.

Will do thanks, Jeff. Do I enable it on both (all) switches involved?
Jeff Carrell
Honored Contributor

Re: Attaching ProCurve 2510-24 to 2510G-48 Produces Broadcast storm.

Purtech2 asked: "Do I enable it on both (all) switches involved?"

I would.

cheers...Jeff
Pieter 't Hart
Honored Contributor

Re: Attaching ProCurve 2510-24 to 2510G-48 Produces Broadcast storm.

If I understand correctly you've got a 2510G-48 and two 2510-24's.

Have you looked at the logging of the switches?
You may have run into a duplex mismatch connecting a "G"-port to a 100Mb port.
Check if you have both connecting ports set to autonegotiate speed/duple or both set to fixed speed/duplex.

>>> because it is a production switch <<<
If it's really production it could suggest the switch allready has a config that does not match the 2510-24's?
please tell us more about the config's.
BGP4
Advisor

Re: Attaching ProCurve 2510-24 to 2510G-48 Produces Broadcast storm.

a broadcast storm on link-up is a Firmware bug. Please update to 11.35 or later

Kind regards
BGP4