Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco 1812 4 * VLAN to ProCurve 2524

Torsten Hellwig 02
Occasional Visitor

Cisco 1812 4 * VLAN to ProCurve 2524

Hello

I have the following problem, I try to connect a Procurve 2524 with 4 Links (seperate VLANs) to a Cisco 1812 (Working as Router between the VLANs.)

Config HP2524
Port 1-6 untagged VLAN ID3
Port 7-12 untagged VLAN ID4
Port 13-18 untagged VLAN ID6
Port 19-24 untagged VLAN ID1 Default VLAN
Port 25 untagged VLAN ID1 Default VLAN Uplink next Switch

Cisco 1812

interface FastEthernet2
description VLAN2 10.128.128.0/20
switchport access vlan 2
!
interface FastEthernet3
description VLAN3 172.16.0.0 /24
switchport access vlan 3
duplex full
!
interface FastEthernet4
description VLAN4 172.16.1.0/24
switchport access vlan 4
!
interface FastEthernet6
description -> procurve Port 19
switchport access vlan 6

!
interface Vlan3
ip address 172.16.0.2 255.255.255.0
!
interface Vlan4
ip address 172.16.1.3 255.255.255.0
!
interface Vlan2
ip address 10.128.128.1 255.255.240.0
!
interface Vlan5
ip address 192.168.77.1 255.255.255.0
!
interface Vlan6
description -> VoiceVLAN
ip address 192.168.10.1 255.255.255.0


As soon as I activate the VLAN configuration on the ProCurve, I have an interruption in the network traffic.
If i try to ping the different VLANs from the default VLAN, some of the packets are lost.And I got no stable network connection.

If I leave all port in the default VLAN everything is working.


What could be reason?

kind regards

Torsten
3 REPLIES
Gerhard Roets
Esteemed Contributor

Re: Cisco 1812 4 * VLAN to ProCurve 2524

Hi Torsten

This in the config of the Cisco bugs me a bit ...

interface FastEthernet3
description VLAN3 172.16.0.0 /24
switchport access vlan 3
duplex full

This does seem asymmetric to the rest.

Just a quick hunch.

HTH
Gerhard
Gerhard Roets
Esteemed Contributor

Re: Cisco 1812 4 * VLAN to ProCurve 2524

Hi Torsten

I Have to add the HP has vlans
1,3,4,6

The Cisco has vlans
2,3,4,5,6

I do realize the since you are not using the tags it is really a bit immaterial. But using different Vlan numbers between the configs does make troubleshooting a bit cumbersome.

Also the Cisco has more Vlans than the HP. A bit odd, I thought to mention it.

HTH
Gerhard
Torsten Hellwig 02
Occasional Visitor

Re: Cisco 1812 4 * VLAN to ProCurve 2524

Hi Gerhard,

I am not using tagged VLAN because, the Cisco 1812 is not able work with link aggregation and tagged VLAN on it.

I will correct the Duplex Settings and the VLAN IDs, but it will take a while because i need a downtime. But that will probably not fix my problem.

I think the problem has something to do with the spanning tree protocol, because the hp 2524 does not support spanning tree per VLAN.

Thanks for you help.

kind regards

Torsten