Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco and HP VLAN Question

SOLVED
Go to solution
Eric Cornwell
Occasional Advisor

Cisco and HP VLAN Question

Hello!
I am currently doing some research into setting up VLAN's for my company. Here is the hardware and the configuration of my test bench.
Cisco:
2611 Router
2950 Switch (2)
HP:
2524 Switch

I started with the Cisco hardware and have each switch set as it's own VLAN (2,3,4). The router is hooked up to VLAN2 and set as a "trunk". The other switches are hooked up to the main switch in the same fasion as the router. The second 2950 is VLAN3 and the 2524 is VLAN4. I have the router setup as a dhcp server to give out a different subnet to each VLAN. When I plug a pc into either of the Cisco's I get the proper IP. If I plug a pc into the HP I don't get anything. I have half the ports set as untagged on the Default-Vlan and the other half as Untagged on VLAN4. The main (trunk) port I have set for all vlans tagged. I don't know what else to do to get a pc to see any other device. The real kicker is each VLAN interface can get a DHCP address with the correct subnet/vlan but a PC can't. If I plug the pc into either the Default or VLAN4 still nothing.
Any ideas?
Thanks!
6 REPLIES
Markku Leinio
Valued Contributor

Re: Cisco and HP VLAN Question

Please post "show run" from each device, I think that would help at this point.
Eric Cornwell
Occasional Advisor

Re: Cisco and HP VLAN Question

I'm not going to post everything (I have to type it all) but here is the important info. This is the Cisco switch:

vtp mode transparent

vlan 2
name VLAN2-Test
!
vlan 3
name VLAN3-Test
!
vlan 4
name VLAN4-Test

interface FastEthernet0/1
switchport mode trunk

interface FastEthernet0/2
switchport mode trunk

interface FastEthernet0/3
switchport access vlan 2
spanning-tree portfast
.
.
.
interface FastEthernet0/9
switchport mode trunk

interface FastEthernet0/10
switchport access vlan2
spanning-tree portfast
.
.
.
interface FastEthernet0/24
switchport access vlan2
spanning-tree portfast

interface Vlan 1
ip address 192.168.1.1

ip default-gateway 192.168.2.1

end

The other cisco switch is configured in a similar way only vlan 3 is used instead of 2 and there aren't as many trunks (only 1).

HP Switch:

vlan 1
name "DEFAULT-VLAN"
untagged 9-26
ip address 192.168.1.4 255.255.255.0
tagged 1
no untagged 2-8
exit
vlan 2
name "VLAN2"
ip address dhcp-bootp
tagged 1
exit
vlan 3
name "VLAN3"
ip address dhcp-bootp
tagged 1
exit
vlan 4
name "VLAN4"
untagged 2-8
ip address dhcp-bootp
tagged 11
exit

I hope that's everything.
Markku Leinio
Valued Contributor
Solution

Re: Cisco and HP VLAN Question

Ok, let's see...

On the first Catalyst, ports Fa0/1, Fa0/2 and Fa0/9 are used to connect to the router, to the second Catalyst and to 2524. They seem to be ok (Catalysts trunk all VLANs by default).

On the 2524, I assume that you use port 1 to connect to the Catalyst. On port 1, you have no untagged VLAN, and have VLANs 1, 2 and 3 as tagged. This means that your 2524 won't be able to connect to the Catalyst with VLAN 1 as Catalyst trunks have VLAN 1 as native (untagged) by default.

VLAN 4, on the other hand, is tagged to port 11 (or is it a typo?), which is probably not connected to the Catalyst. So, VLAN 4 has no connection to the Catalyst (and thus to the DHCP server).

So, make sure that on the 2524 the Catalyst-connected port has VLAN 1 as untagged and VLAN 4 as tagged. After that the VLAN 4 untagged ports should be able to reach the router.

What kind of configuration do you have on the router (and which IOS version)?
Eric Cornwell
Occasional Advisor

Re: Cisco and HP VLAN Question

There are 2 catalyst switches. One switch I've set as a "main" switch. Fa0/1 goes to the second catalyst, Fa0/2 goes to the HP2524, and Fa0/9 goes to the router.

Just before I got your message I set the HP to have vlan1 untagged on the first port (the port that goes to the catalyst).

There was a typo as well, 11 was really supposed to be 1. I have all the VLAN's tagged on port 1 execpt the default vlan.

I can ping the switch now and recieve a dhcp address but only as long as the pc is plugged into the ports that are untagged for the default vlan. When I plug it into the VLAN4 ports I can't get an address.

The router is setup with 3 sub interfaces with dot1Q encapsulation. When I plug the pc into one of the cisco's I get a proper address.

Thanks! :)
Eric Cornwell
Occasional Advisor

Re: Cisco and HP VLAN Question

I don't know what happened but it works now.

Thanks!!!
Markku Leinio
Valued Contributor

Re: Cisco and HP VLAN Question

You're welcome, hope the situation has stabilized now.