Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Collisions on Procurve Switches

Anthony Ament_1
Occasional Visitor

Collisions on Procurve Switches

We are experiencing excess collisions, late collisions and deferred Tx packets when connecting IP radio's and Cisco routers to up 5372XL and HP 2626 or 2560 Procuves.

The two brands of IP radio's operate a fixed speeds of 100FD and 10HD. If the Procurve switches ports forced to match these speeds the ports do not even enable(no link up).
If the Procurve ports are set to Auto, then the 100FD connection is detected as 100HD and there are collisions. The 10HD port is detected as 10HD but also has collisions and many Deferred Tx errors.

Likewise with a Cisco 1751 router, the router is set to 100HD and the switch is set to 100HD but there is still alot of collisions and late collision on the procurve port and CRC errors at the cisco end.

I understand the problems with devices that do not auto negotiate when connected to a Procurve Port that is set to auto, but i dont understand why if you force the Procurve port to a set speed why it does not fix the problem.

Any help would be appreciated.

3 REPLIES
Ron Kinner
Honored Contributor

Re: Collisions on Procurve Switches

I'm not sure about the IP Radios but you say:

"Likewise with a Cisco 1751 router, the router is set to 100HD and the switch is set to 100HD but there is still alot of collisions and late collision on the procurve port and CRC errors at the cisco end."

CRC errors on the Cisco side are usually caused by the switch being in Half duplex while the Cisco is in Full duplex. You need to set the switch to Full Duplex or recheck the Cisco cause it seems to be in full duplex mode. Perhaps it has more than one Ethernet interface and you have been looking at the wrong one?

Are you sure you have CAT 5 cables? Are you sure they are good?

Ron
seymour999
Frequent Advisor

Re: Collisions on Procurve Switches

I'm assuming you've already tested the patch cables and they are OK - in particular, no split pairs.

I too don't understand why locking both the switch and router at FDX doesn't fix the CRC errors.

However, if the links on the far side of the device attached to the switch are full-duplex, and the link between the switch and that device is half-duplex, collisions are inevitable. There's two-way traffic trying to cross a one-way link.
suniram
Occasional Visitor

Re: Collisions on Procurve Switches

Hello Anthony,
On explanation for the link not coming is when you fix the ports on the Procurve gear is that on the models you mention, there is a feature called Auto-MDI/X. It enables you to connect f.e. switch to switch using straight cable. However, when you change the port setting on a Procurve with auto-MDI/X, the feature is disabled. You would need a true cross-over cable to establish a link.

My 2 cents; always use a cross-over cable for mdi-x to mdi-x or mdi to mdi links.

The Procurve falling back to HDx when the port is in Auto and a 100FDx device is connected to that Auto port is per the auto-negotiation standard. Only use the combination Auto<>Auto for best performance when you wish to rely on automation.

Do you fabricate your UTP cables yourself?

Goodluck!