Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Configure multicast over vlans

Mos007
Occasional Advisor

Configure multicast over vlans

Hi,

I have 5412 switch and I need to configure the multicast to run over 3 vlans. I enabled the ip multicast routing.

Traffic still stay within the vlans, is there anything else I need to do?

I would like to hear anyone that can help me out with this asap.

thanks in advance!
10 REPLIES
Patrick Terlisten
Honored Contributor

Re: Configure multicast over vlans

Hello,

can you provide a "show running-config" of the 5412? Thanks.

Regards,
Patrick
Best regards,
Patrick
Mos007
Occasional Advisor

Re: Configure multicast over vlans

yes, here is it:

Running configuration:

; J8698A Configuration Editor; Created on release #K.14.47

hostname "ProCurve Switch 5412zl"
time timezone 2
module 1 type J8702A
module 2 type J8702A
module 3 type J8702A
module 4 type J8702A
module 5 type J8702A
module 6 type J8702A
module 7 type J8702A
module 8 type J8702A
module 9 type J8706A
module 12 type J8702A

ip default-gateway 10.10.13.254
ip routing
vlan 1
name "DEFAULT_VLAN"
no untagged A1-A24,B1-B24,C1-C24,D1-D24,E1-E24,F1-F24,G1-G24,H1-H24,I3-I24,L1-L24,Trk1
no ip address
exit
vlan 14
name "v14"
untagged B4,B6-B11,B14-B24,C1-C23,D1-D2,D4-D14,D16-D24,E1-E2,E4-E24,F1-F13,F15,F17,F19-F24,G1-G11,G13-G24,H1-H23,I22-I24
qos priority 3
ip helper-address 10.10.15.1
ip address 10.10.14.254 255.255.255.0
tagged A1-A14,A17-A24,B1-B3,B5,B13,I3-I21,Trk1
jumbo
ip igmp
exit
vlan 15
name "v15"
untagged A1-A24,B1-B3,B5,B13,L13-L14
qos priority 5
ip address 10.10.15.254 255.255.255.0
tagged I3-I24
jumbo
ip igmp high-priority-forward
exit
vlan 16
name "v16"
untagged H24
qos priority 7
ip helper-address 10.10.15.1
ip address 10.10.16.254 255.255.255.0
tagged A1-A14,A17-A24,B1-B24,C1-C24,D1-D24,E1-E24,F1-F24,G1-G24,H1-H23,I3-I21,L1-L24,Trk1
exit
vlan 13
name "v13"
untagged B12,C24,D3,D15,E3,F14,F16,F18,G12,L1-L12,L15-L23
qos priority 3
ip helper-address 10.10.15.1
ip address 10.10.13.254 255.255.255.0
tagged A1-A14,A17-A24,B1-B3,B5,B13,I3-I24,Trk1
jumbo
ip igmp
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
qos protocol IP priority 7
qos protocol IPX priority 1
qos protocol ARP priority 6
qos protocol AppleTalk priority 0
qos protocol SNA priority 1
qos protocol NetBEUI priority 5
mirror 1 port A2
timesync sntp
sntp unicast
sntp server priority 1 10.10.15.1 3
web-management ssl
ip authorized-managers 10.10.15.239 255.255.255.255 access manager
ip timep manual 10.10.4.12
ip route 0.0.0.0 0.0.0.0 10.10.15.20
ip multicast-routing
interface A1
monitor all both mirror 1
exit
interface A3
monitor all both mirror 1
exit
interface A5
monitor all both mirror 1
exit
snmp-server community "xxx" operator
snmp-server community "xxx" operator unrestricted
primary-vlan 14
Patrick Terlisten
Honored Contributor

Re: Configure multicast over vlans

Hello,

try an "ip pim" in the VLANs, in which multicast traffic should be routed.

Could you post the output of "show ip igmp" and "show ip igmp config"?

Regards,
Patrick
Best regards,
Patrick
Mos007
Occasional Advisor

Re: Configure multicast over vlans

thanks for your quick response :)

can you guide me on configuring the ip pim?

here it is:


ProCurve Switch 5412zl# show ip igmp
Status and Counters - IP Multicast (IGMP) Status

VLAN ID : 1
VLAN Name : DEFAULT_VLAN
IGMP is not enabled

VLAN ID : 13
Querier Address : This switch is Querier

Active Group Addresses Reports Queries Querier Access Port
---------------------- ------- ------- -------------------
225.6.7.8 694 0
239.255.255.250 4843 0
239.255.255.253 117 0

VLAN ID : 14
Querier Address : This switch is Querier

Active Group Addresses Reports Queries Querier Access Port
---------------------- ------- ------- -------------------
224.0.1.60 1392 0
224.0.1.127 2084 0
224.1.239.2 977 0
224.1.239.42 903 0
225.6.7.8 4254 0
239.255.255.250 35043 0
239.255.255.253 2952 0

VLAN ID : 15
Querier Address : This switch is Querier

Active Group Addresses Reports Queries Querier Access Port
---------------------- ------- ------- -------------------
224.0.1.22 1346 0
224.0.1.24 1396 0
224.0.1.60 1066 0
225.6.7.8 694 0
228.7.6.7 1302 0
235.1.1.1 3 0
239.255.255.250 4635 0
239.255.255.253 1372 0
239.255.255.254 1415 0

VLAN ID : 16
IGMP is not enabled


ProCurve Switch 5412zl# show ip igmp 14 config
IGMP Service

VLAN ID : 14
IGMP
Enabled [No] : Yes
Forward with
High Priority [No] : No
Querier
Allowed [Yes] : Yes
Querier
Interval [125] : 125

Port Type | IP Mcast
---- --------- + --------
A1 1000T | Auto
A2 1000T | Auto
A3 1000T | Auto
A4 1000T | Auto
A5 1000T | Auto
A6 1000T | Auto
A7 1000T | Auto
A8 1000T | Auto
A9 1000T | Auto
A10 1000T | Auto
A11 1000T | Auto
A12 1000T | Auto
A13 1000T | Auto
A14 1000T | Auto
A17 1000T | Auto
A18 1000T | Auto
A19 1000T | Auto
A20 1000T | Auto
A21 1000T | Auto
A22 1000T | Auto
A23 1000T | Auto
A24 1000T | Auto
B1 1000T | Auto
B2 1000T | Auto
B3 1000T | Auto
B4 1000T | Auto
B5 1000T | Auto
B6 1000T | Auto
B7 1000T | Auto
B8 1000T | Auto
B9 1000T | Auto
B10 1000T | Auto
B11 1000T | Auto
B13 1000T | Auto
B14 1000T | Auto
B15 1000T | Auto
B16 1000T | Auto
B17 1000T | Auto
B19 1000T | Auto
B20 1000T | Auto
B21 1000T | Auto
B22 1000T | Auto
B23 1000T | Auto
B24 1000T | Auto
C1 1000T | Auto
C2 1000T | Auto
C3 1000T | Auto
C4 1000T | Auto
C5 1000T | Auto
C6 1000T | Auto
C7 1000T | Auto
C8 1000T | Auto
C9 1000T | Auto
C10 1000T | Auto
C11 1000T | Auto
C12 1000T | Auto
C13 1000T | Auto
C14 1000T | Auto
C15 1000T | Auto
C16 1000T | Auto
C17 1000T | Auto
C18 1000T | Auto
C19 1000T | Auto
C20 1000T | Auto
C21 1000T | Auto
C22 1000T | Auto
C23 1000T | Auto
D1 1000T | Auto
D2 1000T | Auto
D4 1000T | Auto
D5 1000T | Auto
D6 1000T | Auto
D7 1000T | Auto
D8 1000T | Auto
D9 1000T | Auto
D10 1000T | Auto
D11 1000T | Auto
D12 1000T | Auto
D13 1000T | Auto
D14 1000T | Auto
D16 1000T | Auto
D17 1000T | Auto
D18 1000T | Auto
D19 1000T | Auto
D20 1000T | Auto
D21 1000T | Auto
D22 1000T | Auto
D23 1000T | Auto
D24 1000T | Auto
E1 1000T | Auto
E2 1000T | Auto
E5 1000T | Auto
E6 1000T | Auto
E7 1000T | Auto
E8 1000T | Auto
E9 1000T | Auto
E10 1000T | Auto
E11 1000T | Auto
E12 1000T | Auto
E13 1000T | Auto
E14 1000T | Auto
E15 1000T | Auto
E16 1000T | Auto
E17 1000T | Auto
E18 1000T | Auto
E19 1000T | Auto
E20 1000T | Auto
E21 1000T | Auto
E22 1000T | Auto
E23 1000T | Auto
E24 1000T | Auto
F1 1000T | Auto
F2 1000T | Auto
F3 1000T | Auto
F4 1000T | Auto
F5 1000T | Auto
F6 1000T | Auto
F7 1000T | Auto
F8 1000T | Auto
F9 1000T | Auto
F10 1000T | Auto
F11 1000T | Auto
F12 1000T | Auto
F13 1000T | Auto
F15 1000T | Auto
F17 1000T | Auto
F19 1000T | Auto
F20 1000T | Auto
F21 1000T | Auto
F22 1000T | Auto
F23 1000T | Auto
F24 1000T | Auto
G1 1000T | Auto
G2 1000T | Auto
G3 1000T | Auto
G4 1000T | Auto
G5 1000T | Auto
G6 1000T | Auto
G7 1000T | Auto
G8 1000T | Auto
G9 1000T | Auto
G10 1000T | Auto
G11 1000T | Auto
G13 1000T | Auto
G15 1000T | Auto
G16 1000T | Auto
G17 1000T | Auto
G18 1000T | Auto
G19 1000T | Auto
G20 1000T | Auto
G21 1000T | Auto
G22 1000T | Auto
G23 1000T | Auto
G24 1000T | Auto
H1 1000T | Auto
H2 1000T | Auto
H3 1000T | Auto
H4 1000T | Auto
H5 1000T | Auto
H6 1000T | Auto
H7 1000T | Auto
H8 1000T | Auto
H9 1000T | Auto
H10 1000T | Auto
H11 1000T | Auto
H12 1000T | Auto
H13 1000T | Auto
H14 1000T | Auto
H15 1000T | Auto
H16 1000T | Auto
H17 1000T | Auto
H18 1000T | Auto
H19 1000T | Auto
H20 1000T | Auto
H21 1000T | Auto
H22 1000T | Auto
H23 1000T | Auto
I3 1000SX | Auto
I4 1000SX | Auto
I5 1000SX | Auto
I6 1000SX | Auto
I7 1000SX | Auto
I8 1000SX | Auto
I9 1000SX | Auto
I10 1000SX | Auto
I11 1000SX | Auto
I12 1000SX | Auto
I13 1000SX | Auto
I14 1000SX | Auto
I15 1000SX | Auto
I16 1000SX | Auto
I17 1000SX | Auto
I18 1000SX | Auto
I19 None | Auto
I20 None | Auto
I21 None | Auto
I22 None | Auto
I24 None | Auto
Trk1 Trunk | Auto


ProCurve Switch 5412zl# show ip igmp 13 config
IGMP Service

VLAN ID : 13
IGMP
Enabled [No] : Yes
Forward with
High Priority [No] : No
Querier
Allowed [Yes] : Yes
Querier
Interval [125] : 125

Port Type | IP Mcast
---- --------- + --------
A1 1000T | Auto
A2 1000T | Auto
A3 1000T | Auto
A4 1000T | Auto
A5 1000T | Auto
A6 1000T | Auto
A7 1000T | Auto
A8 1000T | Auto
A9 1000T | Auto
A10 1000T | Auto
A11 1000T | Auto
A12 1000T | Auto
A13 1000T | Auto
A14 1000T | Auto
A17 1000T | Auto
A18 1000T | Auto
A19 1000T | Auto
A20 1000T | Auto
A21 1000T | Auto
A22 1000T | Auto
A23 1000T | Auto
A24 1000T | Auto
B1 1000T | Auto
B2 1000T | Auto
B3 1000T | Auto
B5 1000T | Auto
B12 1000T | Auto
B13 1000T | Auto
C24 1000T | Auto
D3 1000T | Auto
D15 1000T | Auto
E3 1000T | Auto
F14 1000T | Auto
F16 1000T | Auto
F18 1000T | Auto
G12 1000T | Auto
I3 1000SX | Auto
I4 1000SX | Auto
I6 1000SX | Auto
I7 1000SX | Auto
I8 1000SX | Auto
I9 1000SX | Auto
I10 1000SX | Auto
I11 1000SX | Auto
I12 1000SX | Auto
I13 1000SX | Auto
I14 1000SX | Auto
I15 1000SX | Auto
I16 1000SX | Auto
I17 1000SX | Auto
I18 1000SX | Auto
I19 None | Auto
I20 None | Auto
I21 None | Auto
I22 None | Auto
I23 None | Auto
I24 None | Auto
L1 1000T | Auto
L2 1000T | Auto
L3 1000T | Auto
L4 1000T | Auto
L5 1000T | Auto
L6 1000T | Auto
L7 1000T | Auto
L8 1000T | Auto
L9 1000T | Auto
L10 1000T | Auto
L11 1000T | Auto
L12 1000T | Auto
L15 1000T | Auto
L16 1000T | Auto
L17 1000T | Auto
L18 1000T | Auto
L19 1000T | Auto
L20 1000T | Auto
L21 1000T | Auto
L22 1000T | Auto
L23 1000T | Auto
Trk1 Trunk | Auto


ProCurve Switch 5412zl# ProCurve Switch 5412zl# show ip igmp 15 config
IGMP Service

VLAN ID : 15
IGMP
Enabled [No] : Yes
Forward with
High Priority [No] : Yes
Querier
Allowed [Yes] : Yes
Querier
Interval [125] : 125

Port Type | IP Mcast
---- --------- + --------
A1 1000T | Auto
A2 1000T | Auto
A3 1000T | Auto
A4 1000T | Auto
A5 1000T | Auto
A6 1000T | Auto
A7 1000T | Auto
A8 1000T | Auto
A9 1000T | Auto
A10 1000T | Auto
A11 1000T | Auto
A12 1000T | Auto
A13 1000T | Auto
A14 1000T | Auto
A15 1000T | Auto
A16 1000T | Auto
A17 1000T | Auto
A18 1000T | Auto
A19 1000T | Auto
A20 1000T | Auto
A21 1000T | Auto
A22 1000T | Auto
A23 1000T | Auto
A24 1000T | Auto
B1 1000T | Auto
B2 1000T | Auto
B3 1000T | Auto
B5 1000T | Auto
B13 1000T | Auto
I3 1000SX | Auto
I4 1000SX | Auto
I5 1000SX | Auto
I6 1000SX | Auto
I7 1000SX | Auto
I8 1000SX | Auto
I9 1000SX | Auto
I10 1000SX | Auto
I11 1000SX | Auto
I13 1000SX | Auto
I14 1000SX | Auto
I15 1000SX | Auto
I16 1000SX | Auto
I17 1000SX | Auto
I18 1000SX | Auto
I19 None | Auto
I20 None | Auto
I21 None | Auto
I22 None | Auto
I23 None | Auto
I24 None | Auto
L13 1000T | Auto
L14 1000T | Auto


ProCurve Switch 5412zl#
Patrick Terlisten
Honored Contributor

Re: Configure multicast over vlans

Hello,

just go into the vlan context and type

ip pim all

Regards,
Patrick
Best regards,
Patrick
Mos007
Occasional Advisor

Re: Configure multicast over vlans

I added the following to the setup but still no change. what am I doing wrong :(

ip multicast-routing
router rip
exit
router pim
exit
vlan 13
ip pim-dense
ip-addr 10.10.13.254
exit
exit
vlan 14
ip pim-dense
ip-addr 10.10.14.254
exit
exit
vlan 15
ip pim-dense
ip-addr 10.10.15.254
exit
exit
Jeff Carrell
Honored Contributor

Re: Configure multicast over vlans

in addition, each vlan you want multicast routing must also have a routing protocol (such as rip or ospf)...

so in your vlans you added 'ip pim' you also need 'ip rip' (since you have 'routing rip' enabled)...

hth..jeff
Mos007
Occasional Advisor

Re: Configure multicast over vlans

still not working ...

ProCurve Switch 5412zl# show running-config
Running configuration:

; J8698A Configuration Editor; Created on release #K.14.47

hostname "ProCurve Switch 5412zl"
time timezone 2
module 1 type J8702A
module 2 type J8702A
module 3 type J8702A
module 4 type J8702A
module 5 type J8702A
module 6 type J8702A
module 7 type J8702A
module 8 type J8702A
module 9 type J8706A
module 12 type J8702A

ip default-gateway 10.10.13.254
ip routing
vlan 1
name "DEFAULT_VLAN"
no untagged A1-A24,B1-B24,C1-C24,D1-D24,E1-E24,F1-F24,G1-G24,H1-H24,I3-I24,L1-L24,Trk1
no ip address
exit
vlan 14
untagged B4,B6-B11,B14-B24,C1-C23,D1-D2,D4-D14,D16-D24,E1-E2,E4-E24,F1-F13,F15,F17,F19-F24,G1-G11,G13-G24,H1-H23,I22-I24
qos priority 3
ip helper-address 10.10.15.1
ip address 10.10.14.254 255.255.255.0
tagged A1-A14,A17-A24,B1-B3,B5,B13,I3-I21,Trk1
jumbo
ip igmp
exit
vlan 15
untagged A1-A24,B1-B3,B5,B13,L13-L14
qos priority 5
ip address 10.10.15.254 255.255.255.0
tagged I3-I24
jumbo
ip igmp high-priority-forward
exit
vlan 16
untagged H24
qos priority 7
ip helper-address 10.10.15.1
ip address 10.10.16.254 255.255.255.0
tagged A1-A14,A17-A24,B1-B24,C1-C24,D1-D24,E1-E24,F1-F24,G1-G24,H1-H23,I3-I21,L1-L24,Trk1
exit
vlan 13
untagged B12,C24,D3,D15,E3,F14,F16,F18,G12,L1-L12,L15-L23
qos priority 3
ip helper-address 10.10.15.1
ip address 10.10.13.254 255.255.255.0
tagged A1-A14,A17-A24,B1-B3,B5,B13,I3-I24,Trk1
jumbo
ip igmp
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
qos protocol IP priority 7
qos protocol IPX priority 1
qos protocol ARP priority 6
qos protocol AppleTalk priority 0
qos protocol SNA priority 1
qos protocol NetBEUI priority 5
mirror 1 port A2
timesync sntp
sntp unicast
sntp server priority 1 10.10.15.1 3
web-management ssl
ip authorized-managers 10.10.15.239 255.255.255.255 access manager
ip timep manual 10.10.4.12
ip route 0.0.0.0 0.0.0.0 10.10.15.20
ip multicast-routing
router rip
exit
router pim
exit
interface A1
monitor all both mirror 1
exit
interface A3
monitor all both mirror 1
exit
interface A5
monitor all both mirror 1
exit
snmp-server community "xxx" operator
snmp-server community "xxx" operator unrestricted
spanning-tree Trk1 priority 4
vlan 13
ip rip 10.10.13.254
ip pim-dense
ip-addr any
exit
exit
vlan 14
ip rip 10.10.14.254
ip pim-dense
ip-addr any
exit
exit
vlan 15
ip rip 10.10.15.254
ip pim-dense
ip-addr any
exit
exit
primary-vlan 14
Patrick Terlisten
Honored Contributor

Re: Configure multicast over vlans

Hello,

what kind of application do you use?

Regards,
Patrick
Best regards,
Patrick
Mos007
Occasional Advisor

Re: Configure multicast over vlans

Hi Patrick,

I'm using the default MAC PRO bonjour protocol which working fine within the same vlan but does not working between vlans.

thanks,