Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Configuring Multiple vlans in HP Procurve 8212ZL

ramjimh
Advisor

Configuring Multiple vlans in HP Procurve 8212ZL

Our office contains 6 floors.Each floor has one or many hp procure 2610,2626 and 2650 procurve switches.We have one hp procurve 3400 switch which is acting ascore switch.Now we have only two vlans Named data and voice.We are planning to change this core switch to HP procurve 8212ZL with OFC support and planning to create vlans based on the floors.Each floor will be in different vlans and the servers will be in differnet vlans.How to configure the switches with different vlans support.Need any sample config with examples and need ur suggestions.

With Regards,

Ramji M.H.
22 REPLIES
cenk sasmaztin
Honored Contributor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

hi ramjimh

I make example config for you

you have one core switch 8212 and many edge switch connect to core switch

you must would four seperate network

1-managemet vlan (for network device security)
2-data vlan pc,printer and any network device)
3-voip vlan (ip phone and comminication server)
4-server vlan (all server's)

yess...we can frist config core switch

I create four vlan on switch
vlan 1 managemet
vlan 2 data
vlan 3 voip
vlan 4 server

all server ,voip server,and network managemet pc, some users connect directly core switch


hostname "core"
module 1 type J9145A
interface 21
name "uplinkforfloorswitch"
exit
interface 22
name "uplinkforfloorswitch"
exit
interface 23
name "uplinkforfloorswitch"
exit
interface 24
name "uplinkforfloorswitch"
exit
ip routing
vlan 1
name "manager"
untagged 1-2,21-24
ip address 10.0.11.1 255.255.255.0
no untagged 3-20
exit
vlan 2
name "data"
untagged 3-4
ip address 10.0.12.1 255.255.255.0
tagged 21-24
exit
vlan 3
name "voip"
untagged 5-10
ip address 10.0.13.1 255.255.255.0
tagged 21-24
exit
vlan 4
name "server"
untagged 11-20
ip address 10.0.14.1 255.255.255.0
exit
snmp-server community "public" unrestricted


interface 1-2 manager vlan for managemet pc connection

interface 3-4 data vlan for core switch user connection

interface 5-10 voip vlan for comminication server connection

interface 11-20 server vlan for server connection

interface 21,22,23,24 for other edge switch uplink port


****************************************

we edge switch(floor switch ) serve pc and voip phone for user

in this case edge switch have 3 vlan
data ,voip and management


hostname "edge1"
module 1 type J9145A
vlan 1
name "manager"
ip address 10.0.11.2 255.255.255.0
no untagged 1-24
exit
vlan 2
name "data"
untagged 1-24
no ip address
exit
vlan 3
name "voip"
tagged 1-24
no ip address
exit
snmp-server community "public" unrestricted

vlan 1 only managemet for network managemet
vlan 2 data vlan connect user pc under ip phone
vlan 3 voip vlan connect ip phone all port tagged state vlan 3 for ip phone connection flexibility

switch+ip phone + pc


may it be easy

















cenk

ramjimh
Advisor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

Thanks cenk Sasmatztin.
I will configure this and update the result.

With Regards,

Ramji
ramjimh
Advisor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

Apart from that we have a Microsoft windows 2003 server in which we have configured dhcp.How to configure so that the switch can can assigned ip from the microsoft dhcp server.

With Regards,

Ramji
cenk sasmaztin
Honored Contributor

Re: Configuring Multiple vlans in HP Procurve 8212ZL


hi Ramji
******************************************
dhcp server ip address 10.0.14.20
subnet mask 255.255.255.0
default gateway 10.0.14.1
dhcp server connect must be server vlan untag port for example connect interface 11


scobe 1 name data
ip pool 10.0.12.10---200
subnet mask 255.255.255.0
default gateway 10.0.12.1

scobe 2 name voip
ip pool 10.0.13.10---200
subnet mask 255.255.255.0
default gateway 10.0.13.1





hostname "core"
module 1 type J9145A
interface 21
name "uplinkforfloorswitch"
exit
interface 22
name "uplinkforfloorswitch"
exit
interface 23
name "uplinkforfloorswitch"
exit
interface 24
name "uplinkforfloorswitch"
exit
ip routing
vlan 1
name "manager"
untagged 1-2,21-24
ip address 10.0.11.1 255.255.255.0
no untagged 3-20
exit
vlan 2
name "data"
untagged 3-4
ip address 10.0.12.1 255.255.255.0
ip helper-address 10.0.14.20**************
tagged 21-24
exit
vlan 3
name "voip"
untagged 5-10
ip address 10.0.13.1 255.255.255.0
ip helper-address 10.0.14.20*************
tagged 21-24
exit
vlan 4
name "server"
untagged 11-20
ip address 10.0.14.1 255.255.255.0
exit
snmp-server community "public" unrestricted
cenk

ramjimh
Advisor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

I will provide the exact scenario what i need.our office has 6 floors and some of our branch office r in different place.Each Floors has 2 departments.Need to create vlans based on departments(like,finance,personnel,procurement,supply,engineering,IT and other 2 divisions based on class B networks like 172.16.2.x,172.16.3..x etc...)apart from that we have to create vlans for Servers,voice,management and internet,SAP valn and sun management vlan.We have dhcp server which is configured in microsoft windows 2003 server as well as in sun solaris 10 server and the users should have to receive ip from this dhcp server and those who r using sap they must receive ip from sun server.The IT vlan must have access to sun management vlan.kindly need sample configuration based on this.i will be very much helpful for me.
ramjimh
Advisor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

Hi cenksasmaztin,

I am waiting for ur reply.Kindly help me in configuring the 8212zl switch.

cenk sasmaztin
Honored Contributor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

hi Ramji

I send simple config for you

you can create config for your 8212 switch

if your config be fail at the time

send me sh run print.


good luck .

cenk

ramjimh
Advisor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

There is no attachment in my mail.

With Regards,

Ramji
cenk sasmaztin
Honored Contributor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

hi Ramji
******************************************
dhcp server ip address 10.0.14.20
subnet mask 255.255.255.0
default gateway 10.0.14.1
dhcp server connect must be server vlan untag port for example connect interface 11


scobe 1 name data
ip pool 10.0.12.10---200
subnet mask 255.255.255.0
default gateway 10.0.12.1

scobe 2 name voip
ip pool 10.0.13.10---200
subnet mask 255.255.255.0
default gateway 10.0.13.1





hostname "core"
module 1 type J9145A
interface 21
name "uplinkforfloorswitch"
exit
interface 22
name "uplinkforfloorswitch"
exit
interface 23
name "uplinkforfloorswitch"
exit
interface 24
name "uplinkforfloorswitch"
exit
ip routing
vlan 1
name "manager"
untagged 1-2,21-24
ip address 10.0.11.1 255.255.255.0
no untagged 3-20
exit
vlan 2
name "data"
untagged 3-4
ip address 10.0.12.1 255.255.255.0
ip helper-address 10.0.14.20**************
tagged 21-24
exit
vlan 3
name "voip"
untagged 5-10
ip address 10.0.13.1 255.255.255.0
ip helper-address 10.0.14.20*************
tagged 21-24
exit
vlan 4
name "server"
untagged 11-20
ip address 10.0.14.1 255.255.255.0
exit
snmp-server community "public" unrestricted
cenk

ramjimh
Advisor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

Hi cenk sasmaztin,

here i have given the config of our switch based on ur sample config.We are using hp procurve 8212zl switch and the configuration is given below:
Hostname â Al-osais Core Switchâ
Module 1 type

Vlan 2
Name â Al-Osais Supplyâ
Ip address 172.16.2.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 3
Name â Power Divisionâ
Ip address 172.16.3.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 4
Name â IT Departmentâ
Ip address 172.16.4.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 5
Name â Finance Departmentâ
Ip address 172.16.5.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 6
Name â Al-Osais Personnal Departmentâ
Ip address 172.16.6.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 7
Name â Al-Osais Procurement Departmentâ
Ip address 172.16.7.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 8
Name â Al-Osais Engineering Departmentâ
Ip address 172.16.8.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 9
Name â Al-Osais conference hallâ
Ip address 172.16.9.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 14
Name â rslanes-Dahranâ
Ip address 172.16.14.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 16
Name â Server vlanâ
Ip address 172.16.16.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 15
Name â Internetâ
Ip address 172.16.15.254 255.255.255.0
Untagged ports
Exit
Vlan 100
Name â managementâ
Ip address 172.16.100.25 255.255.255.0
Untagged ports
Exit

Vlan 10
Name â SAP Serverâ
Ip address 172.16.10.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 11
Name â SAP-Managementâ
Ip address 172.16.11.254 255.255.255.0
Untagged ports
Exit
Vlan 32
Name â voiceâ
Ip address 172.16.32.254 255.255.240.0
Qos priority 6
Tagged ports
Exit

Dhcp server ip address 172.16.16.40
Subnet mask 255.255.255.0
Default gateway 172.16.16.254

now the required thing is given below:
1).how to configure the edge swithes.(edge switches are HP2610,2626,2650).
2)we have many valns and which are the pots to untag and which are ports to be tagged.
3)vlan 4 should have to communicate with vlan 11 and vlan 10
needs ur suggestions asap.Waiting for ur reply.

cenk sasmaztin
Honored Contributor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

1).how to configure the edge swithes.
*********************************************
edge switch config very easy main job put up core siwtch

edge switch not included all vlan's
for example your edge switch resiade Osais Engineering Departmentâ
not included server vlan not included all other vlan
this switch included vlan 1 for management and vlan 8 for Osais Engineering Departmentâ
user

for example edge switch config
vlan 1
name "managemt"
untagged 24
ip address 172.16.0.254 255.255.255.0
no untagged 1-23
exit
vlan 8
name "Al-OsaisEngineeringDepartment"
untagged 1-23
ip address 172.16.8.254 255.255.255.0
tagged 24
exit

******************************************
2)we have many valns and which are the pots to untag and which are ports to be tagged.
*******************************************
untag port's on not carry vlan information
tagged port's carrying vlan information

user and directly pc or server port must have untag port all switch to switch uplink port must have tagged port because uplink port's must be carrying vlan

please see my example config interface 24 uplink port to core switch and interface 24 vlan 8 tagged port for carrying vlan 8 all other port untag vlan 8 for connection pc
same time interface 24 untag port vlan 1

********************************************
3)vlan 4 should have to communicate with vlan 11 and vlan 10
needs ur suggestions asap
********************************************
yes it is possible
when ip routing enable on 8212 switch all vlan communicate all other vlan

same time 8212 switch include access control list feature if you want not connect vlan you can create acl list for deny comminication.
cenk

ramjimh
Advisor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

Thanks cenk sasmaztin

ramjimh
Advisor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

Hi cenk sasmaztin,

here i have given the config of our switch based on ur sample config.We are using hp procurve 8212zl switch and the configuration is given below:
Hostname â  Al-osais Core Switchâ Â
Module 1 type

Vlan 2
Name â  Al-Osais Supplyâ Â
Ip address 172.16.2.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 3
Name â  Power Divisionâ Â
Ip address 172.16.3.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 4
Name â  IT Departmentâ Â
Ip address 172.16.4.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 5
Name â  Finance Departmentâ Â
Ip address 172.16.5.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 6
Name â  Al-Osais Personnal Departmentâ Â
Ip address 172.16.6.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 7
Name â  Al-Osais Procurement Departmentâ Â
Ip address 172.16.7.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 8
Name â  Al-Osais Engineering Departmentâ Â
Ip address 172.16.8.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 9
Name â  Al-Osais conference hallâ Â
Ip address 172.16.9.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 14
Name â  rslanes-Dahranâ Â
Ip address 172.16.14.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 16
Name â  Server vlanâ Â
Ip address 172.16.16.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 15
Name â  Internetâ Â
Ip address 172.16.15.254 255.255.255.0
Untagged ports
Exit
Vlan 100
Name â  managementâ Â
Ip address 172.16.100.25 255.255.255.0
Untagged ports
Exit

Vlan 10
Name â  SAP Serverâ Â
Ip address 172.16.10.254 255.255.255.0
Untagged ports
Qos priority 0
Exit
Vlan 11
Name â  SAP-Managementâ Â
Ip address 172.16.11.254 255.255.255.0
Untagged ports
Exit
Vlan 32
Name â  voiceâ Â
Ip address 172.16.32.254 255.255.240.0
Qos priority 6
Tagged ports
Exit

Dhcp server ip address 172.16.16.40
Subnet mask 255.255.255.0
Default gateway 172.16.16.254

questions:

1)apart form other vlans we have one voice vlan,should i mention this vlan in edge switches.
cenk sasmaztin
Honored Contributor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

1)apart form other vlans we have one voice vlan,should i mention this vlan in edge switches.

yes create on voice vlan edge switch
because you want connect ip phone on edge switch
cenk

tom_m_indy
Occasional Visitor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

Ramji,

What drove your decision to break up your vlans by both floor AND department... That is a lot of VLANs for a 6-story building... Unless you have more than 150-175 hosts on a floor, I'm not sure I see an advantage in breaking up the network by department as well.

...Unless there is some regulatory requirement you are required to follow? In that case, I guess you'd have no choice.

Good luck!
ramjimh
Advisor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

Hi tom m Indy

The purpose of individual Vlans for each departments is whenever there is a problem in a department it should not affect others and day to day each departments are getting more peoples.

If u have different idea kindly suggest me and can u provide me a config based on my question.
ramjimh
Advisor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

below is my configuration of HP core switch:
Running configuration:
; J9091A Configuration Editor; Created on release #K.12.31
hostname "ProCurve Switch 8212zl"
module 1 type J8706A
module 3 type J8702A
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged A1-A24,C1-C24
no ip address
exit
vlan 2
name "AOSUPPLY"
qos priority 0
ip address 172.16.2.254 255.255.255.0
tagged A2
exit
vlan 3
name "Power-Div"
qos priority 0 ip address 172.16.3.254 255.255.255.0
tagged A3-A5
exit
vlan 4
name "IT-Dept."
qos priority 0
ip address 172.16.4.254 255.255.255.0
tagged A6-A7
exit
vlan 5
name "Finance"
qos priority 0
ip address 172.16.5.254 255.255.255.0
tagged A8-A9
exit
vlan 6
name "personnal"
qos priority 0
ip address 172.16.6.254 255.255.255.0
tagged A10-A11
exit
vlan 7
name "Procurement"
qos priority 0
ip address 172.16.7.254 255.255.255.0
tagged A12-A13
exit
vlan 8
name "Engineering"
qos priority 0
ip address 172.16.8.254 255.255.255.0
tagged A14-A15
exit
vlan 14
name "VLAN14"
qos priority 0
ip address 172.16.14.254 255.255.255.0
tagged C22
exit
vlan 32
name "Voice"
untagged C1-C8
qos priority 6
ip address 172.16.32.10 255.255.240.0
tagged C13-C18
exit
vlan 16
name "Server Vlan" untagged A1-A24,C9-C24
qos priority 0
ip address 172.16.16.254 255.255.255.0
tagged C1-C8
exit

1).we have a windows 2003 dhcp server and Sun server & how to configure in this switch.
2)cannot able to communicate with other vlans,even the ip routing is enabled.
3).If i ping to voice vlan,the network is not reachable.how to correct it.
Need ur solution.
cenk sasmaztin
Honored Contributor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

please be carefull read my post
cenk

Ahmad1_1
Occasional Visitor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

if u please i need to configure more VLANs on HP ProCurve 2626 j49000b

how i can do it ?

Thanks
Jeff Carrell
Honored Contributor

Re: Configuring Multiple vlans in HP Procurve 8212ZL


Ahmad1 wrote:

if u please i need to configure more VLANs on HP ProCurve 2626 j49000b

how i can do it ?
======================

jeff replied:

if you are trying to create the 9th+ vlan, you need to "up the vlan count capability"...

the procurve switches support more vlans than their default configuration, as each vlan the switch is capable of requires dedicated system resources, so just because you can possibly configure alot of vlans, only increase the level to what you really need and then add a little more...

fyi, the 2626 can support a max of 253 vlans...


ProCurve(config)# max-vlans 32
Command will take effect after saving configuration and reboot.

hth...jeff
Ahmad1_1
Occasional Visitor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

ok thanks

i do this step

now i want to creat 3 vlan

Vlan1 : from port 1 : 10
port 1 for router
port 2 for server

Vlan2 : port 25 for switch

Vlan3 : port 11 for access point

i need Vlan 2,3 full access to Vlan 1

Thanks
Jeff Carrell
Honored Contributor

Re: Configuring Multiple vlans in HP Procurve 8212ZL

Ahmad1 said:

now i want to creat 3 vlan

Vlan1 : from port 1 : 10
port 1 for router
port 2 for server

Vlan2 : port 25 for switch

Vlan3 : port 11 for access point

i need Vlan 2,3 full access to Vlan 1

----------
jeff replied

opps, thought you had created 7 vlans and needed to create more...disregard my previous info as you do not need to do it...

here is a sample config for you:

----
ip routing

vlan 1 ip address 10.1.1.1/24

vlan 2 ip address 10.2.1.1/24
untag 25

vlan 3 ip address 10.3.1.1/24
untag 11
----

with ip routing enabled and each vlan with an ip address, all vlans can access each other...

vlan 1 (default vlan) is auto created and all ports are unatgged members of vlan 1 by default, so you simply move a port into a different vlan as needed...

hth...jeff