Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Configuring trunking between HP9304 and CISCO 3560

SOLVED
Go to solution
Yousef Jamous
Frequent Advisor

Configuring trunking between HP9304 and CISCO 3560

I have HP 9304 as my core Switch and CISCO Switch 3560 as edge switch.
I want to trunk between these 2 switches.

CISCO configuration:
interface GigabitEthernet0/49
description UPLINK TO CORE Switch1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Vlan104
ip address 172.26.4.251 255.255.255.0
no ip redirects
standby 104 ip 172.26.4.1
standby 104 preempt
standby 104 timer 5 15

And I have this route on CISCO:
ip route 0.0.0.0 0.0.0.0 172.26.4.2

HP Configuration:
vlan 109 by port
tagged ethe 2/15
router-interface ve 10
spanning tree

interface ve 10
ip address 172.26.4.2 255.255.255.0
ip rip v2-only
ip vrrp vrid 10
owner
ip-address 172.26.4.2

And I have this route on HP Switch

ip route 172.26.0.0 255.255.0.0 172.26.4.1

There is a fiber cable connected from CISCO port g0/49 to HP port 2/15

The problem I'm not able to establish the trunking after all this configuration. I'm not able to ping 172.26.4.2 from CISCO Switch and same I cannot ping 172.26.4.1 from HP Switch.

I tried to trunk between 2 CISCO switches, and it worked fine. So, I was wondering is there additional informaton or configurations required to enable trunking between this HP and CISCO switch?
I've attached a diagram of my switches configurations
4 REPLIES
Solution

Re: Configuring trunking between HP9304 and CISCO 3560

Yousef,

I am presuming that you are wanting traffic to flow from the Cisco VLAN 104 too the HP VLAN 109.

The HP port 2/15 has been set to 'Tagged', this means that it will only accept tagged packets on VLAN 109, currently you are sending non tagged packets to the port. If you want the two VLANS to communicate I suggest you set port 2/15 to 'UnTagged', then it will accept all untagged packets.

Hope this helps.
Kell van Daal
Respected Contributor

Re: Configuring trunking between HP9304 and CISCO 3560

You use vlan 104 on the Cisco and vlan 109 on the HP. I suggest correcting this first.
Yousef Jamous
Frequent Advisor

Re: Configuring trunking between HP9304 and CISCO 3560

Thanks David and Kell
I tried changing the VLAN ID and it worked perfectly.

Many thanks and Happy New Year.
Yousef Jamous
Frequent Advisor

Re: Configuring trunking between HP9304 and CISCO 3560

I did what Kell has suggested in the second answer to my question, and it worked perfectly fine