Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Connecting Problem

Connecting Problem

I have a test environment with a 2650 as access switch and a 2824 as core. On the 2824 routing i enabled. I have defined several VLANs and join my notebook and a PC in a first step in the same VLAN, connected on ports of the 2650. These ports are untagged in the used VLAN.
Now i can ping from my notebook th switches, but not the PC. The switches cannot ping my notebook and the PC.
Should be simple, but i have no idea ?

A.
10 REPLIES
Mohieddin Kharnoub
Honored Contributor

Re: Connecting Problem

Hi

Just verify that you do this:

- Default Gateway of 2650 is Vlan1 ip address on the 2824 routing switch.
- Link between 2650 and 2824 is tagged with all vlans, untagged for vlan1.
- PCs IP address in the same range of their vlan ip address.
- PCs gateway in any vlan is the IP address of their vlan on the 2824 routing switch.
- Show ip route on the 2824 to verify all Vlans included in the routing table, and nothing wrong (like ip mismatch).

Thats it :)

Good Luck !!!
Science for Everyone
bscheible
Occasional Advisor

Re: Connecting Problem

Andreas - see the attached pic. This would be a basic setup and I use it for my lab........works like a charm!

Re: Connecting Problem

Yes,

i have it checked. All is OK, but ... no echo.

Now i have changed the config. Only the default vlan, all ports member of this (untagged). My notebook and PC with IP address of this VLAN. Both can ping the switch, but not each other ?

A.

Re: Connecting Problem

I'm confused ?!

Now i configured only one 2650. 2 Vlans, routing enabled. My notebook is on port 1 with 193.197.34.236, the PC on port 16 with 193.197.34.100.

My notebook can ping the switch, but not the PC. The PC can ping the switch but not the notebook. The switch can not ping notebook and pc, but can use the tftp-server on my notebook to backup the config.

WHY ?

Here my config:


; J4899B Configuration Editor; Created on release #H.08.98

hostname "ProCurve Switch 2650"
snmp-server contact "Andreas Schmidt"
max-vlans 15
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "Network"
untagged 2-33,35-50
ip address 192.168.1.11 255.255.255.0
no untagged 1,34
exit
vlan 34
name "Management"
untagged 1,34
ip address 193.197.34.11 255.255.255.0
exit
password manager

Re: Connecting Problem

I'm confused ?!

Now i configured only one 2650. 2 Vlans, routing enabled. My notebook is on port 1 with 193.197.34.236, the PC on port 16 with 193.197.34.100. The gateway is 193.197.34.11.

My notebook can ping the switch, but not the PC. The PC can ping the switch but not the notebook. The switch can not ping notebook and pc, but can use the tftp-server on my notebook to backup the config.

WHY ?

Here my config:


; J4899B Configuration Editor; Created on release #H.08.98

hostname "ProCurve Switch 2650"
snmp-server contact "Andreas Schmidt"
max-vlans 15
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "Network"
untagged 2-33,35-50
ip address 192.168.1.11 255.255.255.0
no untagged 1,34
exit
vlan 34
name "Management"
untagged 1,34
ip address 193.197.34.11 255.255.255.0
exit
password manager
Mohieddin Kharnoub
Honored Contributor

Re: Connecting Problem

Hi

Your notebook on port 1 untagged to Vlan34, and ip address is ok.
Your PC on port 16 untagged to vlan1, but ip address is wrong, different from Vlan1 ip address range.
You have either:
- Untag port 16 to vlan34 and life will be good.
OR
change ip address of the PC to vlan1 ip address range 192.168.1.x/24, and gateway is 192.168.1.11, and again life will be good :)

Don;t forget to assign points.

Good Luck !!!
Science for Everyone

Re: Connecting Problem

Sorry, that was wrong from me. PC is on port 34 ?!

A.
Mohieddin Kharnoub
Honored Contributor

Re: Connecting Problem

Hi

Your configuration is 100% correct on switch and PC and notebook, but i think you have to disable WinXP firewall a while to complete the testing :)

Good Luck !!!
Science for Everyone

Re: Connecting Problem

It's teriblly. It was the firewall on XP, supressing the echo of ping.

And now, i add a new VLAN, join my PC to this, connect a DHCP-Server to the switch and ... the PC get a IP-Address after i deactivate the firewall on the server. It's great, but i can not deactivate the firewalls on all servers and clients.

What should i do ?

A.
Mohieddin Kharnoub
Honored Contributor

Re: Connecting Problem

Hi

DHCP Service is allowed by default on the firewall, anyway i think you can manage default firewall profile on clients by Win server policy.

Good Luck !!!
Science for Everyone