Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Connectvity & VLAN tagging w/ Cisco 3550

Aaron Yee
Occasional Visitor

Connectvity & VLAN tagging w/ Cisco 3550

We just got a Procurve 3500yl to test out and we're trying to implement them as edge switches in a predominantly Cisco environment. I've got the connectivy going between the Catalyst 3550, but I can't seem to get any VLAN data through the 802.1q trunk.

The 3550 here is an edge switch and does not contain any VLAN data itself but merely part of the trunk passing on VLAN information from the core Cisco 6500. The 3550 has been set to transparent mode. I'm trying to pass a couple vlans here, 38 (access vlan) and 180 (voice vlan).

Here's what essential portions of the configs I have so far:

-Cisco 3550-

interface FastEthernet0/24
description ***Test***
switchport trunk encapsulation dot1q
switchport mode trunk
speed 100
duplex full


-Procurve 3500yl-

hostname "hptest"
ip default-gateway 172.31.127.254
timesync sntp
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-48
ip address 172.31.127.50 255.255.255.0
exit
vlan 180
name "VLAN180"
tagged 2-48
voice
no ip address
exit
vlan 38
name "VLAN38"
tagged 2-48
no ip address
exit
gvrp
management-vlan 1
spanning-tree
3 REPLIES
Mohieddin Kharnoub
Honored Contributor

Re: Connectvity & VLAN tagging w/ Cisco 3550

Hi

If you are using this Cisco 3550 as VTP transparent to pass all Vlans info. generated by the core 6500, then its fine from cisco side but not from ProCurve Side and also VTP is a proprietary protocol.

Usually if frames must be transported out another trunk link, the Vlan identifier is added back into the frame header.
Otherwise, if frames are destined out an access (nontrunk) link, the switch removes the VLAN identifier before transmitting the frames to the end station.

I think what you need is IEEE 802.1Q tunnel, and the command is switchport mode dot1qtunnel after you placed the port in access mode.

Good Luck !!!
Science for Everyone
Aaron Yee
Occasional Visitor

Re: Connectvity & VLAN tagging w/ Cisco 3550

Hi, and thanks for replying. Either that didn't work, or I didn't understand it.

I set the dot1q-tunnel on the 3550 port that goes to the Procurve so now the config looks like this:

interface FastEthernet0/24
description ***To HP Procurve***
switchport trunk encapsulation dot1q
switchport mode dot1q-tunnel
speed 100
duplex full
no cdp enable
spanning-tree bpdufilter enable
end

I'm still not seeing the vlans recognized on the Procurve side.
Case Van Horsen
Frequent Advisor

Re: Connectvity & VLAN tagging w/ Cisco 3550

I'm going to assume that you are connecting to interface 1 on the 3500yl.

Try the following:

On the 3550:

interface FastEthernet0/24
switchport trunk encapsualtion dot1q
switchport trunk allowed vlan 1,38,180
switchport mode trunk

Procurve:

vlan 1
name "DEFAULT_VLAN"
untagged 1
no untagged 2-48
exit
vlan 180
name "VLAN180"
tagged 1-48
voice
exit
vlan 38
name "VLAN38"
tagged 1
untagged 2-48
exit

This should be close. You need to make sure vlan 38 & 180 are both tagged on the link between the two switches.