Switches, Hubs, and Modems
1752565 Members
5777 Online
108788 Solutions
New Discussion

Re: Convert config from Cisco to HP??

 
wingnutg144
Occasional Contributor

Convert config from Cisco to HP??

I am trying to convert a config from a Cisco switch that is in production and working fine (but slow) to a gigabit HP switch.  

I'm familar with Cisco networking, but not HP.

 

Can someone tell me why when I have this for the working Cisco config:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Commerce_Switch2
!
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface FastEthernet0/27
!
interface FastEthernet0/28
!
interface FastEthernet0/29
!
interface FastEthernet0/30
!
interface FastEthernet0/31
!
interface FastEthernet0/32
!
interface FastEthernet0/33
!
interface FastEthernet0/34
!
interface FastEthernet0/35
!
interface FastEthernet0/36
!
interface FastEthernet0/37
!
interface FastEthernet0/38
!
interface FastEthernet0/39
!
interface FastEthernet0/40
!
interface FastEthernet0/41
!
interface FastEthernet0/42
!
interface FastEthernet0/43
!
interface FastEthernet0/44
!
interface FastEthernet0/45
!
interface FastEthernet0/46
!
interface FastEthernet0/47
!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface VLAN1
 ip address 164.165.71.52 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 164.165.71.1
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 login
line vty 5 15
 login
!
end

 And I have this for the HP switch:

Running configuration:

; J4865A Configuration Editor; Created on release #G.07.70

hostname "CommerceGigabit"
time timezone -480
cdp run
module 2 type J4862B
module 4 type J4908A
module 6 type J4908A
module 8 type J4908A
ip default-gateway 164.165.71.1
ip routing
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged B1-B24,D1-D22,F1-F22,H1-H22
   ip address 164.165.71.52 255.255.255.0
   exit

 I would like to use the port d20 as a trunk port to the trunk port on the other end (connected to a Cisco switch).  

 

When I connect the network cable to D20, I am able to ping the gateway, but if I connect any other computer to port D1, I don't get a DHCP address, and if I'm on the HP switch, I can't ping anything past the gateway itself.......

 

Can anyone assit??

9 REPLIES 9
Fredrik Lönnman
Honored Contributor

Re: Convert config from Cisco to HP??

That should work. Since you're only using vlan1 in the Cisco config it isnt actually tagged on the uplink.

I would remove "ip routing" from the HP config since Im guessing this is actually not a router but a pure L2 switch. Since you are able to communicate with the default gateway the L2 stuff actually works, might be the "ip routing" that interferes.
---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

wingnutg144
Occasional Contributor

Re: Convert config from Cisco to HP??

I actually added in the IP routing after determining that the HP config didn't allow me to get outside our network.

 

I also had experimented with tagging and untagging port D20 (the trunk port), and the only way I could ping my gateway was to leave D20 untagged.

 

But again if I connect a laptop to D1, I don't get a DHCP address, can't do anything on the network.......

 

Thinking something must not be right :(

Fredrik Lönnman
Honored Contributor

Re: Convert config from Cisco to HP??

But the computers use 164.165.71.1 as default gateway, right, not 164.165.71.52? "ip routing" is only needed if the switch are actually routing packets and not switching, but this looks like it's meant to be a pure L2 switch.

Also when you add "ip routing" the "ip default-gateway" command looses its effect.
---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

wingnutg144
Occasional Contributor

Re: Convert config from Cisco to HP??

So why, if the ip routing command isn't there, would a computer plugged into D1 not be able to connect and get a DHCP address???

Fredrik Lönnman
Honored Contributor

Re: Convert config from Cisco to HP??

Im not exactly sure, but it doesnt have to do with the routing.. since this is a L2 switch right? It shouldnt route.
---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

wingnutg144
Occasional Contributor

Re: Convert config from Cisco to HP??

From the specs I can see, yes, it is a layer 2 switch.  Its a 4108gl

Fredrik Lönnman
Honored Contributor

Re: Convert config from Cisco to HP??

Oh man.. thats like ancient. And the SW isnt even on the download page anymore, so its probably well over 5 years old.

Start with an upgrade to the newest SW G.07.117. As I can't really see any obvious fault in your config maybe its a bug.

Do you see mac adresses both ways?
---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

wingnutg144
Occasional Contributor

Re: Convert config from Cisco to HP??

Well, I am making SOME progress :)

 

I changed 

vlan 1
   name "DEFAULT_VLAN"
   untagged B1-B24,D1-D22,F1-F22,H1-H22
   ip address 164.165.71.52 255.255.255.0
   exit

 to instead get the IP address from DHCP, and then connected a laptop to port D1, and the trunk port to D20.  I can now get a IP address on the laptop, and get to the internet, so that's good.

 

I'm a little confused, from the command line of the HP if I ping the IP address of the laptop in D1, it says the laptop failed to respond......  and I can't ping from the laptop to the IP assigned to VLAN1.

 

Also, from my desktop (not connected to the HP switch) I am unable to ping to a IP address connected to the HP switch.......  or the other way, from the switch to my desktop.......  

 

Its all 1 IP range, we have the full class C, so we're not dealing with a routing issue I don't believe.......

 

So updating the software on the HP via tftp becomes sorta hard......any idea why I can't ping across the same module??

Matcol
Frequent Advisor

Re: Convert config from Cisco to HP??

That doesn't really make much sense.

Remove the IP address from the HP switch - it's just confusing and distracting you.

It's a switch: it doesn't use an IP address to do its switching.

Obviously, remove "ip routing".

 

Now, check your Layer2 is all OK:

 - VLAN exists on both switches

 - VLAN added to both sides of the Switch-switch link

 - VLAN is UNTAGGED on both sides (or, TAGGED on both sides)

 

Test: enable CDP on the HP switch (or LLDP on the Cisco switch), issue a "show cdp nei" (or "sh lldp inf rem").

 - Switches should see each other.

 

Next, check Layer 3 is OK:

 - Host address in correct subnet

 - Host mask OK

 - Host gateway address is the IP address ... where?

 - Gateway address is correct

 - Host can ping its gateway when patched to cisco switch

 - Obviously, this mean host can ping its gateway when patched to HP switch (else, back to Layer2 with you!)