Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Could someone check this configuration please?

Paul Hutchings
Super Advisor

Could someone check this configuration please?

I have 3 Procurve switches each connected to each other to form a redundant loop.

Everything appears to work however I'm seeing some funny stuff going on with arp caching and vsphere if I pull a switch to simulate a failure.

I'd really appreciate a sanity check that I'm not doing something stupid with the switch configuration.

All I need is a VLAN (100 in this instance) for iSCSI that is tagged/trunked so it spans all the switches.

Site A Startup configuration:

; J9145A Configuration Editor; Created on release #W.14.49

hostname "Site A P4000 2910al"
module 1 type J9145A
module 2 type J9008A
interface 1
flow-control
exit
interface 2
flow-control
exit
interface 3
flow-control
exit
interface 4
flow-control
exit
interface 5
flow-control
exit
interface 6
flow-control
exit
interface 7
flow-control
exit
interface 8
flow-control
exit
interface 9
flow-control
exit
interface 10
flow-control
exit
interface 11
flow-control
exit
interface 12
flow-control
exit
interface 13
flow-control
exit
interface 14
flow-control
exit
interface 15
flow-control
exit
interface 16
flow-control
exit
interface 17
flow-control
exit
interface 18
flow-control
exit
interface 19
flow-control
exit
interface 20
flow-control
exit
interface 21
flow-control
exit
interface 22
flow-control
exit
interface 23
flow-control
exit
interface 24
flow-control
exit
interface A1
flow-control
exit
interface A2
flow-control
exit
ip default-gateway 10.65.254.254
ip arp-age 1
vlan 1
name "DEFAULT_VLAN"
untagged 1,13-22,24,A2
ip address 10.65.128.144 255.255.0.0
no untagged 2-12,23,A1
exit
vlan 100
name "iSCSI"
untagged 2-12,23
tagged A1
no ip address
exit
vlan 200
name "vMotion"
tagged 2-12,A1
no ip address
exit
vlan 666
name "no-use"
untagged A1
no ip address
exit
snmp-server community "public" unrestricted
spanning-tree
spanning-tree priority 0


------------------------------------

Site B Startup configuration:

; J9145A Configuration Editor; Created on release #W.14.49

hostname "Site B P4000 2910al"
module 1 type J9145A
module 2 type J9008A
interface 1
flow-control
exit
interface 2
flow-control
exit
interface 3
flow-control
exit
interface 4
flow-control
exit
interface 5
flow-control
exit
interface 6
flow-control
exit
interface 7
flow-control
exit
interface 8
flow-control
exit
interface 9
flow-control
exit
interface 10
flow-control
exit
interface 11
flow-control
exit
interface 12
flow-control
exit
interface 13
flow-control
exit
interface 14
flow-control
exit
interface 15
flow-control
exit
interface 16
flow-control
exit
interface 17
flow-control
exit
interface 18
flow-control
exit
interface 19
flow-control
exit
interface 20
flow-control
exit
interface 21
flow-control
exit
interface 22
flow-control
exit
interface 23
flow-control
exit
interface 24
flow-control
exit
interface A1
flow-control
exit
interface A2
flow-control
exit
ip default-gateway 10.65.254.254
vlan 1
name "DEFAULT_VLAN"
untagged 1,13-23,A2
ip address 10.65.128.143 255.255.0.0
no untagged 2-12,24-A1
exit
vlan 100
name "iSCSI"
untagged 2-12,24
tagged A1
no ip address
exit
vlan 200
name "vMotion"
tagged A1
no ip address
exit
vlan 666
name "no-use"
untagged A1
no ip address
exit
snmp-server community "public" unrestricted
spanning-tree
spanning-tree priority 4



--------------------------



Site C Startup configuration:

; J9279A Configuration Editor; Created on release #Y.11.16

hostname "Site C P4000 2510g"
snmp-server location "Site C"
interface 1
flow-control
exit
interface 2
flow-control
exit
interface 3
flow-control
exit
interface 4
flow-control
exit
interface 5
flow-control
exit
interface 6
flow-control
exit
interface 7
flow-control
exit
interface 8
flow-control
exit
interface 9
flow-control
exit
interface 10
flow-control
exit
interface 11
flow-control
exit
interface 12
flow-control
exit
interface 13
flow-control
exit
interface 14
flow-control
exit
interface 15
flow-control
exit
interface 16
flow-control
exit
interface 17
flow-control
exit
interface 18
flow-control
exit
interface 19
flow-control
exit
interface 20
flow-control
exit
interface 21
flow-control
exit
interface 22
flow-control
exit
interface 23
flow-control
exit
interface 24
flow-control
exit
ip default-gateway 10.65.254.254
sntp server 10.65.3.252
ip arp-age 1
timesync sntp
sntp unicast
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1,13-22
ip address 10.65.128.131 255.255.0.0
no untagged 2-12,23-24
exit
vlan 100
name "iSCSI"
untagged 2-12,23-24
exit
spanning-tree
3 REPLIES
Mohammed Faiz
Honored Contributor

Re: Could someone check this configuration please?

Hi,

Could you confirm what ports your switches are interlinked on?
Also, it's generally a good idea to tag vlans on switch-switch links and use untagged ports for just access ports.
Paul Hutchings
Super Advisor

Re: Could someone check this configuration please?

Sure,

A1 on Site A and A1 on Site B.

23 on Site A to 23 on Site C.

24 on Site B to 24 on Site C.

Thanks.

Mohammed Faiz
Honored Contributor

Re: Could someone check this configuration please?

Ok, well that looks fine as far as connectivity on VLAN 100 goes. Obviously you haven't got the same redundancy setup for VLAN 1.
When you say "pull a switch" are you powering off a whole switch or simulating a link failure?
What is the odd behaviour you experience?