Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Create VLAN Problem

Tendy_1
Occasional Visitor

Create VLAN Problem

Hi, everyone, it's my first time to come here.
Now I have 5406zl(J8697A) VLAN problem, hope you can help me.

Situation:
We have two companys, central company and remote company, they connect by MPLS VPN. Central company server IP: 10.10.168.X , Before create VLAN, default VLAN 6 can access Central server. And create VLAN 2, VLAN 3, VLAN 4, VLAN 5. However, except default VLAN 6, new VLANs cannot access Central server. I will paste my configuration below:

First, paste Router(CISCO 2610) configuration, it connect with ISP and act as CE router.

interface Ethernet0/0
ip address 10.15.0.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 10.0.0.50 255.255.255.252
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.15.0.254
ip route 10.10.0.0 255.255.0.0 10.0.0.49
ip route 10.15.0.0 255.255.0.0 10.15.0.254

Second, paste HP 5406zl(J8697A)configuration, it connect with CISCO Router and act as distrubute layer switch.

; J8697A Configuration Editor; Created on release #K.12.16

hostname "xhhx-switch"
max-vlans 2048
ip access-list extended "vlan10"
10 deny ip 10.15.10.0 0.0.0.255 10.15.2.0 0.0.0.255
20 deny ip 10.15.10.0 0.0.0.255 10.15.3.0 0.0.0.255
30 deny ip 10.15.10.0 0.0.0.255 10.15.4.0 0.0.0.255
40 deny ip 10.15.10.0 0.0.0.255 10.15.15.0 0.0.0.255
50 deny ip 10.15.10.0 0.0.0.255 10.15.16.0 0.0.0.255
60 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
exit
ip access-list extended "vlan3"
10 deny ip 10.15.3.0 0.0.0.255 10.15.4.0 0.0.0.255
20 deny ip 10.15.3.0 0.0.0.255 10.15.10.0 0.0.0.255
30 deny ip 10.15.3.0 0.0.0.255 10.15.15.0 0.0.0.255
40 deny ip 10.15.3.0 0.0.0.255 10.15.16.0 0.0.0.255
50 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
exit
ip access-list extended "vlan4"
10 deny ip 10.15.4.0 0.0.0.255 10.15.3.0 0.0.0.255
20 deny ip 10.15.4.0 0.0.0.255 10.15.10.0 0.0.0.255
30 deny ip 10.15.4.0 0.0.0.255 10.15.15.0 0.0.0.255
40 deny ip 10.15.4.0 0.0.0.255 10.15.16.0 0.0.0.255
50 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
exit
module 1 type J8702A
module 2 type J8706A
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged B1-B9,B11-B24
ip address 192.168.10.1 255.255.255.0
no untagged A1-A24,B10
exit
vlan 2
name "VLAN2"
untagged A13-A14
ip address 10.15.2.254 255.255.255.0
tagged A12,A23-A24,B1-B12
exit
vlan 3
name "VLAN3"
untagged A1-A10
ip address 10.15.3.254 255.255.255.0
tagged A23-A24,B1-B12
ip access-group "vlan3" vlan
ip access-group "vlan3" in
ip access-group "vlan3" out
exit
vlan 4
name "VLAN4"
ip address 10.15.4.254 255.255.255.0
tagged A23-A24,B1-B12
ip access-group "vlan4" vlan
ip access-group "vlan4" in
ip access-group "vlan4" out
exit
( omit )
vlan 6
name "VLAN6"
untagged A11-A12,A15-A22,A24
ip address 10.15.0.254 255.255.255.0
tagged A23,B1-B10
exit
ip route 0.0.0.0 0.0.0.0 10.15.5.254
ip route 10.10.0.0 255.255.0.0 10.15.0.254
spanning-tree

So, If enable VLAN 2,VLAN 3,VLAN 4,VLAN 5 can access Central server 10.10.168.X ,what steps can I do ? Thank you !

Maybe information not detail, if you want, I can add it later.
3 REPLIES
Pieter 't Hart
Honored Contributor

Re: Create VLAN Problem

you must ask the provider of your mpls network to add the new subnets.
if not the mpls network does not know where to forward these subnets to.

Pieter
Tendy_1
Occasional Visitor

Re: Create VLAN Problem

WOW, so it's trouble to do that ? Any methods can solve the problem without via provider ?
Pieter 't Hart
Honored Contributor

Re: Create VLAN Problem

You won't be able to resolve this without your ISP.
As it is routing (Layer-3) not switching (Layer-2), the MPLS network needs to know what subnets are used on both sides of the link.
If it doesn't you can route from your LAN to the MPLs router, but this won't know it must pass this traffic to the other office.

If you want to be set for future expansion you may consider reserving a larger "supernet" for both offices, so you only need to chnage the MPLS network once.
Like you allready do on your own router.

Apart from this I discovered a possible error in you switces config
>>>
vlan 6
name "VLAN6"
untagged A11-A12,A15-A22,A24
ip address 10.15.0.254 255.255.255.0
tagged A23,B1-B10
exit
ip route 0.0.0.0 0.0.0.0 10.15.5.254
ip route 10.10.0.0 255.255.0.0 10.15.0.254
spanning-tree
<<<
the switch points to itself (10.15.0.254 = vlan-6 address) as gateway for 10.10.0.0 subnet.
this must probably be 10.15.0.1?