Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Creating VLAN across two switches

Randy Saeks
Occasional Advisor

Creating VLAN across two switches

Hello.

I am looking to create a VLAN across two switches to isolate some traffic. What I ideally would like is a seperate IP'd VLAN (172.16 scheme, lets just say) with on Switch A trk2 (LACP) being on the same vlan as Switch B trk 1 (LACP).

The config files I have currently, are:

SWITCH A
=========
; J8773A Configuration Editor; Created on release #L.11.09

hostname "Maple MDF"
snmp-server contact "Randy Saeks"
module 1 type J8765A
module 2 type J8765A
module 3 type J8765A
module 4 type J8765A
module 5 type J8765A
module 7 type J9033A
module 8 type J8776A
interface E5
lacp Passive
exit
interface E6
lacp Passive
exit
interface E15
name "ag0"
lacp Passive
interface E16
name "ag0"
lacp Passive
exit
interface G3
name "SAN_Port_1"
exit
interface G4
name "SAN_Port_1"
exit
trunk G5-G6 Trk1 LACP
trunk G3-G4 Trk2 LACP
ip routing
timesync sntp
snmp-server community "public" Unrestricted
snmp-server host 192.168.201.128 "public"
snmp-server host 10.15.100.202 "public"
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24,B1-B24,C1-C24,D1-D24,E1-E24,G1-G2,G7-G24,H1-H4,Trk1-Trk2
ip address 10.15.1.10 255.255.0.0
ip igmp
exit
vlan 10
name "Storage"
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
banner motd "Access to Networking devices is logged. Unauthorized access will be handled in accordance with the AUP.
"
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
password manager


SWITCH B
========
; J4899B Configuration Editor; Created on release #H.10.45

hostname "Ma.IDF1"
snmp-server contact "Randy Saeks"
snmp-server location "Room 107"
time timezone -5
ip default-gateway 10.15.1.1
snmp-server community "public" Unrestricted
snmp-server host 10.16.14.21 "public"
snmp-server host 192.168.201.128 "public"
snmp-server host 10.15.100.202 "public"
vlan 1
name "DEFAULT_VLAN"
untagged 1-50
ip address 10.15.1.11 255.255.255.0
ip igmp
exit
vlan 10
name "Storage"
exit
no fault-finder bad-driver
no fault-finder bad-transceiver
no fault-finder bad-cable
no fault-finder too-long-cable
no fault-finder over-bandwidth
no fault-finder broadcast-storm
no fault-finder loss-of-link
no fault-finder duplex-mismatch-HDx
no fault-finder duplex-mismatch-FDx
banner motd "Access to networking devices is logged. Unauthorized access will be handled in accordance to the AUP.
"
password manager


I know on switch B I need to make the trunk, trk1, but once I have that done, how close am I?

Thanks!
1 REPLY
Yan Henrichon
Frequent Advisor

Re: Creating VLAN across two switches

Well Randy, you're almost there. As you said, you'll need to create the trunk to connect to your other switch.

Then create the vlan(s) you need. Once done, you have to TAG the vlan you want to pass through the trunk to the other switch. Let's say you have created VLAN 10.

Ex:
SWITCH A(vlan 10)# tagged trk2.

Then on SWITCH B:
SWITCH B(vlan 10)# tagged trk1.

REMEMBER: LACP trunks need to be coterminous. All ports used in the truck have to start from the same swithc and end to the other one.

Hope this helps.