Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Creating a Trunk/Tagged Vlan port

Ryrager
Occasional Visitor

Creating a Trunk/Tagged Vlan port

Hi All

Wer have a new 5406zl this is configured to have VLAN 1 and 90 passed through port A2 to a Cisco 2950 on port 1 on the 2950 switch.

This is all set however I can only seem to get Vlan 90 traffic passing between the 2 on that port? any ideas? Configs below.

The 2950 has ports 18,19,20,21 set to be VLAN 90 for our phones.

So we want A2 to be Tagged in both Vlan 1 and 90 on the 5406zl and want fa0/1 to be cisco trunked on Vlan 1 and 90.

Now why aren't they working as expected?

Thanks for any help.

Ryan

Procurve
------------
; J8697A Configuration Editor; Created on release #K.14.41

hostname "Core-Switch-1"
module 1 type J8705A
module 2 type J8705A
interface A2
name "Core-Switch-2"
exit
interface A20
name "AB07-SW1 - 50"
exit
interface A24
name "StrowanSW1 - 50"
exit
interface B23
name "Sci-Trunk"
exit
interface B24
name "Sci-Trunk"
exit
trunk B23-B24 Trk1 LACP
ip default-gateway 172.16.1.1
vlan 1
name "DEFAULT_VLAN"
untagged A1,A3-A19,A21-A23,B1-B22
ip address 172.16.4.45 255.255.0.0
tagged A2,A20,A24,Trk1
exit
vlan 90
name "Voice"
tagged A2,A20,A24,Trk1
voice
no ip address
exit
no ip ssh
snmp-server community "xxxxxx" unrestricted
snmp-server host 172.16.0.100 "public"
snmp-server contact "xxxxxxx" location "xxxxxx"
spanning-tree Trk1 priority 4



-----------------
Cisco 2950
------------------
Current configuration : 4394 bytes
!
! Last configuration change at 08:25:08 IDLE Fri Oct 9 2009
! NVRAM config last updated at 09:03:02 IDLE Fri Oct 9 2009
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service sequence-numbers
!
hostname Core-Switch-2
!
enable secret 5 xxxxxxx
!
clock timezone IDLE 12
ip subnet-zero
!
!
cluster commander-address 000c.857a.d400 member 2 name STAC vlan 1
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface Port-channel1
switchport mode access
!
interface Port-channel3
switchport mode access
!
interface FastEthernet0/1
description Core Link - A2
switchport trunk allowed vlan 1,90
switchport trunk pruning vlan none
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
!
interface FastEthernet0/2
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/3
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/4
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/5
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/6
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/7
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/8
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/9
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/10
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/11
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/12
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/13
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/14
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/15
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/16
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/17
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/18
switchport access vlan 90
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/19
switchport access vlan 90
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/20
switchport access vlan 90
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk

!
interface FastEthernet0/21
switchport access vlan 90
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/22
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/23
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/24
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/25
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface FastEthernet0/26
description Link to Prep_Library
switchport trunk pruning vlan none
switchport mode access
spanning-tree portfast trunk
!
interface Vlan1
ip address 172.16.4.28 255.255.0.0
no ip route-cache
!
ip default-gateway 172.16.1.1
ip http server
snmp-server community xxxxx RW
snmp-server location TC17 - Network Room
snmp-server contact xxxxxxxx
!
line con 0
exec-timeout 0 0
line vty 0 4
password xxxxxx
login
line vty 5 15
password xxxxxxx
login
!
ntp clock-period 17179765
ntp server 172.16.1.20 key 0 prefer
!
end


1 REPLY
Pieter 't Hart
Honored Contributor

Re: Creating a Trunk/Tagged Vlan port

I think your problem is that the Cisco doesn't expect vlan-1 to be tagged. Where the Procurve does.

The "native" vlan on the cisco must match the "untagged" on the procurve.
So untag vlan1 on the procurve or change the native vlan on the cisco so vlan1 is tagged there.

Some Cisco switches have a dot1q-all-tagged mode, don't know if the 2950 does...

suggestion : next time put config in attachement, makes the thread more readable.