Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP Relay Inter VLANs

Luigi Burga
Occasional Visitor

DHCP Relay Inter VLANs

I have two VLANs on the switch 3500CL.
The DHCP is located in the VLAN 10, and the clients are located in the VLAN 20.
I am having issues getting an IP address from my DHCP server.
Here is the report from sh dhcp-relay

HPProCurve1(config)# sh dhcp-relay
DHCP Relay Agent : Enabled
Option 82 : Enabled
Response validation : Disabled
Option 82 handle policy : append
Remote ID : mac


Client Requests Server Responses

Valid Dropped Valid Dropped
---------- ---------- ---------- ----------
123 0 0 0

Here is the switch configuration

hostname "HPProCurve1"
time timezone -5
mirror-port 43
interface 1
name "VLAN 10 UPLINK"
exit
interface 2
name "VLAN 20 UPLINK"
exit
ip default-gateway 192.168.1.69
ip routing
snmp-server community "public" Unrestricted
snmp-server host 192.168.1.233 "public"
vlan 1
name "DEFAULT_VLAN"
untagged 3-10,43-44
no ip address
no untagged 1-2,11-42,45-48
exit
vlan 10
name "CMC-LAN"
untagged 1,11-42,45-48
ip address 192.168.1.69 255.255.255.0
exit
vlan 20
name "CMC-MKT"
untagged 2
ip address 192.168.101.1 255.255.255.0
ip helper-address 192.168.1.3
exit
dhcp-relay option 82 append
ip route 192.168.2.0 255.255.255.0 192.168.1.254
ip route 192.168.3.0 255.255.255.0 192.168.1.254
ip route 192.168.5.0 255.255.255.0 192.168.1.254
ip route 192.168.6.0 255.255.255.0 192.168.1.254
ip route 192.168.7.0 255.255.255.0 192.168.1.254
ip route 192.168.8.0 255.255.255.0 192.168.1.254
ip route 192.168.9.0 255.255.255.0 192.168.1.254
ip route 192.168.10.0 255.255.255.0 192.168.1.254
ip route 192.168.11.0 255.255.255.0 192.168.1.254
ip route 192.168.12.0 255.255.255.0 192.168.1.254
ip route 192.168.13.0 255.255.255.0 192.168.1.254
ip route 192.168.14.0 255.255.255.0 192.168.1.254
ip route 192.168.13.0 255.255.255.0 192.168.1.254
ip route 192.168.14.0 255.255.255.0 192.168.1.254
ip route 192.168.15.0 255.255.255.0 192.168.1.254
ip route 192.168.16.0 255.255.255.0 192.168.1.254
primary-vlan 10
password manager
password operator
2 REPLIES
cenk sasmaztin
Honored Contributor

Re: DHCP Relay Inter VLANs

hi Luigi
you have dhcp server located in vlan 10 untag port and must be dhcp server nic default gateway address vlan 10 ip address

ip address 192.168.1.3
subnet mask 255.255.255.0
default gateway 192.168.1.69


cenk

cenk

cenk sasmaztin
Honored Contributor

Re: DHCP Relay Inter VLANs

and for vlan 20 member pc dhcp scobe must be default gateway address vlan 20 ip address

for example

scobe name: vlan 20
ip pool :192.168.101.10------250
subnet mask:255.255.255.0
default gateway:192.168.101.1

cenk
cenk