Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP SERVER AND VLAN IN HP SWITCHS

moise
Occasional Contributor

DHCP SERVER AND VLAN IN HP SWITCHS

hi all,

I use hp switchs with muliple vlan; 3 VLANs , vlan 2, vlan 3, vlan 4 i wanna configure a dhcp server in windows server 2008 to brodcast ip address in each vlan, for that i use 3 scopes:

VLAN 2: 10.30.60.11-10.30.60.244

VLAN3: 10.30.70.11-10.30.70.244

VLAN4: 10.30.100.11-10.30.100.244

in switch HP i configured:

vlan 2
name "VLAN2"

untagged A1,                                                            //this interface for dhcp server
tagged A2-A24,B1-B24
ip address 10.30.60.1 255.255.255.0
exit
vlan 3
name "VLAN3"
tagged A1-A24,B1-B24
ip address 10.30.70.1 255.255.255.0
ip helper-address 10.30.60.3
exit
vlan 4
name "VLAN4"
tagged A1-A24,B1-B24
ip address 10.30.100.1 255.255.255.0
ip helper-address 10.30.60.3
exit

the dhcp server is in VLAN2 with address 10.30.60.3 with this configruration

dhcp server brodcast address only in VLAN 2 .

what should i do to brodcast ip address in each vlan?

thanks, 

best regards

Moise

3 REPLIES
TerjeAFK
Respected Contributor

Re: DHCP SERVER AND VLAN IN HP SWITCHS

The "ip helper-address" command will forward DHCP requests (broadcast) from clients in vlan 3 and 4 to your DHCP-server as a unicast. As long as you have IP routing between the three VLANs (and no firewall policies denying the traffic) it should work.

If your DHCP server is connected to interface A1 you should not tag vlan 3 and 4 on that interface, only untagged vlan 2.

 

moise
Occasional Contributor

Re: DHCP SERVER AND VLAN IN HP SWITCHS

thnk you TerjeAFK, i have put port A1 as untagged only in Vlan2 , with that dhcp server broadcast address just in vlan 2 with 10.30.60.0/24 but didn't brodcast address in vlan 3 (10.30.70.0/24). in the dhcp server i defined 2 scope : first is 10.30.60.1-10.30.60.244 and second is 10.30.70.1-10.30.70.244. what is the problems? how can i active routing in hp switch?

best regards,

MM

TerjeAFK
Respected Contributor

Re: DHCP SERVER AND VLAN IN HP SWITCHS

The command is "ip routing"